Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(solved) Kernel-4.11.0 und Realtek 1220 Problem
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 56

PostPosted: Sat May 06, 2017 5:07 pm    Post subject: (solved) Kernel-4.11.0 und Realtek 1220 Problem Reply with quote

Hallo zusammen,

Hardware ist ein GA-AX370-Gaming K7 mit eine Ryzen 1700, einer R9 270X und 32 GB RAM. Einzige Hängepartie ist der 1220 Codec, der grundsätzlich erkannt wird, aber merkwürdige dmesg Botschaften produziert. Ich habe gefühlt alle Varianten der Kerneleinstellungen für den Sound durch und habe bei der Recherche bisher nichts verwertbares gefunden.

Ich habe mal alles zum Sound abgewählt und mich dann schrittweise vorgearbeitet.
Unter Alsa ist alles zu OSS, old Alsa API, verbose printk und debug deaktiviert.
Abgewählt sind Generic Sound devices, USB Sound devices, Alsa für SOC audio, x86 sound devices und natürlich das deprecated OSS.

PCI Sound devices ist nur gewählt, um unter HD-Audio weiter zu kommen, alle Devices unter PCI devices sind abgewählt.

HD Audio ist gewählt, um den snd_hda_intel als Grundlage zu haben.

Wird nichts weiter ausgewählt und kompiliert, kommt nach dem booten unter demesg nachvollziehbar die Meldung, dass kein Codec verknüpft ist.
Schalte ich jetzt "Build Realtek-HD audio codec support" dazu, gibt es folgende Meldungen:

[ 3.434939] snd_hda_codec_generic hdaudioC0D0: ignore pin 0x7, too many assigned pins
[ 3.434953] snd_hda_codec_generic hdaudioC0D0: ignore pin 0x9, too many assigned pins
[ 3.434966] snd_hda_codec_generic hdaudioC0D0: ignore pin 0xb, too many assigned pins
[ 3.434979] snd_hda_codec_generic hdaudioC0D0: ignore pin 0xd, too many assigned pins
[ 3.434981] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=0 (0x0/0x0/0x0/0x0/0x0) type:line
[ 3.434982] snd_hda_codec_generic hdaudioC0D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.434983] snd_hda_codec_generic hdaudioC0D0: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.434983] snd_hda_codec_generic hdaudioC0D0: mono: mono_out=0x0
[ 3.434984] snd_hda_codec_generic hdaudioC0D0: dig-out=0x3/0x5
[ 3.434985] snd_hda_codec_generic hdaudioC0D0: inputs:
[ 3.435374] input: HDA ATI HDMI HDMI as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input2
[ 3.435414] input: HDA ATI HDMI HDMI as /devices/pci0000:00/0000:00:03.1/0000:09:00.1/sound/card0/input3
[ 3.437532] random: fast init done
[ 3.444308] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC1220: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[ 3.444309] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.444310] snd_hda_codec_realtek hdaudioC1D0: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.444311] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 3.444312] snd_hda_codec_realtek hdaudioC1D0: dig-out=0x1e/0x0
[ 3.444313] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 3.444313] snd_hda_codec_realtek hdaudioC1D0: Mic=0x18
[ 3.444314] snd_hda_codec_realtek hdaudioC1D0: Line=0x1a
[ 3.455201] snd_hda_codec_realtek hdaudioC1D1: autoconfig for ALC1220: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:hp
[ 3.455202] snd_hda_codec_realtek hdaudioC1D1: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.455203] snd_hda_codec_realtek hdaudioC1D1: hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 3.455203] snd_hda_codec_realtek hdaudioC1D1: mono: mono_out=0x0
[ 3.455204] snd_hda_codec_realtek hdaudioC1D1: inputs:
[ 3.455205] snd_hda_codec_realtek hdaudioC1D1: Mic=0x1a
[ 3.460930] snd_hda_intel 0000:12:00.3: control 2:0:0:Master Playback Volume:0 is already present
[ 3.460933] snd_hda_intel 0000:12:00.3: control 2:0:0:Master Playback Switch:0 is already present
[ 3.460936] snd_hda_intel 0000:12:00.3: control 2:0:0:Loopback Mixing:0 is already present
[ 3.460937] snd_hda_intel 0000:12:00.3: control 2:0:0:Mic Playback Volume:0 is already present
[ 3.460939] snd_hda_intel 0000:12:00.3: control 2:0:0:Mic Playback Switch:0 is already present
[ 3.460941] snd_hda_intel 0000:12:00.3: control 2:0:0:Capture Volume:0 is already present
[ 3.460942] snd_hda_intel 0000:12:00.3: control 2:0:0:Capture Switch:0 is already present
[ 3.460944] snd_hda_intel 0000:12:00.3: control 2:0:0:Mic Boost Volume:0 is already present

[ 3.462332] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input4
[ 3.462372] input: HD-Audio Generic Line as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input5
[ 3.462409] input: HD-Audio Generic Line Out Front as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input6
[ 3.462449] input: HD-Audio Generic Line Out Surround as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input7
[ 3.462485] input: HD-Audio Generic Line Out CLFE as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input8
[ 3.462521] input: HD-Audio Generic Mic as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input9
[ 3.462557] input: HD-Audio Generic Front Headphone as /devices/pci0000:00/0000:00:08.1/0000:12:00.3/sound/card1/input10

Unter der KDE Multimedia Einrichtung sind mit der Option erweiterte Geräte anzeigen, die 1220 Geräte zu sehen. Nur ansprechen lassen sie sich nicht und ohne erweiterte Geräte anzeigen gibt es gar nichts in der Anzeige. Kmix und alsamixer bieten nur device AMD HDMI an.

Gibt es Ideen oder muss weiter auf Kernelpatches gewartet werden?

edit:
Mit verschiedenen Live Distributionen sieht das alles vergleichbar aus. Nur dass der 1220 wegen älterer Kernel nicht erkannt wird und da generische Devices angelegt werden. Also identisch mit dem 4.10. Kernel.
Ich habe bei Gigabyte im AORUS Forum einen Post zu ALSA und dem AX370 Gaming K5 gefunden, wo auf den Support verwiesen wird. Ich nehme mal den gleichen Weg. Wenn es Erkenntnisse gibt, trage ich die nach.

edit2:
Wir geben keinen Support für ein freies Betriebssystem. Nun gut, als Workaround eine Sundblaster Xi-Fi PCIe-1x aus der Kramkiste eingesteckt und läuft.
solved also nicht wie gewollt

edit3
es wird - im Kernel 4.12. Gigabyte hat manchen Gamerboards zwei 1220 Chips spendiert. Einen für das IO Backpanel und einen für das Frontpanel. Der 2. Poster bei Bugzilla hatte auch die Frage im Gigabyteforum gestellt und dürfte genau wie ich "gescheitert" sein. Anbei der Link zum Kernel Bugzilla. Die Mühe mit dem 4.12-rc mache ich mir nicht, sondern warte auf die Veröffentlichung. Läuft ja erst mal mit der XiFi.

https://bugzilla.kernel.org/show_bug.cgi?id=195305


Gruß Demiurg
_________________
Kernel 4.12.xx-gentoo
GCC 6.4.0
Profile amd64/13.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F4
ATI 270X
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum