Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logging to gnome fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 368

PostPosted: Wed May 03, 2017 7:42 am    Post subject: Logging to gnome fails Reply with quote

I can't login to gnome anymore. Gdm starts fine, if i invoke a user the box spins for a while and then falls back to gdm login screen.

The one thing i can think of is that i played around with gnome extensions. Is there a way to switch them off from outside gnome? The behaviour affects all users, not just the one who enabled the extensions.
R.
Back to top
View user's profile Send private message
Shoaloak
n00b
n00b


Joined: 05 Nov 2016
Posts: 48

PostPosted: Wed May 03, 2017 12:42 pm    Post subject: Reply with quote

Gnome does start a new TTY when you log in.
Is there maybe a Xorg log?
And also check your journalctl for errors.
_________________
Happy hacking.
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 368

PostPosted: Wed May 03, 2017 1:13 pm    Post subject: Reply with quote

This is Xorg.2.log https://paste.pound-python.org/show/IYvkwtGD90n4KqWe65cA/ where I tried to run gnome, this isXorg.3.log
https://paste.pound-python.org/show/6h2u7LVXLVCaFRvrTHmd/ where plasma runs now.

The journal shows nothing I can read, the lines are prior to open a new shell an restarting gdm (reading order reversed):
Code:
Mai 03 10:06:30 eg-server login[1185]: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Mai 03 10:06:25 eg-server /usr/libexec/gdm-x-session[1436]: (II) systemd-logind: got pause for 13:66
Mai 03 10:06:25 eg-server /usr/libexec/gdm-x-session[1436]: (II) systemd-logind: got pause for 13:65
Mai 03 10:06:25 eg-server /usr/libexec/gdm-x-session[1436]: (II) systemd-logind: got pause for 13:67
Mai 03 10:06:25 eg-server /usr/libexec/gdm-x-session[1436]: (II) systemd-logind: got pause for 13:64
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: /etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- /etc/X1
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]:        line 26: '0/TextureSharpen=0' (Unrecognized attribute name).
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: ERROR: Error parsing configuration file '/home/rudi/.nvidia-settings-rc' o
Mai 03 10:05:46 eg-server org.a11y.atspi.Registry[1488]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Mai 03 10:05:46 eg-server org.a11y.Bus[1443]: Successfully activated service 'org.a11y.atspi.Registry'
Mai 03 10:05:46 eg-server org.a11y.Bus[1443]: Activating service name='org.a11y.atspi.Registry'
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: Successfully activated service 'org.a11y.Bus'
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: Activating service name='org.a11y.Bus'
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: Successfully activated service 'org.gtk.vfs.Daemon'
Mai 03 10:05:46 eg-server /usr/libexec/gdm-x-session[1436]: Activating service name='org.gtk.vfs.Daemon'
Mai 03 10:05:45 eg-server /usr/libexec/gdm-x-session[1436]: localuser:rudi being added to access control list
Mai 03 10:05:45 eg-server /usr/libexec/gdm-x-session[1436]: /etc/gdm/Xsession: Beginning session setup...


dmesg shows gnome is segfaulting
Code:
[   17.622541] nvidia-modeset: Allocated GPU:0 (GPU-3848791a-4b3d-e0e9-6315-0cb36d40dfaf) @ PCI:0000:01:00.0
[ 1281.789041] gnome-shell[1911]: segfault at 8 ip 00007f736fb79e40 sp 00007ffd799c9db8 error 4 in libmutter.so.0.0.0[7f736fb09000+133000]
[ 1284.639846] gnome-shell[2450]: segfault at 8 ip 00007f5516cb5e40 sp 00007fff3ddc0528 error 4 in libmutter.so.0.0.0[7f5516c45000+133000]
[ 1285.464123] gnome-session-f[2508]: segfault at 0 ip 00007fea29eed0a9 sp 00007ffc05ae7010 error 4 in libgtk-3.so.0.2200.12[7fea29bf4000+719000]
[ 1755.793523] gnome-shell[18579]: segfault at 8 ip 00007f9e5f5d4e40 sp 00007ffd432c3968 error 4 in libmutter.so.0.0.0[7f9e5f564000+133000]
[ 1759.492552] gnome-shell[19032]: segfault at 8 ip 00007fd68243ee40 sp 00007ffd5d09e958 error 4 in libmutter.so.0.0.0[7fd6823ce000+133000]
[ 1760.333426] gnome-session-f[19122]: segfault at 0 ip 00007fc83f1250a9 sp 00007ffc34220ee0 error 4 in libgtk-3.so.0.2200.12[7fc83ee2c000+719000]
Back to top
View user's profile Send private message
Shoaloak
n00b
n00b


Joined: 05 Nov 2016
Posts: 48

PostPosted: Sat May 06, 2017 9:17 am    Post subject: Reply with quote

Hmm the only segfault bug reference I can find is this one.
But since your setup used to work, it must be the extensions right? Or did you perhaps do an emerge upgrade?
_________________
Happy hacking.
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 368

PostPosted: Sat May 06, 2017 4:39 pm    Post subject: Reply with quote

frequently, but not between the last two reboots.
R.
Back to top
View user's profile Send private message
Shoaloak
n00b
n00b


Joined: 05 Nov 2016
Posts: 48

PostPosted: Sun May 07, 2017 11:08 am    Post subject: Reply with quote

Wallsandfences wrote:
frequently, but not between the last two reboots.
R.


Odd, then if I were you I'd first try to remove all extensions you meddled with using the command line.
Code:
per-user basis in ~/.local/share/gnome-shell/extensions/extension-uuid/
system wide basis in /usr/local/share/gnome-shell/extensions/extension-uuid/

so, e.g.
$ rm -rf ~/.local/share/gnome-shell/extensions/faulty-extension


If that doesn't work, maybe emerge yourself a clean gnome install?
_________________
Happy hacking.
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 368

PostPosted: Fri May 12, 2017 8:01 pm    Post subject: Reply with quote

It really were (on of) the extensions. Call me old fashioned, but I don't feel extensions should be able to segfault my de...

R.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum