Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installazione Driver Nvidia su Lenovo Y580
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Mon May 01, 2017 4:57 pm    Post subject: Reply with quote

genspx wrote:
scusa non avevo trascritto >= credevo fosse superfluo ora sto facendo di nuovo newuse e non mi da quell errore ... sta compilando i 14 pacchetti segnati...

Puoi ometterlo solo se non specifichi la versione
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 5:16 pm    Post subject: Reply with quote

fedeliallalinea wrote:
genspx wrote:
scusa non avevo trascritto >= credevo fosse superfluo ora sto facendo di nuovo newuse e non mi da quell errore ... sta compilando i 14 pacchetti segnati...

Puoi ometterlo solo se non specifichi la versione

grazie capito ...
purtroppo dopo aver compilato 4 dei 5 pacchetti non riesce a scaricare i driver dai server nvidia ... ho riprovato a emergere e niente fetch failed ... caspita.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Mon May 01, 2017 5:30 pm    Post subject: Reply with quote

Hai la connessione ad internet?
prova a fare un ping

Code:
ping -c3 www.google.it
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 5:37 pm    Post subject: Reply with quote

Maxxx wrote:
Hai la connessione ad internet?
prova a fare un ping

Code:
ping -c3 www.google.it


si si ho la connessione ... vi scrivo da qui .. ping ok ..
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Mon May 01, 2017 5:43 pm    Post subject: Reply with quote

Allora forse dipende dal repository... che hai nel file /etc/portage/repos.conf/gentoo.conf?
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 5:55 pm    Post subject: Reply with quote

Maxxx wrote:
Allora forse dipende dal repository... che hai nel file /etc/portage/repos.conf/gentoo.conf?


guarda mi sono scaricato i file dal sito ... e li ho messi nella directory ora sta installando ... speriamo bene ... cmq controllerò
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Mon May 01, 2017 6:06 pm    Post subject: Reply with quote

Il problema del download e' un bug.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 6:45 pm    Post subject: Reply with quote

allora .. ho installato i driver ... almeno sembra ... da lspci -k ora vedo

driver in uso : nvdia
kernel modules : nvidia_drm,nvidia ...

il problema ora è che nvidia-xconfig mi da comando non trovato ...
se do nvidia-settings si apre l utility ma di dice di settare x server con nvidia-xconfig...
non ho alcun file di configurazione per xorg solo 20opengl.conf ...
cosa posso fare ?!
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Tue May 02, 2017 6:47 am    Post subject: Reply with quote

genspx wrote:
il problema ora è che nvidia-xconfig mi da comando non trovato ...

Il pacchetto nvidia-drivers ha la use flag tools abilitata?

Se no per fare partire X puoi creare semplicemente il file /etc/X11/xorg.conf.d/01-nvidia.conf
Code:
Section "Device"
  Identifier   "Device0"
  Driver       "nvidia"
  Option       "NoLogo" "True"
EndSection

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Tue May 02, 2017 8:46 am    Post subject: Reply with quote

fedeliallalinea wrote:
genspx wrote:
il problema ora è che nvidia-xconfig mi da comando non trovato ...

Il pacchetto nvidia-drivers ha la use flag tools abilitata?

Se no per fare partire X puoi creare semplicemente il file /etc/X11/xorg.conf.d/01-nvidia.conf
Code:
Section "Device"
  Identifier   "Device0"
  Driver       "nvidia"
  Option       "NoLogo" "True"
EndSection


ho provato a inseriere il file ma al riavvio non trova nessuno schermo .. dentro la directory distfile non è presente alcun file Nvidia ...
il mio scopo sarebbe quello di avere le due schede switchabili tramite bbswitch cosi da poter scegliere l integrata in caso di mancanza di alimentazione da rete .
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Wed May 03, 2017 9:26 am    Post subject: Reply with quote

aggiornamento :

nvidia-xconfig funziona quando sono fuori x ... ma con i file di configurazione che crea .... con la parte identica per la scheda nvidia a quella che mi hai mandato , X non si avvia ...
dice che non trova lo schermo ...
ho anche disinstallato e i driver e ho notato un messaggio d errore riguardante qualcosa del kernel ... cmq i driver si sono ugualemente installati ....
Ma nei file di configurazione di x non dovrebbe esserci la voce anche per la scheda intel ? è la scheda intel che è collegata allo schermo non la nvidia ... forse per questo non trova
lo schermo ?
thx
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Wed May 03, 2017 9:43 am    Post subject: Reply with quote

Purtroppo non saprei dirti io ho installato bumblebee (che se non erro usa bbswitch) con primusrun.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Wed May 03, 2017 2:06 pm    Post subject: Reply with quote

Stando a questo, sembra che vada bene bumblebee.

Altrimenti prova a chiedere al forum internazionale.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Wed May 03, 2017 9:38 pm    Post subject: Reply with quote

Farò qualche altro tentativo appena avrò tempo grazie a tutti e due per la disponibilità .. per ora sono soddisfattissimo di questa distribuzione ... Sto cominciando ad usare awesome bhe che dire .. stupenda !
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sat May 06, 2017 1:38 pm    Post subject: Reply with quote

Aggiornamento ...
Non so in che modo ma sono riuscito a far funzionare primus .. ho installato e provato nexuis e la gtx funziona ...
ora ho installato steam attraverso layman ma quando lo lancio mi dice che manca la libreria libgl.so.1 .. sapete se è possibile installare questa libreria 32 bit ?
purtroppo non credo di aver installato un ambiente multilib ...
ho speranze ? 8O
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sat May 06, 2017 3:58 pm    Post subject: Reply with quote

Puoi postare l'errore esatto?
E il comando
Code:
$ primusrun glxinfo | grep nvidia -i

cosa ti ritorna (glxinfo lo trovi installando il pacchetto x11-apps/mesa-progs)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sat May 06, 2017 5:39 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare l'errore esatto?
E il comando
Code:
$ primusrun glxinfo | grep nvidia -i

cosa ti ritorna (glxinfo lo trovi installando il pacchetto x11-apps/mesa-progs)?


eccomi ..
Code:
server glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
OpenGL core profile version string: 4.5.0 NVIDIA 378.13
OpenGL core profile shading language version string: 4.50 NVIDIA
OpenGL version string: 4.5.0 NVIDIA 378.13
OpenGL shading language version string: 4.50 NVIDIA


quando parte il launcher mi dice :

you are missing the following 32-bit libraries,and Steam may not run:
libGL.so.1
failed to load steam.ui

ho provato qualche soluzione nei vari threads del forum ma niente da fare ... entrando nella cartella dove ci sono le librerie di steam in effetti è l unica che lampeggia in rosso (da terminale) ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sun May 07, 2017 7:33 am    Post subject: Reply with quote

genspx wrote:
ho provato qualche soluzione nei vari threads del forum ma niente da fare ... entrando nella cartella dove ci sono le librerie di steam in effetti è l unica che lampeggia in rosso (da terminale) ...

Puoi postare l'output di quella cartella con il comando
Code:
$ ls -l
:?:
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun May 07, 2017 10:19 am    Post subject: Reply with quote

fedeliallalinea wrote:
genspx wrote:
ho provato qualche soluzione nei vari threads del forum ma niente da fare ... entrando nella cartella dove ci sono le librerie di steam in effetti è l unica che lampeggia in rosso (da terminale) ...

Puoi postare l'output di quella cartella con il comando
Code:
$ ls -l
:?:


ls -l /.steam/bin
Code:


totale 317304
-rwxr-xr-x 1 ruokz ruokz   1426024 26 apr 01.55 chromehtml.so
-rwxr-xr-x 1 ruokz ruokz    259297 26 apr 01.55 crashhandler.so
-rwxr-xr-x 1 ruokz ruokz     13777 24 feb  2013 driverhelper.py
-rwxr-xr-x 1 ruokz ruokz    162660 26 apr 01.55 filesystem_stdio.so
-rwxr-xr-x 1 ruokz ruokz   7094534 26 apr 01.55 friendsui.so
-rwxr-xr-x 1 ruokz ruokz    224866 26 apr 01.55 gameoverlayrenderer.so
-rwxr-xr-x 1 ruokz ruokz      7116 26 apr 01.55 gameoverlayui
-rwxr-xr-x 1 ruokz ruokz   7704437 26 apr 01.55 gameoverlayui.so
-rwxr-xr-x 1 ruokz ruokz    201648 26 apr 01.55 libaudio.so
-rwxr-xr-x 1 ruokz ruokz   2515328 27 gen  2016 libavcodec.so.56
-rwxr-xr-x 1 ruokz ruokz    274532 11 ago  2015 libavformat.so.56
-rwxr-xr-x 1 ruokz ruokz    130544  8 ago  2015 libavresample.so.2
-rwxr-xr-x 1 ruokz ruokz    166732  8 ago  2015 libavutil.so.54
lrwxrwxrwx 1 ruokz ruokz        39  6 mag 15.45 libGL.so.1 -> /usr/lib/i386-linux-gnu/mesa/libGL.so.1
-rwxr-xr-x 1 ruokz ruokz   2673748  9 ago  2016 libicui18n.so
-rwxr-xr-x 1 ruokz ruokz  12237291  9 ago  2016 libicuuc.so
-rwxr-xr-x 1 ruokz ruokz    472576  5 dic 20.53 libmiles.so
-rwxr-xr-x 1 ruokz ruokz    287376 20 feb 23.14 libopenvr_api.so
-rwxr-xr-x 1 ruokz ruokz      6714 26 apr 01.55 liboverride.so
-rwxr-xr-x 1 ruokz ruokz   1000406 10 mar 01.13 libSDL2-2.0.so.0
-rwxr-xr-x 1 ruokz ruokz   4217996 18 gen  2014 libsteam.so
-rwxr-xr-x 1 ruokz ruokz    343640  8 ago  2015 libswscale.so.3
-rwxr-xr-x 1 ruokz ruokz    211352 26 apr 01.55 libtier0_s.so
-rwxr-xr-x 1 ruokz ruokz  11156651  9 ago  2016 libv8.so
-rwxr-xr-x 1 ruokz ruokz   4294550 26 apr 01.55 libvideo.so
-rwxr-xr-x 1 ruokz ruokz    328212 26 apr 01.55 libvstdlib_s.so
-rwxr-xr-x 1 ruokz ruokz    868080 19 mag  2014 libx264.so.142.crypt
-rwxr-xr-x 1 ruokz ruokz        32 17 apr  2014 libx264.so.142.md5
-rwxr-xr-x 1 ruokz ruokz     50688 22 nov 00.01 mssdsp.flt
-rwxr-xr-x 1 ruokz ruokz     35840 22 nov 00.01 mssmixer.mix
-rwxr-xr-x 1 ruokz ruokz     71168  2 mag  2014 mssmp3.asi
-rwxr-xr-x 1 ruokz ruokz     41472  2 mag  2014 mssogg.asi
-rwxr-xr-x 1 ruokz ruokz    152064  2 mag  2014 mssvoice.asi
drwxr-xr-x 2 ruokz ruokz      4096  6 mag 14.58 panorama
-rwxr-xr-x 1 ruokz ruokz   3369860 26 apr 01.55 serverbrowser.so
-rwxr-xr-x 1 ruokz ruokz   4687395 26 apr 01.55 steam
-rwxr-xr-x 1 ruokz ruokz  20554006 26 apr 01.55 steamclient.so
-rwxr-xr-x 1 ruokz ruokz     59633 26 apr 01.55 steam_monitor
-rwxr-xr-x 1 ruokz ruokz     69518 26 apr 01.55 steamoverlayvulkanlayer.so
drwxr-xr-x 6 ruokz ruokz      4096  6 mag 14.58 steam-runtime
-rwxr-xr-x 1 ruokz ruokz        55 20 feb 22.59 steam-runtime.checksum
drwx------ 4 ruokz ruokz      4096 24 nov 03.18 steam-runtime.old
-rw-r--r-- 1 ruokz ruokz 103884992  6 mag 14.58 steam-runtime.tar.xz
-rwxr-xr-x 1 ruokz ruokz  52428800 20 feb 22.59 steam-runtime.tar.xz.part0
-rwxr-xr-x 1 ruokz ruokz  51456192 20 feb 22.59 steam-runtime.tar.xz.part1
-rwxr-xr-x 1 ruokz ruokz   3445658 26 apr 01.55 steamservice.so
-rwxr-xr-x 1 ruokz ruokz  20590636 26 apr 01.55 steamui.so
-rwxr-xr-x 1 ruokz ruokz   2710029 26 apr 01.55 streaming_client
-rwxr-xr-x 1 ruokz ruokz   2922245 26 apr 01.55 vgui2_s.so


ma credo di aver creato il io link seguendo un post ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21362
Location: here

PostPosted: Sun May 07, 2017 1:30 pm    Post subject: Reply with quote

Non conosco steam ma se il link e' la pista giusta devi farlo a una libreria esistente, nel mio sistema libGL.so si trova qua
Code:
$ locate libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so.1
/usr/lib32/opengl/nvidia/lib/libGL.so.381.09
/usr/lib32/primus/libGL.so.1
/usr/lib64/libGL.so
/usr/lib64/libGL.so.1
/usr/lib64/libGL.so.1.2.0
/usr/lib64/opengl/nvidia/lib/libGL.so
/usr/lib64/opengl/nvidia/lib/libGL.so.1
/usr/lib64/opengl/nvidia/lib/libGL.so.381.09
/usr/lib64/primus/libGL.so.1

Se vuoi provare sul tuo sistema installa sys-apps/mlocate e poi dai i comandi
Code:
# emerge sys-apps/mlocate
# updatedb <-- da root
$ locate libGL.so

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun May 07, 2017 3:35 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Non conosco steam ma se il link e' la pista giusta devi farlo a una libreria esistente, nel mio sistema libGL.so si trova qua
Code:
$ locate libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so.1
/usr/lib32/opengl/nvidia/lib/libGL.so.381.09
/usr/lib32/primus/libGL.so.1
/usr/lib64/libGL.so
/usr/lib64/libGL.so.1
/usr/lib64/libGL.so.1.2.0
/usr/lib64/opengl/nvidia/lib/libGL.so
/usr/lib64/opengl/nvidia/lib/libGL.so.1
/usr/lib64/opengl/nvidia/lib/libGL.so.381.09
/usr/lib64/primus/libGL.so.1

Se vuoi provare sul tuo sistema installa sys-apps/mlocate e poi dai i comandi
Code:
# emerge sys-apps/mlocate
# updatedb <-- da root
$ locate libGL.so


ok ho installato mlocate

Code:
locate libGL.so
/home/ruokz/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/share/doc/nvidia-cg-toolkit/examples/Tools/trace/libGL.so.1.gz
/home/ruokz/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/share/doc/nvidia-cg-toolkit/examples/Tools/trace/libGL.so.1.gz
/usr/fakelib/amd64/libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so
/usr/lib32/opengl/nvidia/lib/libGL.so.1
/usr/lib32/opengl/nvidia/lib/libGL.so.378.13
/usr/lib64/libGL.so
/usr/lib64/libGL.so.1
/usr/lib64/libGL.so.1.2.0
/usr/lib64/opengl/nvidia/lib/libGL.so
/usr/lib64/opengl/nvidia/lib/libGL.so.1
/usr/lib64/opengl/nvidia/lib/libGL.so.378.13
/usr/lib64/primus/libGL.so.1


sto provando ln -s una di queste su ~/.steam/bin ma senza successo .. quando vado a fare ls sulla directory ~/.steam/bin la bibreria lampeggia sempre in rosso ... boh
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun May 07, 2017 4:10 pm    Post subject: Reply with quote

copiando da la libreria steam non da più l' errore della libreria mancante ma si blocca qui :
Code:

primusrun  steam
/home/ruokz/.local/share/Steam/steam.sh: riga 154: VERSION_ID: variabile non assegnata
/home/ruokz/.local/share/Steam/steam.sh: riga 154: VERSION_ID: variabile non assegnata
Running Steam on gentoo  64-bit
STEAM_RUNTIME is enabled by the user
Installing breakpad exception handler for appid(steam)/version(1493162727)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum