Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installazione Driver Nvidia su Lenovo Y580
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun Apr 30, 2017 12:14 pm    Post subject: Installazione Driver Nvidia su Lenovo Y580 Reply with quote

Salve .. ho da poco installato Gentoo sul mio portatile Lenovo y580 ..
Sono molto soddifatto del sistema e vorrei installare i driver proprietari per poter giocare ogni tanto a CS il nuovo Doom e compagnia bella ...
Il sistema ha 2 schede video , una integrata HD4000 che sta funzionando col driver intel 915... e l altra è una ottima gtx660m che usa il driver fb,nouveau ...
Ho letto diversi howto ma ho dei dubbi : in origine ho compilato con genkernel (vga nvidia disabilitata da bios) e ho i moduli abilitati per tutte e due le schede ...
E' necessario ricompilare il kernel per togliere i vari frame buffer ( purtroppo non l ho fatto durante l installazione ) ...
E' consigliabile togliere anche il modulo noveau dal kernel ?
Sarà poi possibile avere il supporto alle api Vulkan (necessario per doom)?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sun Apr 30, 2017 2:49 pm    Post subject: Reply with quote

Ciao, io ho la GTX 1070. Nel mio kernel ho disabilitato i frame buffers Nvidia e tutti i moduli nouveau, dopodichè ho compilato i driver Nvidia.
Comunque l'impostazione del kernel indispensabile per le GPU Nvidia la trovi su

https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers/it

Per quanto riguarda le API Vulkan credo che dovrebbero essere incluse nei driver stessi.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sun Apr 30, 2017 3:23 pm    Post subject: Reply with quote

C'e' anche la possibilita' di avere nvidia e Nouveau decidendo al boot cosa scegliere.
La guida la trovi qua
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun Apr 30, 2017 4:12 pm    Post subject: Reply with quote

Maxxx wrote:
Ciao, io ho la GTX 1070. Nel mio kernel ho disabilitato i frame buffers Nvidia e tutti i moduli nouveau, dopodichè ho compilato i driver Nvidia.
Comunque l'impostazione del kernel indispensabile per le GPU Nvidia la trovi su

https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers/it

Per quanto riguarda le API Vulkan credo che dovrebbero essere incluse nei driver stessi.


Bhe ho letto questa guida ma io ho già installato xorg ecc ... qui dice di reinstallare tutto ... il mio problema poi è che ho 2 vga ... la integrata e la discreta Nvidia ... vorrei poter switchare fra le due cosi da usare la integrata intel hd4000 quando sono fuori (per questioni di autonomia ) e la Nvidia solo per giochi e applicazione grafiche quando sono in casa ...
Su altre distribuzioni ho questa possibilità attraverso il pannello nvidia-settings si ha la possibilità di scegliere fra le due interfacce grafiche .. previo logout ....
Mi chiedo solo se sia meglio installare tutto da zero creando un kernel adatto e installare xorg con le dovute use flags

@fedelliallalinea : purtroppo i driver nouveau non mi consentono di giocare ... l ottimo per me sarebbe intel + nvidia ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sun Apr 30, 2017 5:01 pm    Post subject: Reply with quote

Io sul mio portatile ho configurato bumblebee con primusrun.
Praticamente quando voglio lanciare qualche programma che usi nvidia lo lancio con primusrun.
Trovi la guida qua (cerca il titolo Configurazione Intel/NVIDIA con Bumblebee e primus)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Sun Apr 30, 2017 9:48 pm    Post subject: Reply with quote

genspx wrote:

Bhe ho letto questa guida ma io ho già installato xorg ecc ... qui dice di reinstallare tutto ...


Perché devi reinstallare tutto? Devi ricompilare il kernel e compilare i drivers Nvidia.
Successivamente:

Code:
nvidia-xconfig


e

Code:
eselect opengl set nvidia
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun Apr 30, 2017 10:16 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Io sul mio portatile ho configurato bumblebee con primusrun.
Praticamente quando voglio lanciare qualche programma che usi nvidia lo lancio con primusrun.
Trovi la guida qua (cerca il titolo Configurazione Intel/NVIDIA con Bumblebee e primus)


ho letto la tua guida e mi sembra di capire che devo cmq cominciare da 0 ... compilare il kernel con le giuste opzioni :no frame buffers, no nouveau driver ecc
poi (dalla wiki di nvidia driver/xorg) devo compilare xorg con le use flags nvidia intel ...
Ho letto anche un wiki per ottenere optimus su gentoo ... cioè un sistema che usa la scheda nvidia e praticamente visualizza tramite l integrata [url] https://wiki.gentoo.org/wiki/NVIDIA/Optimus [/url]

appena ho tempo proverò ...
thx
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Sun Apr 30, 2017 10:41 pm    Post subject: Reply with quote

quote="Maxxx"]
genspx wrote:

Bhe ho letto questa guida ma io ho già installato xorg ecc ... qui dice di reinstallare tutto ...


Perché devi reinstallare tutto? Devi ricompilare il kernel e compilare i drivers Nvidia.
Successivamente:

Code:
nvidia-xconfig


e

Code:
eselect opengl set nvidia
[/quote]

non sono molto ferrato ancora sull argomento ... proverò a capire qualcosa ... ho usato genkernel -menuconfig all per l installazione ... ho solo spuntato qualche driver non riconosciuto ...
;)
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 11:40 am    Post subject: Reply with quote

As esempio non mi è chiaro in /usr/src/ ho due directory : linux e linux-4-9-16 ... in quale delle due devo dare make config per modificare il kernel ...
Dando poi make && make modules_install mi creera un nuovo kernel da copiare in /boot giusto ?
Potrei usare genkernel all per automatizzare l installazione del nuovo kernel ?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Mon May 01, 2017 12:25 pm    Post subject: Reply with quote

Prima dai

Code:
eselect kernel list


Vedi l'asterisco su quale kernel é... Probabilmente é già sul 4.9.16.
Altrimenti dai

Code:
eselect kernel set [numero]


Per impostare il kernel giusto.
A questo punto il make config lo dai su /usr/src/linux, che già punta al 4.9.16
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 1:44 pm    Post subject: Reply with quote

Maxxx wrote:
Vedi l'asterisco su quale kernel é... Probabilmente é già sul 4.9.16.

Ho puoi anche vedere con uname -a
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 2:07 pm    Post subject: Reply with quote

mah sicuro di fare un casino e dover ricominciare da parted ho lanciato genkernel menuconfig all ... ho riavviato ed effettivamente ora da lspci -k non vedo più i moduli nouveau e fb ... forse ho qualche speranza ... ora sto emergendo i driver nvidia proprietari ma ho questo pacchetto mascherato
[quote]

ho questo problema ora mentre installo i driver
Quote:
x11-libs/libXext-1.3.2::gentoo (Change USE: +abi_x86_32)
000097 - x11-drivers/nvidia-drivers-378.13::gentoo (Change USE: -abi_x86_32)
000098 (dependency required by "x11-drivers/nvidia-drivers-378.13::gentoo" [ebuild])
000099 (dependency required by "x11-drivers/nvidia-drivers" [argument])

devo mica impostare la flag -abi x86 32 per il pacchetto libXext?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 2:31 pm    Post subject: Reply with quote

genspx wrote:
Quote:
x11-libs/libXext-1.3.2::gentoo (Change USE: +abi_x86_32)
000097 - x11-drivers/nvidia-drivers-378.13::gentoo (Change USE: -abi_x86_32)
000098 (dependency required by "x11-drivers/nvidia-drivers-378.13::gentoo" [ebuild])
000099 (dependency required by "x11-drivers/nvidia-drivers" [argument])

devo mica impostare la flag -abi x86 32 per il pacchetto libXext?

Puoi postare tutto l'output? Hai tolto la use flag abi x86 32 a nvidia-drivers?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 2:55 pm    Post subject: Reply with quote

fedeliallalinea wrote:
genspx wrote:
Quote:
x11-libs/libXext-1.3.2::gentoo (Change USE: +abi_x86_32)
000097 - x11-drivers/nvidia-drivers-378.13::gentoo (Change USE: -abi_x86_32)
000098 (dependency required by "x11-drivers/nvidia-drivers-378.13::gentoo" [ebuild])
000099 (dependency required by "x11-drivers/nvidia-drivers" [argument])

devo mica impostare la flag -abi x86 32 per il pacchetto libXext?

Puoi postare tutto l'output? Hai tolto la use flag abi x86 32 a nvidia-drivers?



Allora quando provo ha emergere i driver ottengo questo ...
Code:
000001 *** emerge --nospinner --noreplace x11-drivers/nvidia-drivers ***
000002
000003  * IMPORTANT: 13 news items need reading for repository 'gentoo'.
000004  * Use eselect news read to view new items.
000005
000006 Calculating dependencies  .... done!
000007 [ebuild  N     ] sys-power/acpid-2.0.28  USE="(-selinux)"
000008 [ebuild  N     ] virtual/linux-sources-3  USE="-firmware"
000009 [ebuild   R    ] sys-libs/zlib-1.2.11  ABI_X86="32*"
000010 [ebuild   R    ] x11-proto/xproto-7.0.31  ABI_X86="32*"
000011 [ebuild   R    ] x11-proto/xextproto-7.3.0  ABI_X86="32*"
000012 [ebuild   R    ] x11-proto/inputproto-2.3.2  ABI_X86="32*"
000013 [ebuild   R    ] x11-proto/kbproto-1.0.7  ABI_X86="32*"
000014 [ebuild   R    ] dev-libs/libpthread-stubs-0.3-r1  ABI_X86="32*"
000015 [ebuild   R    ] x11-proto/xf86bigfontproto-1.2.0-r1  ABI_X86="32*"
000016 [ebuild  N     ] dev-libs/jansson-2.9  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
000017 [ebuild   R    ] x11-libs/libXau-1.0.8  ABI_X86="32*"
000018 [ebuild   R    ] x11-libs/libXdmcp-1.1.2-r1  ABI_X86="32*"
000019 [ebuild  N     ] app-eselect/eselect-opencl-1.1.0-r1
000020 [ebuild   R    ] x11-proto/xcb-proto-1.12-r2  ABI_X86="32*"
000021 [ebuild   R    ] x11-libs/libxcb-1.12-r2  ABI_X86="32*"
000022 [ebuild   R    ] x11-libs/libX11-1.6.5  ABI_X86="32*"
000023 [ebuild   R    ] x11-libs/libXext-1.3.3  ABI_X86="32*"
000024 [ebuild   R    ] x11-libs/libvdpau-1.1.1  ABI_X86="32*"
000025 [ebuild  N     ] x11-drivers/nvidia-drivers-378.13  USE="X acpi driver kms multilib tools -compat -gtk3 -pax_kernel -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)"
000026
000027 The following USE changes are necessary to proceed:
000028  (see "package.use" in the portage(5) man page for more details)
000029 # required by x11-libs/libX11-1.6.5::gentoo
000030 # required by x11-libs/libXext-1.3.3::gentoo
000031 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000032 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000033 # required by x11-drivers/nvidia-drivers (argument)
000034 >=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32
000035 # required by x11-libs/libX11-1.6.5::gentoo
000036 # required by x11-libs/libXext-1.3.3::gentoo
000037 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000038 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000039 # required by x11-drivers/nvidia-drivers (argument)
000040 >=x11-proto/inputproto-2.3.2 abi_x86_32
000041 # required by x11-libs/libvdpau-1.1.1::gentoo
000042 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000043 # required by x11-drivers/nvidia-drivers (argument)
000044 >=x11-libs/libX11-1.6.5 abi_x86_32
000045 # required by x11-libs/libXext-1.3.3::gentoo
000046 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000047 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000048 # required by x11-drivers/nvidia-drivers (argument)
000049 >=x11-proto/xextproto-7.3.0 abi_x86_32
000050 # required by x11-libs/libXau-1.0.8::gentoo
000051 # required by x11-libs/libxcb-1.12-r2::gentoo
000052 # required by x11-libs/libX11-1.6.5::gentoo
000053 # required by x11-libs/libXext-1.3.3::gentoo
000054 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000055 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000056 # required by x11-drivers/nvidia-drivers (argument)
000057 >=x11-proto/xproto-7.0.31 abi_x86_32
000058 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000059 # required by x11-drivers/nvidia-drivers (argument)
000060 >=x11-libs/libvdpau-1.1.1 abi_x86_32
000061 # required by x11-libs/libX11-1.6.5::gentoo
000062 # required by x11-libs/libXext-1.3.3::gentoo
000063 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000064 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000065 # required by x11-drivers/nvidia-drivers (argument)
000066 >=x11-proto/kbproto-1.0.7 abi_x86_32
000067 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000068 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000069 # required by x11-drivers/nvidia-drivers (argument)
000070 >=x11-libs/libXext-1.3.3 abi_x86_32
000071 # required by x11-libs/libX11-1.6.5::gentoo
000072 # required by x11-libs/libXext-1.3.3::gentoo
000073 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000074 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000075 # required by x11-drivers/nvidia-drivers (argument)
000076 >=x11-libs/libxcb-1.12-r2 abi_x86_32
000077 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000078 # required by x11-drivers/nvidia-drivers (argument)
000079 >=sys-libs/zlib-1.2.11 abi_x86_32
000080 # required by x11-libs/libxcb-1.12-r2::gentoo
000081 # required by x11-libs/libX11-1.6.5::gentoo
000082 # required by x11-libs/libXext-1.3.3::gentoo
000083 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000084 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000085 # required by x11-drivers/nvidia-drivers (argument)
000086 >=x11-libs/libXau-1.0.8 abi_x86_32
000087 # required by x11-libs/libxcb-1.12-r2::gentoo
000088 # required by x11-libs/libX11-1.6.5::gentoo
000089 # required by x11-libs/libXext-1.3.3::gentoo
000090 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000091 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000092 # required by x11-drivers/nvidia-drivers (argument)
000093 >=dev-libs/libpthread-stubs-0.3-r1 abi_x86_32
000094 # required by x11-libs/libxcb-1.12-r2::gentoo
000095 # required by x11-libs/libX11-1.6.5::gentoo
000096 # required by x11-libs/libXext-1.3.3::gentoo
000097 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000098 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000099 # required by x11-drivers/nvidia-drivers (argument)
000100 >=x11-libs/libXdmcp-1.1.2-r1 abi_x86_32
000101 # required by x11-libs/libxcb-1.12-r2::gentoo
000102 # required by x11-libs/libX11-1.6.5::gentoo
000103 # required by x11-libs/libXext-1.3.3::gentoo
000104 # required by x11-libs/libvdpau-1.1.1::gentoo[dri]
000105 # required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
000106 # required by x11-drivers/nvidia-drivers (argument)
000107 >=x11-proto/xcb-proto-1.12-r2 abi_x86_32
000108
000109 Use --autounmask-write to write changes to config files (honoring
000110 CONFIG_PROTECT). Carefully examine the list of proposed changes,
000111 paying special attention to mask or keyword changes that may expose
000112 experimental or unstable packages.
000113
000114 !!! All ebuilds that could satisfy ">=x11-libs/libX11-1.6.2:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.
000115 !!! One of the following masked packages is required to complete your request:
000116 - x11-libs/libX11-1.6.5::gentoo (masked by: )
000117
000118 (dependency required by "x11-libs/libXext-1.3.3::gentoo" [ebuild])
000119 (dependency required by "www-client/chromium-58.0.3029.19::gentoo" [installed])
000120 (dependency required by "@selected" [set])
000121 (dependency required by "@world" [argument])
000122 For more information, see the MASKED PACKAGES section in the emerge
000123 man page or refer to the Gentoo Handbook.
000124
000125 *** process completed ***


:)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 3:04 pm    Post subject: Reply with quote

Se non sei interessato al supporto 32 bit (ma se userai wine sarai obbligato a compilare alcuni pacchetti in 32bit tra cui anche i driver nvidia) , disabilita la use flag abi_x86_32
Code:
# echo "x11-drivers/nvidia-drivers -abi_x86_32" >> /etc/portage/package.use


Code:
!!! One of the following masked packages is required to complete your request:
x11-libs/libX11-1.6.5::gentoo (masked by: )

Hai mascherato questo pacchetto per caso? Puoi postare il risultato del comando emerge -pv x11-libs/libX11
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 3:22 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Se non sei interessato al supporto 32 bit (ma se userai wine sarai obbligato a compilare alcuni pacchetti in 32bit tra cui anche i driver nvidia) , disabilita la use flag abi_x86_32
Code:
# echo "x11-drivers/nvidia-drivers -abi_x86_32" >> /etc/portage/package.use


Code:
!!! One of the following masked packages is required to complete your request:
x11-libs/libX11-1.6.5::gentoo (masked by: )

Hai mascherato questo pacchetto per caso? Puoi postare il risultato del comando emerge -pv x11-libs/libX11


non credo di aver mascherato il pacchetto .. il risultato è

Code:
USE="ipv6 -doc-static-libs {-test}" ABI_X86="(64) -32 (-x32)" kiB


eh si avrei bisogno anche si wine ...


Last edited by genspx on Mon May 01, 2017 3:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 3:35 pm    Post subject: Reply with quote

Ok ma vuoi avere il supporto a 32bit?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 3:38 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Ok ma vuoi avere il supporto a 32bit?


si per Wine
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 3:48 pm    Post subject: Reply with quote

Ok allora aggiungi i seguenti pachetti al file /etc/portage/package.use
Code:
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/inputproto-2.3.2 abi_x86_32
# required by x11-libs/libvdpau-1.1.1::gentoo
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libX11-1.6.5 abi_x86_32
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/xextproto-7.3.0 abi_x86_32
# required by x11-libs/libXau-1.0.8::gentoo
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/xproto-7.0.31 abi_x86_32
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libvdpau-1.1.1 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/kbproto-1.0.7 abi_x86_32
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libXext-1.3.3 abi_x86_32
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libxcb-1.12-r2 abi_x86_32
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=sys-libs/zlib-1.2.11 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libXau-1.0.8 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=dev-libs/libpthread-stubs-0.3-r1 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-libs/libXdmcp-1.1.2-r1 abi_x86_32
# required by x11-libs/libxcb-1.12-r2::gentoo
# required by x11-libs/libX11-1.6.5::gentoo
# required by x11-libs/libXext-1.3.3::gentoo
# required by x11-libs/libvdpau-1.1.1::gentoo[dri]
# required by x11-drivers/nvidia-drivers-378.13::gentoo[X]
# required by x11-drivers/nvidia-drivers (argument)
>=x11-proto/xcb-proto-1.12-r2 abi_x86_32

e installa nvidia-drivers.
Se libX11 da ancore il problema prova con
Code:
# emerge -1 libX11
# emerge nvidia-drivers

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 3:55 pm    Post subject: Reply with quote

Allora .. in etc/portage/ non ho il file package.use .. ho una directory con quel nome è lo stesso ? dentro c è solo un file vuoto : iputils ..
Non ho capito bene come inserire la lista di file ...
:x
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Mon May 01, 2017 4:09 pm    Post subject: Reply with quote

E' indifferente, o crei il file package.use su /etc/portage oppure crei un file che lo puoi chiamare come vuoi all'interno della cartella /etc/portage/package.use
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 4:11 pm    Post subject: Reply with quote

Si certo package.use puo' essere o un file o una directory.
Se e' una directory, come nel tuo caso, allora crea un file con qualsiasi nome (nominalo nvidia visto che e' per quello che lo crei).
La directory e' usata per avere piu' files per una questione di ordine e capire al volo a cosa si riferiscono
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 4:35 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Si certo package.use puo' essere o un file o una directory.
Se e' una directory, come nel tuo caso, allora crea un file con qualsiasi nome (nominalo nvidia visto che e' per quello che lo crei).
La directory e' usata per avere piu' files per una questione di ordine e capire al volo a cosa si riferiscono

ho creato il file nvidia ho messo tutte le librerie con la flag abi_x86_32 ma quando aggiorno il sistema con newuse mi da invali atom per tutte le linee aggiunte ..
ho seguito la guida per le useflag ho solo messo la libreria seguita dalla use ...

mi da invalid atom in /etc/portage/package.use/nvidia: x11-proto/xcb-proto-1.12-r2

nel file ho inserito x11-proto/xcb-proto-1.12-r2 abi_x86_32


Last edited by genspx on Mon May 01, 2017 4:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon May 01, 2017 4:39 pm    Post subject: Reply with quote

Puoi postare il contenuto del file?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genspx
n00b
n00b


Joined: 21 Apr 2017
Posts: 29

PostPosted: Mon May 01, 2017 4:52 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare il contenuto del file?


scusa non avevo trascritto >= credevo fosse superfluo ora sto facendo di nuovo newuse e non mi da quell errore ... sta compilando i 14 pacchetti segnati...
ora sta installando i driver ... ma non è riuscito alla fine a scaricarli dai server nvidia .... che fortuna


Last edited by genspx on Mon May 01, 2017 5:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum