Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unicode fonts and square symbols with codes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Fri Apr 28, 2017 5:42 pm    Post subject: Unicode fonts and square symbols with codes Reply with quote

Hello! I am trying to configure my system to support full unicode range. But firefox and emacs won't show some characters, replacing them with square symbols with codes.
locale is set to en_us.utf8
Code:

LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE=C
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=

media-fonts/noto is installed, but it changed nothing. Looks like it's not used.
Fontconfig list gives me:
Code:
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf
  [12]  20-unhint-small-dejavu-sans-mono.conf
  [13]  20-unhint-small-dejavu-sans.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf
  [19]  31-cantarell.conf
  [20]  40-nonlatin.conf *
  [21]  45-latin.conf
  [22]  49-sansserif.conf
  [23]  50-user.conf *
  [24]  51-local.conf *
  [25]  52-infinality.conf *
  [26]  57-dejavu-sans-mono.conf
  [27]  57-dejavu-sans.conf
  [28]  57-dejavu-serif.conf
  [29]  60-latin.conf
  [30]  60-liberation.conf *
  [31]  62-croscore-arimo.conf
  [32]  62-croscore-cousine.conf
  [33]  62-croscore-symbolneu.conf
  [34]  62-croscore-tinos.conf
  [35]  65-fonts-persian.conf
  [36]  65-khmer.conf
  [37]  65-nonlatin.conf *
  [38]  69-unifont.conf
  [39]  70-no-bitmaps.conf
  [40]  70-yes-bitmaps.conf
  [41]  80-delicious.conf
  [42]  90-synthetic.conf
  [43]  99pdftoopvp.conf

Thanks in advance!
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 782
Location: usually offline

PostPosted: Fri Apr 28, 2017 9:47 pm    Post subject: Re: Unicode fonts and square symbols with codes Reply with quote

Unb0rn wrote:
media-fonts/noto is installed, but it changed nothing. Looks like it's not used.

i removed media-fonts/noto, as it was doing nothing for me either. try media-fonts/symbola?


Last edited by josephg on Sat Apr 29, 2017 5:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Apr 29, 2017 12:52 am    Post subject: Reply with quote

Noto doesn't come with any fontconfig, you have to do it yourself:
Code:
  <alias>
    <family>serif</family>
    <prefer><family>Noto Serif</family></prefer>
  </alias>
  <alias>
    <family>sans-serif</family>
    <prefer><family>Noto Sans</family></prefer>
  </alias>
  <alias>
    <family>monospace</family>
    <accept><family>Noto Mono</family></accept>
    <accept><family>Noto Sans Mono CJK JP</family></accept>
  </alias>
Back to top
View user's profile Send private message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Sat Apr 29, 2017 9:39 am    Post subject: Reply with quote

Ant P. wrote:
Noto doesn't come with any fontconfig, you have to do it yourself:
Code:
  <alias>
    <family>serif</family>
    <prefer><family>Noto Serif</family></prefer>
  </alias>
  <alias>
    <family>sans-serif</family>
    <prefer><family>Noto Sans</family></prefer>
  </alias>
  <alias>
    <family>monospace</family>
    <accept><family>Noto Mono</family></accept>
    <accept><family>Noto Sans Mono CJK JP</family></accept>
  </alias>


And here comes the really noobish question... =) Should I add it to local.conf? Or create any other .conf? Do I need to disable every other .conf, except liberation and infinality? Ideally, main font should be liberation and Noto should be used as a fallback. Any guide? Gentoo wiki confused me a little. Thanks!
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Apr 29, 2017 9:02 pm    Post subject: Reply with quote

local.conf is fine. If you want programs to prefer Liberation fonts just put <accept> lines for those above the Noto ones.
Back to top
View user's profile Send private message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Sat Apr 29, 2017 9:05 pm    Post subject: Reply with quote

Applied changes to 51-local.conf and now fc-match displays that serif and sans serif are from Noto family-it didn't help. Still Firefox and emacs are displaying codes instead of characters...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum