Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nach gcc Update Problem mit gpgme [gelöst]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 334

PostPosted: Tue Apr 18, 2017 7:12 pm    Post subject: Nach gcc Update Problem mit gpgme [gelöst] Reply with quote

Nach dem GCC Update auf 5.4.0-r3 wollte ich die
Code:
 revdep-rebuild --library 'libstdc\+\+.so.6' -- --exclude gcc

ausführen. Gpgme meldete plötzlich eine Problem mit den Use-Flags. Wenn qt5 gesetzte ist sollte cxx mit gesetzt werden. CXX ist aber im Plasma Profil disabled. Und das qt5 Use-Flag für gpgme zu verbieten führt zu Problemen mit mit den den KDEPIM Anwendungen. Hat hier jemand eine Lösung? Auch ja, ich bin auf unstable was Plasma und den ganzen KF5 Krams angeht. :oops:
Danke


Last edited by deranonyme on Wed Apr 19, 2017 4:16 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3154
Location: Germany

PostPosted: Wed Apr 19, 2017 12:23 am    Post subject: Reply with quote

Ja, auf einem stable System sind die beiden Useflags app-crypt/gpgme[cxx qt5] im plasma Profil maskiert.
(schau dazu im /usr/portage/profiles/targets/desktop/plasma/package.use.stable.mask)

Wenn du die (zZt noch nicht stable) >=KDEPIM-Anwendungen-16.12.3:5 (zb kmail) nutzen möchtest,
dann wird app-crypt/gpgme[cxx qt5] benötigt.
Wenn du diese beiden Flags für das app-crypt/gpgme Paket demaskieren möchtest, dann mache das zb wie folgt:
Code:
mkdir -p /etc/portage/profile
echo "app-crypt/gpgme -cxx -qt5" >> /etc/portage/profile/package.use.mask
Damit sollten die Flags für dieses Paket demaskiert, und somit wieder nutzbar sein (für genaueres schaue dazu zb bitte auch im man portage).
Back to top
View user's profile Send private message
deranonyme
Guru
Guru


Joined: 09 Jul 2005
Posts: 334

PostPosted: Wed Apr 19, 2017 4:16 am    Post subject: Reply with quote

Danke, das hat geholfen. Ich musste den Pfad fürs demaskieren nur anpassen.
Code:
/etc/portage/profile/package.use.mask/gpgme
:D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum