Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Abandon] Portage EAPI5 to EAPI6 ??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 73

PostPosted: Thu Apr 13, 2017 2:19 pm    Post subject: [Abandon] Portage EAPI5 to EAPI6 ?? Reply with quote

Bonjour le forum ! ça faisait longtemps :D

Je suis entrain de vouloir update mon serveur de dev pour ajouter une couche Samba :

Quote:
Linux mythydev 3.18.11-gentoo #2 SMP Thu Apr 13 16:28:36 CEST 2017 x86_64 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz GenuineIntel GNU/Linux


Quand je veux installer Samba, il me dit ça :

Quote:
mythydev ~ # emerge -a samba
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!! line 6: News-Item-Format: 2.0

* IMPORTANT: config file '/etc/portage/package.use/vim' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=sys-libs/tevent-0.9.28[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/tevent-0.9.31-r1::gentoo (masked by: EAPI 6)
- sys-libs/tevent-0.9.28::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "net-fs/samba-4.2.14::gentoo" [ebuild])
(dependency required by "samba" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Du coup je veux update Portage, par contre on dirait qu'il y a eu pas mal de modifications sur Portage depuis, lorsque j'essaie de le mettre à jour pour pouvoir installer de nouveau paquet, il me dit ça :

Quote:
mythydev ~ # emerge -a portage
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!! line 6: News-Item-Format: 2.0

* IMPORTANT: config file '/etc/portage/package.use/vim' needs updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-python/certifi-2015.04.28[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/certifi-2017.1.23::gentoo (masked by: EAPI 6)
- dev-python/certifi-2016.9.26::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-python/setuptools-18.4::gentoo" [ebuild])
(dependency required by "dev-python/pyxattr-0.5.5::gentoo" [ebuild])
(dependency required by "sys-apps/portage-2.3.3::gentoo[python_targets_python2_7,xattr]" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Est ce qu'il y a une façon de faire pour update ça ? Ou bien je dois me retaper une full install ? :/

Merci d'avance !

PS: le make.conf au cas ou :

Quote:
mythydev ~ # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="python vim-syntax -X mmx sse sse2 -gtk -sdl -bindist"
MAKEOPTS="-j3"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
#SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"


Edit : ajout de la balise [Abandon]
_________________
Mythy'Zone - Blog technique / Jeux vidéos


Last edited by Mythy on Fri Apr 14, 2017 1:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Thu Apr 13, 2017 10:48 pm    Post subject: Reply with quote

Bonjour,

J'aurai tendance à penser que d'un point de vue strict du temps, ce sera plus rapide de faire une nouvelle installation :-)

Maintenant, en toute logique tu devrais réussir à mettre à jour ta distribution, déjà commencer par un etc-update vu qu'il te parle d'un fichier qui nécessite une MAJ (/etc/portage/package.use/vim). Une fois que c'est fait il va falloir s'occuper de ton histoire de python puis de portage, en tout cas ce sont les priorités avant samba.
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1660
Location: 127.0.0.1

PostPosted: Fri Apr 14, 2017 6:12 am    Post subject: Reply with quote

Salut,

Quote:

!!! All ebuilds that could satisfy ">=dev-python/certifi-2015.04.28[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/certifi-2017.1.23::gentoo (masked by: EAPI 6)
- dev-python/certifi-2016.9.26::gentoo (masked by: EAPI 6)

Pour mettre à jour portage, et éviter ce blocage tu peux essayer :
Code:

# USE="-xattr" emerge -avu1 portage

Une fois que c'est fait, tu devrais pouvoir continuer tes mises à jour normalement.
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 73

PostPosted: Fri Apr 14, 2017 7:29 am    Post subject: Reply with quote

Merci pour vos réponses !

En faite j'aimerais pas réinstaller car un pote m'avait installé tout un système sur ce serveur et j'aimerais pas le perdre, et ce pote n'a plus forcément le temps de s'occuper de ce genre de choses :/

Sinon j'ai fais un etc-update :

Quote:
mythydev ~ # etc-update
Scanning Configuration files...
The following is the list of files which need updating, each
configuration file is followed by a list of possible replacement files.
1) /etc/portage/package.use/vim (1)
2) /etc/ssh/sshd_config (1)
Please select a file to edit by entering the corresponding number.
(don't use -3, -5, -7 or -9 if you're unsure what to do)
(-1 to exit) (-3 to auto merge all files)
(-5 to auto-merge AND not use 'mv -i')
(-7 to discard all updates)
(-9 to discard all updates AND not use 'rm -i'): -3
Replacing /etc/portage/package.use/vim with /etc/portage/package.use/._cfg0000_vim
mv: overwrite '/etc/portage/package.use/vim'? y
Replacing /etc/ssh/sshd_config with /etc/ssh/._cfg0000_sshd_config
mv: overwrite '/etc/ssh/sshd_config'? y
Exiting: Nothing left to do; exiting. :)
mythydev ~ #
mythydev ~ #
mythydev ~ # etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)


Et j'ai testé la commande :

Code:
# USE="-xattr" emerge -avu1 portage


Mais ça n'a pas l'air de fonctionner non plus :

Quote:
mythydev ~ # USE="-xattr" emerge -avu1 portage
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!! line 6: News-Item-Format: 2.0

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-portage/elt-patches-20170317" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-portage/elt-patches-20170317::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-lang/python-3.4.5::gentoo" [ebuild])
(dependency required by "sys-apps/portage-2.3.3::gentoo[python_targets_python3_4,-build]" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Avant de poster sur le forum j'ai testé pas mal de choses, ou j'avais le même type de réponses, mais la situation semble désespéré :lol:
_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1660
Location: 127.0.0.1

PostPosted: Fri Apr 14, 2017 8:27 am    Post subject: Reply with quote

Si tu n'arrives pas à mettre à jour portage par les moyens classiques, dans le pire des cas tu peux utiliser cette procédure :
https://wiki.gentoo.org/wiki/Project:Portage/Fixing_broken_portage

Edit : en utilisant cette archive : http://distfiles.gentoo.org/distfiles/portage-2.3.3.tar.bz2
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 608
Location: S.O. France

PostPosted: Fri Apr 14, 2017 9:46 am    Post subject: Reply with quote

Comme DuF je pense que ce sera plus rapide une rénstall.
Sinon t'as la soluce de prendre les anciens snapchot et t'y vas petit à petit (mois par mois par exemple).
http://mexmat.sgu.ru/soft/Linux/distributions/gentoo/portage/

Tu peux poster emerge --info qu'on voit l'état de la bête...
Back to top
View user's profile Send private message
Mythy
n00b
n00b


Joined: 17 Jul 2012
Posts: 73

PostPosted: Fri Apr 14, 2017 1:49 pm    Post subject: Reply with quote

Merci pour vos réponses ;)

Alors finalement, vu que le but était de mettre 2 serveurs physiques en un, je voulais ajouter une couche Samba sur le serv de Dev

Mais vu que les 2 OS Gentoo sont dans le même état, bloqué en Portage EAPI5, je vais finalement garder les 2 serveurs physiques parce que je sens que je vais bien galérer à remettre en état Portage ^^'

Du coup j'ai clonezillé les 2 disques systèmes et je vais prier pour que le reste du matoss ne décède pas le temps que je réinstalle tout au propre, au pire une petite recompil de kernel devrait suffire :)

D'ailleurs j'ai du mixer un peu de matoss (eth/carte sata/cm) et j'ai déjà du recompiler le kernel, c'est fou comme Gentoo est souple de ce côté, contrairement à ce qui peut se dire ;)

Je met quand même le emerge --info, n'hésitez pas à me dire ce que vous en pensez !

Quote:
mythydev ~ # emerge --info
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.20-r2, 3.18.11-gentoo x86_64)
=================================================================
System uname: Linux-3.18.11-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-gentoo-2.2
KiB Mem: 4050604 total, 3385856 free
KiB Swap: 2097148 total, 2097148 free
Timestamp of repository gentoo: Fri, 14 Apr 2017 07:00:01 +0000
sh bash 4.2_p53
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash: 4.2_p53::gentoo
dev-lang/perl: 5.20.2::gentoo
dev-lang/python: 2.7.9-r1::gentoo, 3.3.5-r1::gentoo
dev-util/cmake: 2.8.12.2-r1::gentoo
dev-util/pkgconfig: 0.28-r2::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.13.11::gentoo
sys-apps/sandbox: 2.6-r1::gentoo
sys-devel/autoconf: 2.69::gentoo
sys-devel/automake: 1.13.4::gentoo
sys-devel/binutils: 2.24-r3::gentoo
sys-devel/gcc: 4.8.4::gentoo
sys-devel/gcc-config: 1.7.3::gentoo
sys-devel/libtool: 2.4.6::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc: 2.20-r2::gentoo
Repositories:

gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.gentoo.org/gentoo-portage
priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx modules multilib ncurses nls nptl openmp pam pcre python readline seccomp session sse sse2 ssl tcpd unicode vim-syntax xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
Mythy'Zone - Blog technique / Jeux vidéos
Back to top
View user's profile Send private message
ahpoblete
n00b
n00b


Joined: 05 Dec 2007
Posts: 2

PostPosted: Thu May 04, 2017 5:14 am    Post subject: N'actualiser que Portage Reply with quote

Bon soir,

Je n'ai pas sous la main un système dans un état similaire, mais, j'essayerais avec un emerge oneshot, comme voici:
Code:
emerge -av -1 portage

(ou, pareil)
Code:
emerge --ask --verbose --oneshot portage

Le paramètre --oneshot indiquera Portage de s'actualiser lui-même et que lui-même. Si tout a l'air d'être correct, il suffit d'appuyer sur la touche entrée pour accepter.

Dis-moi si ça marche bien, stp!

Salut.
_________________
If it moves, compile it!
Back to top
View user's profile Send private message
helecho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2016
Posts: 110

PostPosted: Thu May 04, 2017 6:25 am    Post subject: Reply with quote

ahpoblete wrote:
Le paramètre --oneshot indiquera Portage de s'actualiser lui-même et que lui-même.

man emerge wrote:
--oneshot (-1)
Emerge as normal, but do not add the packages to the world file for later updating.

WARNING: This option should only be used for packages that are reachable from the @world package set (those that would not be removed by --depclean), since dependencies of
unreachable packages are allowed to be broken when satisfying dependencies of other packages. Broken dependencies of this sort will invalidate assumptions that make it pos‐
sible for --deep to be disabled by default.


nouvelle édition : le passage suivant est erroné !

Lorsqu'on installe une version de Portage (sys-apps/portage) avec emerge --oneshot, Portage ne se basera pas sur cette version pour effectuer la prochaine mise à jour.
Prenons un exemple. On installe explicitement la version 2.3.3 de Portage avec --oneshot (emerge --oneshot =sys-apps/portage-2.3.3) sur un système utilisant la version 2.3.0.
On admet également (dans notre exemple) que la version 2.3.5 de Portage est disponible dans la "branche stable" de l'arborescence Portage. Finalement, on décide de
mettre à jour le système. Portage proposera la mise à jour de la version 2.3.0 (passage à la version 2.3.5) bien que la version de Portage installée récemment soit la version 2.3.3.


Remarque : Je crois malheureusement que le manuel nous renseigne partiellement sur les caractéristiques de l'option oneshot. Je n'ai toujours pas saisi comment cette option
pemettait de résoudre les conflits logiciels lors du processus d'installation :

"Often, it's advantageous to one-shot (--oneshot or -1) all of the conflicts at once because they sometimes depend on one another"

helecho.


Last edited by helecho on Thu May 04, 2017 6:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3012
Location: Paris

PostPosted: Thu May 04, 2017 9:42 am    Post subject: Reply with quote

helecho wrote:
Portage proposera la mise à jour de la version 2.3.0 (passage à la version 2.3.5) bien que la version de Portage installée récemment soit la version 2.3.3.

Huh? Pas sûr de bien te comprendre.


Sinon, à moins que je ne me goure sauvagement, l'option one-shot n'a pas pour but de résoudre un problème. Elle a pour but d'éviter d'en créer. Cela vous permet par exemple de recompiler un paquet B qui EST une dépendance d'un paquet A, sans ajouter B au world (ce qui aurait pour effet de rendre B générateur de dépendances à son tour).

Si jamais il est trop tard, que vous avez oublié d'utiliser --one-shot et que des saletés sont donc présentes dans votre world, vous n'avez plus qu'à aller le nettoyez à la main (opération à risque modéré, mais faites quand même attention).
_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
helecho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2016
Posts: 110

PostPosted: Thu May 04, 2017 11:32 am    Post subject: Reply with quote

El_Goretto wrote:
helecho wrote:
Portage proposera la mise à jour de la version 2.3.0 (passage à la version 2.3.5) bien que la version de Portage installée récemment soit la version 2.3.3.

Huh? Pas sûr de bien te comprendre.

Je me suis trompé. En fait, Portage met à jour la version 2.3.0 en la remplaçant par la version 2.3.3. Je croyais que les deux versions étaient installées en simultané.
En conséquence, j'ai fais un test avec elogviewer : [ebuild U ] app-portage/elogviewer-2.1-r1 [0.6.2-r3]. On constate que Portage propose de remplacer [ U ]
la version 0.6.2-r3 par la version 2.1-r1. Contrairement à ce que je pensais, le fichier /var/lib/portage/world n'indique pas les versions ("atom base" vs "atom version")
des logiciels installés.

El_Goretto wrote:
[...] l'option oneshot n'a pas pour but de résoudre un problème. Elle a pour but d'éviter d'en créer. [...]


Eh bien, je n'ai pas compris l'explication de l'article du Wiki ! Le contexte pourrait permettre de comprendre : il y a un conflit d'emplacement dû à deux versions d'un logiciel.
Avec plus d'information ou de pédagogie, dans l'article, on pourrait sûrement saisir facilement l'explication. Je suppose que l'option oneshot permet, dans cette situation, de
forcer la mise à jour du logiciel spécifié, automatiquement.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3012
Location: Paris

PostPosted: Thu May 04, 2017 1:11 pm    Post subject: Reply with quote

helecho wrote:
Je croyais que les deux versions étaient installées en simultané.

Ca, c'est le mécanisme des "slots" (ex: gcc, les sources noyaux, etc).

helecho wrote:
Contrairement à ce que je pensais, le fichier /var/lib/portage/world n'indique pas les versions ("atom base" vs "atom version") des logiciels installés.

Il peut, si. Tout dépend de ce que tu as donné à la commande emerge: un nom de paquet, ou un paquet + version spécifique.
_________________
-Gentoo hardened: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
helecho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2016
Posts: 110

PostPosted: Fri May 05, 2017 5:49 am    Post subject: Reply with quote

El_Goretto wrote:
[...]
helecho wrote:
Contrairement à ce que je pensais, le fichier /var/lib/portage/world n'indique pas les versions ("atom base" vs "atom version") des logiciels installés.

Il peut, si. Tout dépend de ce que tu as donné à la commande emerge: un nom de paquet, ou un paquet + version spécifique.

Non, le fichier world ne semble pas indiquer les versions des logiciels installés. J'ai effectué la vérification en installant une version spécifique d'un logiciel et
en regardant le contenu du fichier world.

man portage wrote:
/var/lib/portage/world Every time you emerge a package, the package that you requested is recorded here. Then when you run `emerge world -up`, the list of packages is read from this file.
Note that this does not mean that the packages that were installed as dependencies are listed here. For example, if you run `emerge mod_wsgi` and you do not have
apache already, then "www-apache/mod_wsgi" is recorded in the world file but "www-servers/apache" is not. For more information, review emerge(1).

Format:
- one DEPEND atom base per line

Example:
games-misc/fortune-mod-gentoo-dev
dev-libs/uclibc
app-cdr/cdemu


Les fichiers world des utilisateurs du fil de discussion n'ont aucune version logicielle spécifiée. Hum, intéressant !
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1660
Location: 127.0.0.1

PostPosted: Fri May 05, 2017 6:28 am    Post subject: Reply with quote

Et pourtant :
Quote:

# emerge -av =sys-kernel/gentoo-sources-4.9.16

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-kernel/gentoo-sources-4.9.16:4.9.16::gentoo USE="-build -experimental -symlink" 91 402 KiB

Total: 1 package (1 new), Size of downloads: 91 402 KiB

Would you like to merge these packages? [Yes/No] yes
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) sys-kernel/gentoo-sources-4.9.16::gentoo
>>> Installing (1 of 1) sys-kernel/gentoo-sources-4.9.16::gentoo
>>> Recording sys-kernel/gentoo-sources:4.9.16 in "world" favorites file...
>>> Jobs: 1 of 1 complete Load avg: 1.61, 0.81, 0.51
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

* GNU info directory index is up-to-date.
# grep gentoo /var/lib/portage/world
sys-kernel/gentoo-sources:4.9.16


helecho wrote:
El_Goretto wrote:
[...]
helecho wrote:
Contrairement à ce que je pensais, le fichier /var/lib/portage/world n'indique pas les versions ("atom base" vs "atom version") des logiciels installés.

Il peut, si. Tout dépend de ce que tu as donné à la commande emerge: un nom de paquet, ou un paquet + version spécifique.

Non, le fichier world ne semble pas indiquer les versions des logiciels installés. J'ai effectué la vérification en installant une version spécifique d'un logiciel et
en regardant le contenu du fichier world.

Si le logiciel en question n'est pas slotté, portage n'a aucun intérêt à conserver le numéro de version dans le fichier world.

Quote:

# emerge -av --noreplace =www-client/firefox-45.8.0

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB


* www-client/firefox

Would you like to add these packages to your world favorites? [Yes/No] yes
>>> Recording www-client/firefox in "world" favorites file...
# grep firefox /var/lib/portage/world
www-client/firefox
# emerge -av --deselect www-client/firefox
>>> Removing www-client/firefox from "world" favorites file...
Would you like to remove these packages from your world favorites? [Yes/No] yes
Back to top
View user's profile Send private message
helecho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2016
Posts: 110

PostPosted: Fri May 05, 2017 8:37 am    Post subject: Reply with quote

J'ai l'impression de revoir les même notions en boucle !

devmanual wrote:
Packages can support having multiple versions installed simultaneously. [...] Most packages have no need for slotting.

netfab wrote:
Si le logiciel en question n'est pas "slotté", Portage n'a aucun intérêt à conserver le numéro de version dans le fichier world.

Cette affirmation est discutable. On peut se demander comment Portage détermine la version d'un logiciel installé, afin de pouvoir le mettre à jour.

Merci d'avoir précisé, netfab !
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1660
Location: 127.0.0.1

PostPosted: Fri May 05, 2017 8:47 am    Post subject: Reply with quote

helecho wrote:

devmanual wrote:
Packages can support having multiple versions installed simultaneously. [...] Most packages have no need for slotting.

netfab wrote:
Si le logiciel en question n'est pas "slotté", Portage n'a aucun intérêt à conserver le numéro de version dans le fichier world.

Cette affirmation est discutable. On peut se demander comment Portage détermine la version d'un logiciel installé, afin de pouvoir le mettre à jour.

Tout est là :
Code:

$ ls -ld /var/db/pkg/www-client/*
drwxr-xr-x 2 root root 4096 25 avril 09:36 /var/db/pkg/www-client/firefox-45.8.0
drwxr-xr-x 2 root root 4096  4 mai   09:18 /var/db/pkg/www-client/google-chrome-58.0.3029.96
drwxr-xr-x 2 root root 4096 14 déc.  12:24 /var/db/pkg/www-client/links-2.14
drwxr-xr-x 2 root root 4096  9 janv. 14:37 /var/db/pkg/www-client/qarte-3.5.0
Back to top
View user's profile Send private message
helecho
Tux's lil' helper
Tux's lil' helper


Joined: 26 Dec 2016
Posts: 110

PostPosted: Fri May 05, 2017 3:04 pm    Post subject: Reply with quote

Je te remercies netfab pour ces renseignements !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum