Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new stage3 Error on NVIDIA DRIVER 340.102
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Tue Sep 19, 2017 7:06 am    Post subject: new stage3 Error on NVIDIA DRIVER 340.102 Reply with quote

ok i've a absolute new and clean stage3 installation
Profile is set to
kde/systemd

worldupdate and Kernel are compiled

and now i run in following error Failed to emerge x11-drivers/nvidia-drivers-340.102,

Code:

 * Found sources for kernel version:
 *     4.12.12-gentoo
 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-4.10
 * <sys-kernel/vanilla-sources-4.10
 *
 * You are free to utilize eapply_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 *
 * Do not file a bug report about this.
 *
 * Ch
.............

make[2]: Entering directory '/usr/src/linux-4.12.12-gentoo'
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
/bin/false)
....


Code:

....
/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-linux.h:199:2: error: #error "This driver requires the ability to change memory types!"
 #error "This driver requires the ability to change memory types!"
  ^
In file included from /var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-chrdev.c:15:0:
/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-linux.h: At top level:
In file included from /var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv.c:13:0:
/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-linux.h: At top level:
/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-linux.h:199:2: error: #error "This driver requires the ability to change memory types!"
 #error "This driver requires the ability to change memory types!"
  ^
/var/tmp/portage/x11-drivers/nvidia-drivers-340.102/work/kernel/nv-linux.h:199:2: error: #error "This driver requires the ability to change memory types!"
 #error "This driver requires the ability to change memory types!"
  ^




:roll: :roll: :roll:
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22312
Location: here

PostPosted: Tue Sep 19, 2017 7:15 am    Post subject: Reply with quote

Maybe you need patch for kernel 4.12
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Tue Sep 19, 2017 12:36 pm    Post subject: Reply with quote

i've downgraded my kernel to
Code:
 sys-kernel/gentoo-sources-4.9.49-r1

that works :D
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 431
Location: LB

PostPosted: Wed Sep 20, 2017 12:21 am    Post subject: Reply with quote

:cry: no the sys-kernel/gentoo-sources-4.9.49-r1 DOESN'T work
not with nvidia-drivers

so i downgraded again to version sys-kernel/gentoo-sources-4.4.87
this works with nvidia-drivers-340.*

:wink:

and such a thing in a new stage3 :roll:

but the next big thing looks even more like a bug
Code:
libtool: compile: ...o .libs/libcommon_la-dmrc.o
cc1: error: /arch/x86/include/uapi: No such file or directory [-Werror=missing-include-dirs]
cc1: error: /arch/x86/include/uapi: No such file or directory [-Werror=missing-include-dirs]
cc1: some warnings being treated as errors
..
make[2]: Leaving directory '/var/tmp/portage/x11-misc/lightdm-1.24.0/work/lightdm-1.24.0/common'

but thats another Problem and so i started this thread https://forums.gentoo.org/viewtopic-p-8120060.html#8120060
_________________
Never give up
WM : E16 layman -o https://raw.githubusercontent.com/mcclung/e16-overlay/master/repositories.xml -f -a e16-overlay
achim
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum