Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Sat Apr 01, 2017 6:38 pm    Post subject: Plasma Reply with quote

Hello! I am having a hard time installing ~amd64 version of Plasma due to conflicts.
I am running a no-multilib amd64 system on Gnome for some time.
After adding ~amd64 flag for plasma-meta and all of its' dependencies and running emerge -av --update --changed-use --deep, I am getting this: Link
My make.conf is: Link
Accept.keywords for Plasma is: Link
Any help is appreciated =)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6829
Location: Austria

PostPosted: Sat Apr 01, 2017 6:44 pm    Post subject: Re: Plasma Reply with quote

You realise it would be much easier to not mix amd64 with ~amd64?

Code:
You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.


Also, Plasma-5.9.4 requires >=Qt-5.7, so make sure to add *all* the necessary dev-qt/* package versions to package.keywords.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Unb0rn
n00b
n00b


Joined: 12 Jun 2012
Posts: 63

PostPosted: Sat Apr 01, 2017 7:33 pm    Post subject: Re: Plasma Reply with quote

Oh! That was it! Had to add qtwayland and linguist-tools to keywords and now it works! Thanks!
Regarding stable and "unstable" branches-I do understand that its not the best practice to mix them up, but it seems to be the only option for modern "ultrabooks"
I am running Gentoo on a Lenovo Yoga 3 Pro, which uses Core M on Broadwell-Y with HD Graphics 5300. When I installed Gentoo(not so long ago), it used gcc 4.9, Mesa 12, kernel 4.4 and a relatively old x-server with Intel's abandoned DDX driver, so it was all or nothing=) Now I'm running Gnome 3.22 on wayland, compiled with gcc 5.4 with latest stable kernel and mesa 17.0.3. And everything works fine so far... Would it be better to switch to ~amd64 branch fully? Or is it generally a bad idea to mess with unstable branch at all?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum