Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xfce, xfwm4-4.13.0, moving/resizing windows broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1564
Location: Germany

PostPosted: Fri Mar 31, 2017 5:41 am    Post subject: [SOLVED] Xfce, xfwm4-4.13.0, moving/resizing windows broken Reply with quote

Hi, since some recent updates I notice an issue that happens occasionally. Moving windows on Xfce is not possible. Using Alt+mouse I can move a window some pixel then it stops. Same issue when using window context menu -> Move.
Code:

     Mon Mar 20 11:43:25 2017 <<< x11-drivers/xf86-video-ati-7.8.0
     Mon Mar 20 11:43:30 2017 >>> x11-drivers/xf86-video-ati-7.9.0
     Tue Mar 21 09:24:51 2017 <<< xfce-base/xfwm4-4.12.3-r1
     Tue Mar 21 09:24:57 2017 >>> xfce-base/xfwm4-4.13.0

Doing xfwm4 --replace solves the issue for a short time, then it is there again.
Code:
$ xfwm4 --replace
/usr/share/themes/MurrinaNeoGraphite/gtk-2.0/gtkrc:52: Murrine configuration option "scrollbar_color" is no longer supported and will be ignored.
Waiting for current window manager (Xfwm4) on screen :2.0 to exit: Done
(xfwm4:31219): xfwm4-WARNING **: Unmanaged net_wm_state (window 0x140003b, atom "_NET_WM_STATE_FOCUSED")
(xfwm4:31219): xfwm4-WARNING **: Unmanaged net_wm_state (window 0x1400035, atom "_NET_WM_STATE_FOCUSED")
(xfwm4:31219): xfwm4-WARNING **: Unmanaged net_wm_state (window 0x1400004, atom "_NET_WM_STATE_FOCUSED")
(xfwm4:31219): Gdk-WARNING **: /var/tmp/portage/x11-libs/gtk+-2.24.31-r1/work/gtk+-2.24.31/gdk/x11/gdkproperty-x11.c:325 invalid X atom: 450

How can I debug that?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme


Last edited by Massimo B. on Fri Jun 09, 2017 11:45 am; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22319
Location: here

PostPosted: Fri Mar 31, 2017 5:44 am    Post subject: Reply with quote

Try to downgrade, one at a time, the packages xf86-video-ati and xfwm4 to even begin to understand if problem is one of these two package.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
v_2e
n00b
n00b


Joined: 28 Dec 2008
Posts: 21

PostPosted: Thu Apr 13, 2017 4:13 pm    Post subject: Reply with quote

I do not use the ATI drivers, but I experience the very same problem after upgrade. So, the cause is probably the xfwm4-4.13.0
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1564
Location: Germany

PostPosted: Wed Apr 26, 2017 5:34 am    Post subject: Reply with quote

Using xfce-base/xfwm4-4.13.0 here as well. Can someone reproduce this issue?
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Wed Apr 26, 2017 7:45 am    Post subject: Reply with quote

I remember reading something on the lines somewhere a few days ago, so I looked in the git and saw a commit related to that window hint.

https://git.xfce.org/xfce/xfwm4/commit/?id=84ef731d4ccf167886d4d2ed0557ebf8882105d7

Whether it's the one causing the problem, I can't really say, but there has been work related to that hint lately so it might be indicative of something.

For the time being, I suggest keeping the previous version of xfwm4.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1564
Location: Germany

PostPosted: Wed Apr 26, 2017 8:11 am    Post subject: Reply with quote

While filing a bug report on bugzilla.xfce.org I found there is already a report. It's exactly that issue, pressing CTRL+1 toggles the lock.
-> bug 616644
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1564
Location: Germany

PostPosted: Fri Jun 09, 2017 11:45 am    Post subject: Reply with quote

Setting to [SOLVED] as the reason is an upstream bug and there is the workaround to switch back to CTRL+1.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Anarchy
Developer
Developer


Joined: 29 Jun 2005
Posts: 135

PostPosted: Wed Apr 10, 2019 10:13 pm    Post subject: Reply with quote

Massimo B. wrote:
Setting to [SOLVED] as the reason is an upstream bug and there is the workaround to switch back to CTRL+1.


Code:
commit dc6a5562a06951cb3fbfab4595463c73af3e2d0d
Author: Michał Górny <mgorny@gentoo.org>
Date:   Wed Apr 10 09:59:50 2019 +0200

    xfce-base/xfwm4: Backport upstream fix for event mask length

    Closes: https://bugs.gentoo.org/664710
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

This should actually be completely fixed now that the event mask is set correctly.

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum