Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Totally disable hardware 3D acceleration, force software
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
UralZima
n00b
n00b


Joined: 04 Mar 2017
Posts: 9

PostPosted: Sat Mar 25, 2017 7:10 am    Post subject: Totally disable hardware 3D acceleration, force software Reply with quote

Hello. I want to boot with nouveau.no_accel=1, because nouveau freezes often on any 3D activity.

If I use 3D, every day twice I have total freeze of my GK106 with bunch of nouveau pgraph errors and only reset helps. Especially when a browser does some WebGL. No way to reload nouveau driver. And this is with blobs, without blobs it working much worst.

I want to use only software rendering (I know it's slow). Right now if I boot with this kernel arg, Plasma is not starting, because it needs opengl.

localhost # eselect mesa list
i915 (Intel 915, 945)
i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
r300 (Radeon R300-R500)
r600 (Radeon R600-R700, Evergreen, Northern Islands)
sw (Software renderer)
[1] classic
[2] gallium *

I don't see 'sw' in my list and didn't found any use flags related. How to switch any opengl activity to software rendering?
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Sat Mar 25, 2017 3:18 pm    Post subject: Reply with quote

Hi,

the kernel parameter must be nouveau.noaccel=1. You can use too nouveau.nofbaccel=1 too. For Xorg, you have to pass parameters to nouveau
Code:
man nouveau
...
Option "AccelMethod" "string"
              Specify the acceleration method. One of "none", or "exa". Default: exa.

       Option "NoAccel" "boolean"
              Disable or enable acceleration.  Default: acceleration is enabled.
...

I have this video card
Code:
lspci
...
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
...


It freeze sometime with nouveau when Seamonkey is the active window. Linux give me this message about missing firmware files after I have open an Xfce4 session:
Code:
[18775.554552] nouveau 0000:01:00.0: Direct firmware load for nouveau/nv106_fuc084 failed with error -2
[18775.554569] nouveau 0000:01:00.0: Direct firmware load for nouveau/nv106_fuc084d failed with error -2

All required firmware packages are installed but those files do not exist.
Code:
equery l *firmware*
 * Searching for *firmware* ...
[IP-] [  ] sys-firmware/nvidia-firmware-340.32:0
[IP-] [  ] sys-kernel/linux-firmware-20170314:0


I have enable and disable hardware acceleration in Seamonkey but this have change nothing. I use the ~amd64 versions of the gentoo-sources and xf86-video-nouveau. Xorg do not freeze often. I can ssh to Gentoo when it's happen. ArchLinux have the same problem too but Linux do not say there are missing firmware files.

I want to give full chances to nouveau to work properly. nouveau give me enough acceleration for what I do. I work to resolv the problem without disabling the hardware acceleration because there is no reason to not work with a recent video card.

I prefer to use an other video card than Nvidia instead of disabling the hardware acceleration or using the proprietary nvidia-drivers package. Some of the Nvidia card features need their signed drivers to work. The reverse engineering of the nouveau developpers have it's limit.
_________________
Paul
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Mar 25, 2017 7:21 pm    Post subject: Reply with quote

Why not use VESA? temporarily? videocards => vesa
Back to top
View user's profile Send private message
Leio
Developer
Developer


Joined: 27 Feb 2003
Posts: 480
Location: Estonia

PostPosted: Sat Mar 25, 2017 7:31 pm    Post subject: Re: Totally disable hardware 3D acceleration, force software Reply with quote

UralZima wrote:
localhost # eselect mesa list
i915 (Intel 915, 945)
i965 (Intel GMA 965, G/Q3x, G/Q4x, HD)
r300 (Radeon R300-R500)
r600 (Radeon R600-R700, Evergreen, Northern Islands)
sw (Software renderer)
[1] classic
[2] gallium *

I don't see 'sw' in my list and didn't found any use flags related. How to switch any opengl activity to software rendering?


These are the choices for software renderer... swrast (classic) or llvmpipe (gallium)...
There can be multiple classic/gallium choices, e.g if you had built i965 driver, you'd see "classic" for that too; or if had built for r600/radeonsi you'd see a "gallium" for that too - and if had built a 32bit mesa too via ABI_X86 then 32bit choices for all of those too. eselect mesa is showing them all, but you only have choices for sw. If you had more, then for "eselect mesa set" you'd have to potentially specify 32bit|64bit, <family> <architecture> etc, "eselect mesa" tells you all about it as help.
_________________
GNOME team lead; GStreamer; MIPS/ARM64
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sat Mar 25, 2017 7:58 pm    Post subject: Reply with quote

You can set LIBGL_ALWAYS_SOFTWARE to disable it per-program, e.g.:
Code:
 ~ $ LIBGL_ALWAYS_SOFTWARE=1 glxinfo -B
[...]
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)

If you're using Firefox, about:config -> webgl.disabled will let you turn that off while not making the rest of the browser run like molasses.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum