Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED][QtGui-5.7.1] Gtkstyle - qtstyleplugins?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 536

PostPosted: Sat Mar 25, 2017 3:56 am    Post subject: [SOLVED][QtGui-5.7.1] Gtkstyle - qtstyleplugins? Reply with quote

Hi

Since version 5.7.0 QtGui has no Gtkstyle theme, the module needed for this was moved to the Qtstyleplugins project.
https://code.qt.io/cgit/qt/qtstyleplugins.git/


I have not found an ebuild for qtstyleplugins, how to properly install these themes?

Cheers
8)

PS.
Sorry for my english. 8O

EDIT:
A few minutes after writing this post I found a working solution:
https://faase.org/Calrama/gestalt/blob/91760b608097bc7b99a7fa1c4d774da882c870d1/dev-qt/qt5-styleplugins/qt5-styleplugins-9999.ebuild
https://faase.org/Calrama/gestalt/raw/91760b608097bc7b99a7fa1c4d774da882c870d1/dev-qt/qt5-styleplugins/qt5-styleplugins-9999.ebuild

;)
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Fri May 19, 2017 3:12 pm    Post subject: Reply with quote

Thanks for the information. There is also x11-themes/qtstyleplugins::abendbrot (but I haven’t tried it as I’m still on Qt 5.6).
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Tue Dec 12, 2017 10:33 pm    Post subject: Re: [SOLVED][QtGui-5.7.1] Gtkstyle - qtstyleplugins? Reply with quote

Jacekalex wrote:

EDIT:
A few minutes after writing this post I found a working solution:
https://faase.org/Calrama/gestalt/blob/91760b608097bc7b99a7fa1c4d774da882c870d1/dev-qt/qt5-styleplugins/qt5-styleplugins-9999.ebuild
https://faase.org/Calrama/gestalt/raw/91760b608097bc7b99a7fa1c4d774da882c870d1/dev-qt/qt5-styleplugins/qt5-styleplugins-9999.ebuild

;)


I clicked on it but it said I need to sign in or sign up to continue, entered two different emails and it said an admin has blocked my accounts both times, tried to sign in with github & it said "csrf detected" whatever that means
How is anyone supposed to make an account for this faase.org thing???? There's no link in sight -.-

Could you please move this ebuild to a different site that doesn't require an account?

edit: now faase.org has changed either that or its rerouting me to a different page I have no idea why, this makes no sense! it tells me to sign in but now I can't even do that!

edit 2: now that I've successfully made an account, its now telling me that my account is blocked! What gives with this link?! omg.... so annoying. -.-
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Tue Dec 12, 2017 10:55 pm    Post subject: Reply with quote

You can add the abendbrot overlay and install x11-themes/qtstyleplugins from it. I’ve been using that since the switch to Qt 5.7.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Wed Dec 13, 2017 3:02 pm    Post subject: Reply with quote

stqn wrote:
You can add the abendbrot overlay and install x11-themes/qtstyleplugins from it. I’ve been using that since the switch to Qt 5.7.


Oh, thank you very much Stqn!! I just need to figure out how to do that now :D
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Wed Dec 13, 2017 3:33 pm    Post subject: Reply with quote

Install Layman and then run:
Code:

layman -a abendbrot

After that, you may need to eix-sync or emaint sync or similar, not sure.
Add x11-themes/qtstyleplugins to /etc/portage/package.accept_keywords.
Then you should be able to install qtstyleplugins.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Wed Dec 13, 2017 4:51 pm    Post subject: Reply with quote

stqn wrote:
Install Layman and then run:
Code:

layman -a abendbrot

After that, you may need to eix-sync or emaint sync or similar, not sure.
Add x11-themes/qtstyleplugins to /etc/portage/package.accept_keywords.
Then you should be able to install qtstyleplugins.


I'm not sure what's causing this... Is it just -bindist and -tls-heartbeat for openssl? Do I just have to add the USE flags to the package.use file?

Code:

sudo emerge layman

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild     U #] dev-libs/openssl-1.1.0g-r2 [1.0.2m] USE="-bindist* -tls-heartbeat*"
[ebuild  N     ] dev-python/idna-2.5  PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/pyasn1-0.2.3  USE="-doc" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/chardet-3.0.4  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/PySocks-1.6.7  PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/asn1crypto-0.22.0  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/enum34-1.1.6  USE="-doc" PYTHON_TARGETS="python2_7 (-pypy) (-pypy3)"
[ebuild  N     ] dev-python/ply-3.9  USE="-examples" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/ipaddress-1.0.18  PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild  N     ] virtual/python-ipaddress-1.0-r1  PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/pycparser-2.14  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/cffi-1.9.1  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
[ebuild  N     ] dev-python/cryptography-2.0.2-r1  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/pyopenssl-17.2.0  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/ndg-httpsclient-0.4.0  PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/urllib3-1.22  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/requests-2.18.2-r1  USE="ssl -socks5 {-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) (-pypy3) -python3_4 -python3_6"
[ebuild  N     ] dev-python/ssl-fetch-0.4  PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6"
[ebuild  N     ] app-portage/layman-2.4.2  USE="git -bazaar -cvs -darcs (-g-sorcery) -gpg -mercurial -sqlite -squashfs -subversion -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_5 (-pypy) -python3_4 -python3_6"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.0g-r2:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                                                                                   

  (dev-libs/openssl-1.0.2m:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0= required by (dev-lang/python-3.4.5:3.4/3.4m::gentoo, installed)
                    ^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0=[bindist=] required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, installed)
                                ^^^^^^^^                                                                                                     
    dev-libs/openssl:0/0=[abi_x86_32(-)] required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
                    ^^^^^                                                                                                                   
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
                       ^^^^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.14:2.7/2.7::gentoo, installed)
                    ^^^^^                                                                                                   
    (and 15 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (dev-lang/python-2.7.14:2.7/2.7::gentoo, installed): ebuild is masked or unavailable
  (dev-lang/python-3.4.5:3.4/3.4m::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21544
Location: here

PostPosted: Wed Dec 13, 2017 4:52 pm    Post subject: Reply with quote

Remove bindist use flag from make.conf and then run
Code:
# emerge -UD @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Wed Dec 13, 2017 5:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Remove bindist use flag from make.conf and then run
Code:
# emerge -UD @world


I don't have bindist in my make.conf though... Should I have openssl -bindist like that? Because I added bindist to openssl package.use entry because I thought it was telling me that it wanted that

edit: wait a tick, I'm wrong, I already put -bindist.. for some reason I thought I put bindist in the package.use openssl entry but I re-checked it and its -bindist not bindist

Bodhi, I really appreciate you and Neddy always helping me, I owe you guys big time for helping me get started with Gentoo lol. Thank you.


Last edited by kenny_w on Wed Dec 13, 2017 5:17 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21544
Location: here

PostPosted: Wed Dec 13, 2017 5:17 pm    Post subject: Reply with quote

kenny_w wrote:
I don't have bindist in my make.conf though... Should I have openssl -bindist like that? Because I added bindist to openssl package.use entry because I thought it was telling me that it wanted that

edit: wait a tick, I'm wrong, I already put -bindist.. for some reason I thought I put bindist in the package.use openssl entry but I re-checked it and its -bindist not bindist

Ok then run emerge command that I posted before
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Wed Dec 13, 2017 5:22 pm    Post subject: Reply with quote

fedeliallalinea wrote:
kenny_w wrote:
I don't have bindist in my make.conf though... Should I have openssl -bindist like that? Because I added bindist to openssl package.use entry because I thought it was telling me that it wanted that

edit: wait a tick, I'm wrong, I already put -bindist.. for some reason I thought I put bindist in the package.use openssl entry but I re-checked it and its -bindist not bindist

Ok then run emerge command that I posted before


Alrighty, I've just entered that command after rebooting.

edit: off-topic from this, I'm trying to troubleshoot why I cannot get bluetooth working too in case you'd like to take a look at that
https://forums.gentoo.org/viewtopic-p-8155450.html#8155450
and a few others too..
pavucontrol/pulseaudio configuration
https://forums.gentoo.org/viewtopic-p-8155438.html#8155438
qt5ct config
https://forums.gentoo.org/viewtopic-p-8155526.html#8155526

33 packages to emerge, looks like it may take a while. Its already on package 3 though so that's good news, but some packages take several hours. I'm just happy qtwebengine isn't in that list because that thing took nearly 24 hours.

32/33 packages so far

MESA takes a while to recompile but I'm glad its now building against my i915 driver! I'm sure that's solved problems I have yet to encounter :D
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Thu Dec 14, 2017 11:55 pm    Post subject: Reply with quote

stqn wrote:
Install Layman and then run:
Code:

layman -a abendbrot

After that, you may need to eix-sync or emaint sync or similar, not sure.
Add x11-themes/qtstyleplugins to /etc/portage/package.accept_keywords.
Then you should be able to install qtstyleplugins.


It tells me abendbrot doesn't exist.... :S my connection works, I can ping google, so I know my settings wasn't "eaten by a grue" (whatever that is)

edit: I checked the USE flags on layman and found out the portage extension wasn't enabled :D so I think that should solve this issue.

edit 2: layman has finished reinstalling with the sync-plugin-portage use flag and its still telling me abendbrot doesn't exist -.-

edit 3: I've solved it I think. I had to run layman -L :P

edit 4: WHY does it not let me use qt5ct -.- I have to type in the terminal export QT_QPA_PLATFORMTHEME=qt5ct (or =gtk2) then open the application I wanna open from the terminal or else it won't use the gtk theme -.-
what is causing this???? I made an entry in /etc/profile.d but its STILL not working..... This is so annoying.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Fri Dec 15, 2017 1:07 am    Post subject: Reply with quote

stqn wrote:
Install Layman and then run:
Code:

layman -a abendbrot

After that, you may need to eix-sync or emaint sync or similar, not sure.
Add x11-themes/qtstyleplugins to /etc/portage/package.accept_keywords.
Then you should be able to install qtstyleplugins.


How do you make it stay on the gtk theme???? I don't understand OMG..... this is way too complicated, I've already altered /etc/environment and /etc/profile.d/qt5ct.sh yet it STILL won't work...
I'm starting to feel like giving up, this is really frustrating, problem after problem.... I need my computer to be working for Tuesday so if by Monday its not working then I have to install a binary distro, I still need to solve bluetooth and pulseaudio issues ontop of this :@
I can't find any answers for any of these problems.... starting to feel really hopeless...
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Fri Dec 15, 2017 2:09 pm    Post subject: Reply with quote

Maybe things work "automatically" for me because I am using the LXQt DE, I have no idea.

In your case it looks like setting QT_QPA… in /etc/environment or ~/.xinitrc (if you use startx to launch Xorg) should work? (with "export" too, at least in .xinitrc).

If you need a computer for "serious" work maybe Gentoo is not the best choice… as you need to update frequently and updates aren’t always a walk in the park.
Back to top
View user's profile Send private message
kenny_w
Tux's lil' helper
Tux's lil' helper


Joined: 26 Nov 2017
Posts: 83
Location: Toronto, Canada

PostPosted: Fri Dec 15, 2017 3:04 pm    Post subject: Reply with quote

stqn wrote:
Maybe things work "automatically" for me because I am using the LXQt DE, I have no idea.

In your case it looks like setting QT_QPA… in /etc/environment or ~/.xinitrc (if you use startx to launch Xorg) should work? (with "export" too, at least in .xinitrc).

If you need a computer for "serious" work maybe Gentoo is not the best choice… as you need to update frequently and updates aren’t always a walk in the park.


I've done all of that -.-
I guess this is hopeless. I thought I'd be able to learn Gentoo & use it for my day-to-day stuff with my netbook but it looks utterly hopeless.

Edit: I've decided to give up. I'm done. this is hopeless, I just want bluetooth and sound to work... I can't even make stupid QT applications theme right.. I can't make anything work & I've been trying endlessly for the past near two weeks & I just can't do this shit. Sorry for wasting everyones' time but I just can't do this. If somebody really wanted to help me, this stuff would be working.
Back to top
View user's profile Send private message
stqn
n00b
n00b


Joined: 07 Apr 2015
Posts: 49

PostPosted: Fri Dec 15, 2017 3:55 pm    Post subject: Reply with quote

kenny_w wrote:
If somebody really wanted to help me, this stuff would be working.

I hope you realise how rude you sound.
Be sure that I won’t waste any more time with you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum