Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with Samba shares
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
alienjon
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1689

PostPosted: Fri Mar 24, 2017 1:34 am    Post subject: Problem with Samba shares Reply with quote

I setup a Gentoo machine to act as a home server. I'm running Samba off the machine and have been transcoding videos for a Plex server. Recently, as in the last few days (possibly since an update, come to think of it, though I don't believe Samba was among the updated programs) I've found two issues occurring that I believe to be related. Firstly, there have been several instances where the mapped Samba share on my Windows 10 machine weren't able to reconnect. A simple 'disconnect drive' and 'connect drive' resolved the issue, but as it came up a few times I'm not sure what happened (I didn't have to touch the server at all for this). The second issue is that during transcoding (where I'm taking an original file on a network drive, transcoding via Handbrake in Windows 10, and saving to the new file on the share) the process will randomly stop. It seemed random, and I'm not entirely sure it isn't a problem with something else (though sometimes running the same action again on the same file will succeed, so I don't think it's the files) but I believe this is also connected to the Samba share because there was one instance where I was using my Windows 10 machine as the transcoding process failed and the mapped drive got messed up at the exact same time.

I suspect Samba, because a) they are Samba shares and b) I can still SSH and otherwise connect to other services on the server. I'm not getting any error messages in Handbrake (Which is exceedingly frustrating, because it will simply say that the transcoding failed without any detail - even the detailed debugging only gives more info on the transcoding process, not any errors).
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Mar 24, 2017 1:43 am    Post subject: Reply with quote

https://packages.gentoo.org/packages/net-fs/samba

Quote:
net-fs/samba: Bump to version 4.5.6
Lars Wendler, Fri, 10 Mar 2017 12:29, commit 21957a03
samba-4.5.6.ebuild
Back to top
View user's profile Send private message
alienjon
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1689

PostPosted: Fri Mar 24, 2017 3:37 am    Post subject: Reply with quote

Timeframe could be correct, except I'm running the latest stable. 4.5.6 is masked. I'm on 4.2.14:

emerge samba -pv:
[ebuild   R    ] net-fs/samba-4.2.14::gentoo  USE="acl addns ads aio avahi client cups gnutls ldap pam system-mitkrb5 winbind -addc -cluster -dmapi -fam -iprint -quota (-selinux) -syslog -systemd {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum