Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thunderbird under Plasma 5 has no scrollbar arrows [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
miket
Guru
Guru


Joined: 28 Apr 2007
Posts: 412
Location: Gainesville, FL, USA

PostPosted: Tue Oct 10, 2017 1:58 am    Post subject: Thunderbird under Plasma 5 has no scrollbar arrows [solved] Reply with quote

Here's another annoyance from GTK land.

I'm running mail-client/thunderbird-52.3.0 in a Plasma 5 environment (kde-plasma/plasma-meta-5.10.5) and the scrollbars have no arrows on them. I guess it's just another manifestation of insanity among those GTK developers; I give thanks that the KDE people aren't that crazy. Qt windows have normal scrollbars; I wish that Thunderbird did. I have thousands of emails, so I need much finer scrolling than I can get by trying to drag the slider by impossibly tiny increments. Also, I like to look at the Subject lines without changing the message-read status, so scrolling with the arrow keys doesn't work out for me either.

I tried some tweaks I read about on the internet, but they were all pretty much directed to changing the behavior in a Gnome or XFCE. I haven't seen anyone address this for KDE (any version). Yes, I have System Settings -> Window Management -> KWin Scripts -> Enforces Window Decorations on GTK+ window enabled, and yes I set up ~/.config/gtk-3.0/gtk.css as
Code:
.scrollbar {
  -GtkScrollbar-has-backward-stepper: true;
  -GtkScrollbar-has-forward-stepper: true;
}

and even tried switching the GTK theme to HighContrast by setting this in ~/.config/gtk-3.0/settings.ini as
Code:
[settings]
gtk-theme-name = HighContrast
gtk-icon-theme-name = gnome
gtk-cursor-theme-name = Adwaita

but nothing gave me arrow buttons on the scrollbars. (Adding that settings.ini did change the appearance of the window, but changing the file again to s/Adwaita/HighContrast/ still gave me no arrows.)

How do I get my arrows? Not having them is a usability problem.


Last edited by miket on Thu Oct 12, 2017 12:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
karmaking
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2004
Posts: 81
Location: Berlin, Germany

PostPosted: Thu Oct 12, 2017 10:27 am    Post subject: Reply with quote

Create or add to ~/.config/gtk-3.0/gtk.css


*{

-GtkScrollbar-has-backward-stepper: 1;
-GtkScrollbar-has-forward-stepper: 1;

}


Cheers,
Daniel
Back to top
View user's profile Send private message
miket
Guru
Guru


Joined: 28 Apr 2007
Posts: 412
Location: Gainesville, FL, USA

PostPosted: Thu Oct 12, 2017 12:01 pm    Post subject: Reply with quote

That's great. I replaced ".scrollbar" with an asterisk in my ~/.config/gtk-3.0/gtk.css file and it worked. I've got arrows on the scrollbar now. Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum