Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
networkmanager-openconnect-1.2.4 broken?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ppwaskie
n00b
n00b


Joined: 10 Sep 2015
Posts: 12

PostPosted: Mon Mar 20, 2017 6:33 pm    Post subject: networkmanager-openconnect-1.2.4 broken? Reply with quote

Hi all,

I'm running Gnome 3.20.2, with NetworkManager 1.4.4-r1. I was running networkmanager-openconnect, the plugin for Cisco AnyConnect VPN's, at version 1.2.2 for a long time. I noticed that 1.2.4 was broken, where the login GUI wouldn't display when trying to connect, and it would immediately disconnect. Now that portage only has 1.2.4 from what I can tell, it seems like I'm back at the same problem. This is the only logging I can see from /var/log/messages that indicates anything is going sideways:

Code:

Mar 20 11:24:02 wolverine NetworkManager[4207]: <info>  [1490034242.1299] audit: op="connection-activate" uuid="0b78be54-97ec-4871-acfc-a097b803587d" name="XXXX" pid=24236 uid=1000 result="success"
Mar 20 11:24:02 wolverine NetworkManager[4207]: <info>  [1490034242.1317] vpn-connection[0x1c60530,0b78be54-97ec-4871-acfc-a097b803587d,"XXXX",0]: Started the VPN service, PID 24256
Mar 20 11:24:02 wolverine gnome-shell[4618]: (gnome-shell:4618): Gjs-WARNING **: JS ERROR: TypeError: a._connection is null
Mar 20 11:24:02 wolverine gnome-shell[4618]: NMVPNSection<.setActiveConnections/<@resource:///org/gnome/shell/ui/status/network.js:1534
Mar 20 11:24:02 wolverine gnome-shell[4618]: NMVPNSection<.setActiveConnections@resource:///org/gnome/shell/ui/status/network.js:1533
Mar 20 11:24:02 wolverine gnome-shell[4618]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
Mar 20 11:24:02 wolverine gnome-shell[4618]: NMApplet<._syncVPNConnections@resource:///org/gnome/shell/ui/status/network.js:1822
Mar 20 11:24:02 wolverine gnome-shell[4618]: wrapper@resource:///org/gnome/gjs/modules/lang.js:178
Mar 20 11:24:02 wolverine NetworkManager[4207]: <info>  [1490034242.1353] vpn-connection[0x1c60530,0b78be54-97ec-4871-acfc-a097b803587d,"XXXX",0]: Saw the service appear; activating connection
Mar 20 11:24:02 wolverine gnome-shell[11265]: Gjs-Message: JS LOG: Invalid VPN service type (cannot find authentication binary)
Mar 20 11:24:02 wolverine gnome-shell[11265]: Gjs-Message: JS LOG: Invalid VPN service type (cannot find authentication binary)
Mar 20 11:24:02 wolverine NetworkManager[4207]: <error> [1490034242.2109] vpn-connection[0x1c60530,0b78be54-97ec-4871-acfc-a097b803587d,"XXXX",0]: Failed to request VPN secrets #3: No agents were available for this request.
Mar 20 11:24:02 wolverine NetworkManager[4207]: <info>  [1490034242.2116] vpn-connection[0x1c60530,0b78be54-97ec-4871-acfc-a097b803587d,"XXXX",0]: VPN plugin: state changed: stopped (6)


Now the other part is if I try to add a VPN connection through the nm-applet GUI, OpenConnect is not an option. Once I was able to downgrade before back to 1.2.2, then it did show up, and the VPN connection worked just fine.

I just did an emerge -avuDN --with-bdeps=y @world and picked up anything that was needing an update, and I'm still seeing the same issue. The only thing I can see from the networkmanager-openconnect-1.2.4 release notes that is significant is the split of the GUI module and the CLI piece, which I suspect could be causing this.

Is anyone else seeing this? Any suggestions, or other data I can gather to help debug this?

Thanks,
-PJ
Back to top
View user's profile Send private message
muddle
n00b
n00b


Joined: 01 May 2007
Posts: 20

PostPosted: Wed Mar 22, 2017 6:46 am    Post subject: Reply with quote

Hi ppwaskie,

could you try to use networkmanager at the command line? At a terminal do (as normal user):
Code:

nmcli --ask connection up <your vpn name>
Back to top
View user's profile Send private message
linuxale
n00b
n00b


Joined: 11 Jan 2006
Posts: 33

PostPosted: Tue Apr 18, 2017 6:31 pm    Post subject: Same problem Reply with quote

I have the same problem.
Actually I am using Sabayon but the problem is identical.

From the CLI it works properly.

I ran NetworkManager in debug mode:
Code:

NetworkManager --log-level=debug --no-daemon -d  2>&1

And this is what I get:
Code:

[NetworkManager[12007]: <debug> [1492539674.0846] Secrets requested for connection /org/freedesktop/NetworkManager/Settings/1 (HereVpc/vpn)
NetworkManager[12007]: <debug> [1492539674.0846] agent-manager: req[0x1c97990, :1.58/org.gnome.Shell.NetworkAgent/90026485]: agent allowed for secrets request [0x1ccd190/"HereVpc"/"vpn"]
NetworkManager[12007]: <debug> [1492539674.0846] settings-connection[0x1be59e0,4be9be13-19ff-4b7b-9d87-6a4f6719e50f]: (vpn:0x1ccd190) secrets requested flags 0x5 hints '(none)'
NetworkManager[12007]: <debug> [1492539674.0849] agent-manager: ([0x1ccd190/"HereVpc"/"vpn"]) system settings secrets insufficient, asking agents
NetworkManager[12007]: <debug> [1492539674.0850] agent-manager: req[0x1c97990, :1.58/org.gnome.Shell.NetworkAgent/90026485]: agent getting secrets for request [0x1ccd190/"HereVpc"/"vpn"]
NetworkManager[12007]: <debug> [1492539674.0850] agent-manager: ([0x1ccd190/"HereVpc"/"vpn"]) request has system secrets; checking agent :1.58 for MODIFY
NetworkManager[12007]: <debug> [1492539674.0850] auth: call[35]: CheckAuthorization(org.freedesktop.NetworkManager.settings.modify.own), subject=unix-process[pid=3657, uid=90026485, start=170794]
NetworkManager[12007]: <debug> [1492539674.0862] auth: call[35]: CheckAuthorization succeeded: (is_authorized=1, is_challenge=0)
NetworkManager[12007]: <debug> [1492539674.0863] agent-manager: req[0x1c97990, :1.58/org.gnome.Shell.NetworkAgent/90026485]: agent [0x1ccd190/"HereVpc"/"vpn"] MODIFY check result YES
NetworkManager[12007]: <debug> [1492539674.0890] agent-manager: req[0x1c97990, :1.58/org.gnome.Shell.NetworkAgent/90026485]: agent failed secrets request [0x1ccd190/"HereVpc"/"vpn"]: An internal error occurred while processing the request.
NetworkManager[12007]: <debug> [1492539674.0890] settings-connection[0x1be59e0,4be9be13-19ff-4b7b-9d87-6a4f6719e50f]: (vpn:0x1c250c0) secrets request error: No agents were available for this request.
NetworkManager[12007]: <error> [1492539674.0890] vpn-connection[0x1bf01a0,4be9be13-19ff-4b7b-9d87-6a4f6719e50f,"HereVpc",0]: Failed to request VPN secrets #3: No agents were available for this request.
NetworkManager[12007]: <debug> [1492539674.0890] active-connection[0x1bf01a0]: set state deactivated (was activating)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum