Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mate 1.14
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pakk
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2016
Posts: 143

PostPosted: Sun Mar 19, 2017 5:48 pm    Post subject: mate 1.14 Reply with quote

hello

i have mate 1.12 and i wanna install mate 1.14

i used layman -a mate-gentoo

Code:

$ eix mate-desktop
[U] mate-base/mate-desktop
     Available versions:  1.12.1-r2 1.12.1-r2[1] ~1.14.1 ~1.14.1[1] (~)1.16.1 (~)1.16.1[1] ~1.18.0[1] **9999[1] {X debug gtk3 +introspection startup-notification PYTHON_TARGETS="python2_7"}
     Installed versions:  1.12.1-r2[1](17:32:12 19. 03. 17)(X introspection startup-notification -debug -gtk3 PYTHON_TARGETS="python2_7")
     Homepage:            http://mate-desktop.org
     Description:         Libraries for the MATE desktop that are not part of the UI

[1] "gentoo-mate" /var/lib/layman/gentoo-mate


in /etc/portage/package.use/
Code:

$ cat mate
 mate-base/mate-desktop
mate-base/gentoo-mate


then
Code:

emerge -avquDN --with-bdeps=y @world


and then nothing to merge.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sun Mar 19, 2017 6:05 pm    Post subject: Reply with quote

pakk,
Code:

[U] mate-base/mate-desktop
     Available versions:  1.12.1-r2 1.12.1-r2[1] ~1.14.1 ~1.14.1[1] (~)1.16.1 (~)1.16.1[1] ~1.18.0[1] **9999[1]

The ~ means a testing kernion
The ** means a non keyworded (for your arch) version.

If you really want 1.14.1, you need to keyword it. Depending on what your write in package.accept_keywords, you can get any of the testing versions.

Mate is in the portage tree now too, which is why you have two eix entries for most versions.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pakk
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2016
Posts: 143

PostPosted: Sun Mar 19, 2017 7:09 pm    Post subject: Reply with quote

Code:
sudo emerge -avquDN --with-bdeps=y @world
!!! Invalid PORTDIR_OVERLAY (not a dir): '/var/lib/layman/mate-de-gentoo'
[ebuild     UD] mate-base/mate-common-1.12.0 [1.16.0]

Would you like to merge these packages? [Yes/No]


Code:
/etc/portage/package.accept_keywords $ cat mate
=mate-base/mate-desktop-1.14.1 ~amd64
# required by mate-base/mate-desktop-1.16.1::gentoo
# required by mate-extra/mate-tweak-3.5.10.1::jorgicio
# required by mate-tweak (argument)
#mate-base/mate-common-1.16.0 ~amd64
# required by mate-tweak (argument)
#mate-extra/mate-tweak-3.5.10.1 ~amd64
#mate-base/mate-gentoo

Code:
sudo emerge -1aq mate-desktop
!!! Invalid PORTDIR_OVERLAY (not a dir): '/var/lib/layman/mate-de-gentoo'
[ebuild   R   ] mate-base/mate-desktop-1.12.1-r2

Would you like to merge these packages? [Yes/No]


i cant see any mate 1.14
Back to top
View user's profile Send private message
pakk
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2016
Posts: 143

PostPosted: Fri Mar 24, 2017 1:33 pm    Post subject: Reply with quote

now looks better but still not vers. 1.14

Code:

sudo emerge -1aq mate-desktop
[ebuild     U ] mate-base/mate-common-1.18.0 [1.12.0]
[ebuild     U ] mate-base/mate-desktop-1.18.0 [1.12.1-r2]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

mate-base/mate-desktop:0

  (mate-base/mate-desktop-1.18.0:0/0::gentoo-mate, ebuild scheduled for merge) pulled in by
    mate-base/mate-desktop (Argument)

  (mate-base/mate-desktop-1.12.1-r2:0/0::gentoo-mate, installed) pulled in by
    =mate-base/mate-desktop-1.12*:0[gtk3(-)?] required by (mate-base/mate-1.12-r1:0/0::gentoo, installed)
    ^                       ^^^^^^^   
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Fri Mar 24, 2017 1:36 pm    Post subject: Reply with quote

pakk,

What do you have in package.use ?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
pakk
Tux's lil' helper
Tux's lil' helper


Joined: 25 Nov 2016
Posts: 143

PostPosted: Sat Mar 25, 2017 9:27 pm    Post subject: Reply with quote

i have 3 places for MATE

Code:
etc/portage/package.use $ cat custom
#MATE
mate-base/mate-menus python

/etc/portage/package.accept_keywords $ cat mate
mate-base/mate-desktop
#required by mate-base/mate-desktop-1.16.1::gentoo
# required by mate-extra/mate-tweak-3.5.10.1::jorgicio
# required by mate-tweak (argument)
#mate-base/mate-common-1.16.0 ~amd64
# required by mate-tweak (argument)
#mate-extra/mate-tweak-3.5.10.1 ~amd64
#mate-base/mate-gentoo
#mate-base/mate
=dev-libs/libmateweather-1.14.1 ~amd64
=dev-libs/libmateweather-1.14.1 ~amd64
=app-text/atril-1.14.1 ~amd64
=app-arch/engrampa-1.14.1 ~amd64
=mate-extra/mate-netbook-1.14.1 ~amd64
=app-editors/pluma-1.14.1 ~amd64

/etc/portage/package.keywords $ cat mate
mate-base/caja
mate-base/libmatekbd
mate-base/mate
mate-base/mate-applets
mate-base/mate-applets-meta
mate-base/mate-common
mate-base/mate-control-center
mate-base/mate-desktop
mate-base/mate-menus
mate-base/mate-panel
mate-base/mate-session-manager
mate-base/mate-settings-daemon
mate-extra/caja-dropbox
mate-extra/caja-extensions
mate-extra/mate-indicator-applet
mate-extra/mate-media
mate-extra/mate-polkit
mate-extra/mate-power-manager
mate-extra/mate-screensaver
mate-extra/mate-sensors-applet
mate-extra/mate-system-monitor
mate-extra/mate-user-guide
mate-extra/mate-user-share
mate-extra/mate-utils
media-gfx/eom
media-libs/libmatemixer
x11-misc/mate-notification-daemon
x11-misc/mozo
x11-terms/mate-terminal
x11-themes/mate-backgrounds
x11-themes/mate-icon-theme
x11-themes/mate-icon-theme-faenza
x11-wm/marco
mate-extra/mate-calc
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 730
Location: S.O. France

PostPosted: Fri Mar 31, 2017 12:39 pm    Post subject: Reply with quote

According to your keywords files, you are mixing mate 1.14 and mate 1.18 (why 2 keywords files?)

For ex you have in your keyword file
Code:
mate-base/mate-desktop.

This will install the last testing mate i.e. 1.18.
If you only want 1.14, you have to put the exact version
Code:
=mate-base/mate-desktop-1.14.1

You have to do this for all 1.14 packages. Autounmask can help you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum