Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
setxkbmap - Does not remain active
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Sat Mar 18, 2017 1:17 pm    Post subject: setxkbmap - Does not remain active Reply with quote

I have problems with the continuous setting of the Xkbmap layout. The setting is reset after entering the command line after a few secunds. The temporary setting works, but is very fast away again. I created a file according to wiki. Unfortunately, the keymap layout is not active after a boot.

Code:
less /etc/X11/xorg-conf.d/10-keyboard.conf

Section "InputClass"
    Identifier "keyboard-all"
    Driver "evdev"
    Option "XkbLayout" "de"
    EndSection


EDIT: i tested it in Fluxbox. There its ok.
_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
roboto
Apprentice
Apprentice


Joined: 15 Feb 2017
Posts: 156
Location: My IP address.

PostPosted: Sat Mar 18, 2017 7:37 pm    Post subject: Reply with quote

If you use bash, put the following in ~/.bashrc

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll dvorak


dvorak is the keyboard layout I use.

Substitute dvorak with the keyboard layout you use.

Xkbmap stays on for me.

Hope I helped.
_________________
Answers please.

The true hater of man expects nothing from him and is indiscriminate to his works.
-Ayn Rand
Quote:
Dude. Minus 30 credibility points.

Yep
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum