Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sddm stopped working: no login screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Wed Mar 15, 2017 7:32 am    Post subject: sddm stopped working: no login screen Reply with quote

Hi!

I have a problem with sddm. Yesterday, I logged out from KDE, and instead of getting the sddm login screen, I only see a non blinking cursor in the left upper corner of the screen. Restarting /etc/init.d/xdm and also rebooting did not change anything. I also did a system update, depclean etc. (I'm on stable), but still, I get no X server when using sddm. Rebuilding sddm also changed nothing.

I neither see an error in Xorg.0.log (according to this, the X server is started normally), nor in sddm.log, nor in the syslog or dmesg.

I tried to install slim and set this as display manager. With slim, when starting /etc/init.d/xdm, the X server starts normally, I see the slim login screen and also can do a login to KDE.

I'm out of ideas where to search for the error … apparently, this is a sddm problem (as the X server works via startx and also using slim).

I would greatly appreciate any help!


Last edited by l3u on Thu Mar 16, 2017 10:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Wed Mar 15, 2017 12:46 pm    Post subject: Reply with quote

sddm is still in the group video?
Code:
usermod -a -G video sddm
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Wed Mar 15, 2017 5:14 pm    Post subject: Reply with quote

Yes, I already tried this one. No change, also not after a reboot.
Back to top
View user's profile Send private message
sdoubleyou
n00b
n00b


Joined: 27 May 2016
Posts: 42

PostPosted: Wed Mar 15, 2017 7:34 pm    Post subject: Reply with quote

Grr :wink:
Is your sddm.conf changed during the last update?

Here is my sddm.conf for comparison

Code:
[Autologin]
# Whether sddm should automatically log back into sessions when they exit
Relogin=false

# Name of session file for autologin session
Session=

# Username for autologin session
User=


[General]
# Halt command
HaltCommand=/sbin/shutdown -h -P now

# Input method module
InputMethod=

# Initial NumLock state. Can be on, off or none.
# If property is set to none, numlock won't be changed
# NOTE: Currently ignored if autologin is enabled.
Numlock=none

# Reboot command
RebootCommand=/sbin/shutdown -r now


[Theme]
# Current theme name
Current=breeze

# Cursor theme used in the greeter
CursorTheme=

# Number of users to use as threshold
# above which avatars are disabled
# unless explicitly enabled with EnableAvatars
DisableAvatarsThreshold=7

# Enable display of custom user avatars
EnableAvatars=true

# Global directory for user avatars
# The files should be named <username>.face.icon
FacesDir=/usr/share/sddm/faces

# Theme directory path
ThemeDir=/usr/share/sddm/themes


[Users]
# Default $PATH for logged in users
DefaultPath=/bin:/usr/bin:/usr/local/bin

# Comma-separated list of shells.
# Users with these shells as their default won't be listed
HideShells=

# Comma-separated list of users that should not be listed
HideUsers=

# Maximum user id for displayed users
MaximumUid=60000

# Minimum user id for displayed users
MinimumUid=1000

# Remember the session of the last successfully logged in user
RememberLastSession=true

# Remember the last successfully logged in user
RememberLastUser=true


[Wayland]
# Path to a script to execute when starting the desktop session
SessionCommand=/usr/share/sddm/scripts/wayland-session

# Directory containing available Wayland sessions
SessionDir=/usr/share/wayland-sessions

# Path to the user session log file
SessionLogFile=.local/share/sddm/wayland-session.log


[X11]
# Path to a script to execute when starting the display server
DisplayCommand=/usr/share/sddm/scripts/Xsetup

# Path to a script to execute when stopping the display server
DisplayStopCommand=/usr/share/sddm/scripts/Xstop

# The lowest virtual terminal number that will be used.
MinimumVT=7

# Arguments passed to the X server invocation
ServerArguments=-nolisten tcp

# Path to X server binary
ServerPath=/usr/bin/X

# Path to a script to execute when starting the desktop session
SessionCommand=/usr/share/sddm/scripts/Xsession

# Directory containing available X sessions
SessionDir=/usr/share/xsessions

# Path to the user session log file
SessionLogFile=.local/share/sddm/xorg-session.log

# Path to the Xauthority file
UserAuthFile=.Xauthority

# Path to xauth binary
XauthPath=/usr/bin/xauth

# Path to Xephyr binary
XephyrPath=/usr/bin/Xephyr


For me was the entry
Code:
# The lowest virtual terminal number that will be used.
MinimumVT = 7

important
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Wed Mar 15, 2017 9:54 pm    Post subject: Reply with quote

There are only slight differences here (that should not cause the X server not to be displayed imo):
Code:
HaltCommand=

RebootCommand=

CursorTheme=breeze_cursors

MaximumUid=65000

MinimumVT is also set to 7.
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Thu Mar 16, 2017 5:19 pm    Post subject: Reply with quote

I now even rebuilt my whole system using emerge -e @world to be sure there's no linker/dependency/whatever problem. Still the very same problem after a reboot :-(

Perhaps, I simply don't see it … here is the log of sddm:
Code:
[18:10:29.046] (II) DAEMON: Initializing...
[18:10:29.118] (II) DAEMON: Starting...
[18:10:29.118] (II) DAEMON: Adding new display on vt 7 ...
[18:10:29.212] (II) DAEMON: Display server starting...
[18:10:29.212] (II) DAEMON: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{3e1af591-81d4-47c5-b4bc-05009055a7ac} -background none -noreset -displayfd 18 vt7
[18:10:31.543] (II) DAEMON: Running display setup script  "/usr/share/sddm/scripts/Xsetup"
[18:10:31.600] (II) DAEMON: Display server started.
[18:10:31.600] (II) DAEMON: Socket server starting...
[18:10:31.600] (II) DAEMON: Socket server started.
[18:10:31.654] (II) DAEMON: Greeter starting...
[18:10:31.654] (II) DAEMON: Adding cookie to "/var/run/sddm/{3e1af591-81d4-47c5-b4bc-05009055a7ac}"
[18:10:31.725] (II) HELPER: [PAM] Starting...
[18:10:31.725] (II) HELPER: [PAM] Authenticating...
[18:10:31.725] (II) HELPER: [PAM] returning.
[18:10:31.774] (II) DAEMON: Greeter session started successfully
[18:10:32.940] (II) DAEMON: Message received from greeter: Connect

and the according X log:
Code:
[  2582.918] (--) Log file renamed from "/var/log/Xorg.pid-4357.log" to "/var/log/Xorg.0.log"
[  2582.918]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[  2582.918] X Protocol Version 11, Revision 0
[  2582.918] Build Operating System: Linux 4.9.6-gentoo-r1 x86_64 Gentoo
[  2582.918] Current Operating System: Linux brokkr 4.9.6-gentoo-r1 #1 SMP Mon Mar 13 22:29:09 CET 2017 x86_64
[  2582.918] Kernel command line: BOOT_IMAGE=/boot/vmlinuz root=/dev/md0
[  2582.918] Build Date: 16 March 2017  09:43:40AM
[  2582.918] 
[  2582.918] Current version of pixman: 0.34.0
[  2582.919]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  2582.919] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2582.919] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 16 18:53:10 2017
[  2582.919] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2582.919] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2582.919] (==) No Layout section.  Using the first Screen section.
[  2582.919] (==) No screen section available. Using defaults.
[  2582.919] (**) |-->Screen "Default Screen Section" (0)
[  2582.919] (**) |   |-->Monitor "<default monitor>"
[  2582.919] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  2582.919] (==) Automatically adding devices
[  2582.919] (==) Automatically enabling devices
[  2582.919] (==) Automatically adding GPU devices
[  2582.919] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2582.919] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[  2582.919] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  2582.919] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2582.919] (II) Loader magic: 0x811c80
[  2582.919] (II) Module ABI versions:
[  2582.920]    X.Org ANSI C Emulation: 0.4
[  2582.920]    X.Org Video Driver: 23.0
[  2582.920]    X.Org XInput driver : 24.1
[  2582.920]    X.Org Server Extension : 10.0
[  2582.920] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2582.933] (--) PCI:*(0:0:2:0) 8086:0f31:1849:0f31 rev 12, Mem @ 0xb0000000/4194304, 0xa0000000/268435456, I/O @ 0x0000f080/8, BIOS @ 0x????????/131072
[  2582.933] (II) LoadModule: "glx"
[  2582.934] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  2582.936] (II) Module glx: vendor="X.Org Foundation"
[  2582.936]    compiled for 1.19.2, module version = 1.0.0
[  2582.936]    ABI class: X.Org Server Extension, version 10.0
[  2582.936] (==) Matched intel as autoconfigured driver 0
[  2582.936] (==) Matched intel as autoconfigured driver 1
[  2582.936] (==) Matched modesetting as autoconfigured driver 2
[  2582.936] (==) Matched fbdev as autoconfigured driver 3
[  2582.936] (==) Matched vesa as autoconfigured driver 4
[  2582.936] (==) Assigned the driver to the xf86ConfigLayout
[  2582.936] (II) LoadModule: "intel"
[  2582.936] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  2582.936] (II) Module intel: vendor="X.Org Foundation"
[  2582.936]    compiled for 1.19.2, module version = 2.99.917
[  2582.936]    Module class: X.Org Video Driver
[  2582.936]    ABI class: X.Org Video Driver, version 23.0
[  2582.936] (II) LoadModule: "modesetting"
[  2582.937] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
[  2582.937] (II) Module modesetting: vendor="X.Org Foundation"
[  2582.937]    compiled for 1.19.2, module version = 1.19.2
[  2582.937]    Module class: X.Org Video Driver
[  2582.937]    ABI class: X.Org Video Driver, version 23.0
[  2582.937] (II) LoadModule: "fbdev"
[  2582.937] (WW) Warning, couldn't open module fbdev
[  2582.937] (II) UnloadModule: "fbdev"
[  2582.937] (II) Unloading fbdev
[  2582.937] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  2582.937] (II) LoadModule: "vesa"
[  2582.937] (WW) Warning, couldn't open module vesa
[  2582.937] (II) UnloadModule: "vesa"
[  2582.937] (II) Unloading vesa
[  2582.937] (EE) Failed to load module "vesa" (module does not exist, 0)
[  2582.937] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  2582.938] (II) intel: Driver for Intel(R) HD Graphics
[  2582.938] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  2582.938] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  2582.938] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2582.938] (++) using VT number 7

[  2582.938] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[  2582.939] (WW) Falling back to old probe method for modesetting
[  2582.939] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[  2582.939] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[  2582.939] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[  2582.939] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  2582.939] (==) intel(0): RGB weight 888
[  2582.939] (==) intel(0): Default visual is TrueColor
[  2582.940] (II) intel(0): Output VGA1 has no monitor section
[  2582.940] (II) intel(0): Enabled output VGA1
[  2582.940] (II) intel(0): Output DP1 has no monitor section
[  2582.940] (II) intel(0): Enabled output DP1
[  2582.940] (II) intel(0): Output HDMI1 has no monitor section
[  2582.941] (II) intel(0): Enabled output HDMI1
[  2582.941] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[  2582.941] (II) intel(0): Output VIRTUAL1 has no monitor section
[  2582.941] (II) intel(0): Enabled output VIRTUAL1
[  2582.941] (--) intel(0): Output HDMI1 using initial mode 1920x1080 on pipe 0
[  2582.941] (==) intel(0): TearFree disabled
[  2582.941] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[  2582.941] (==) intel(0): DPI set to (96, 96)
[  2582.941] (II) Loading sub module "dri3"
[  2582.941] (II) LoadModule: "dri3"
[  2582.941] (II) Module "dri3" already built-in
[  2582.941] (II) Loading sub module "dri2"
[  2582.941] (II) LoadModule: "dri2"
[  2582.941] (II) Module "dri2" already built-in
[  2582.941] (II) Loading sub module "present"
[  2582.941] (II) LoadModule: "present"
[  2582.941] (II) Module "present" already built-in
[  2582.941] (II) UnloadModule: "modesetting"
[  2582.941] (II) Unloading modesetting
[  2582.941] (==) Depth 24 pixmap format is 32 bpp
[  2582.942] (II) intel(0): SNA initialized with Baytrail (gen7) backend
[  2582.942] (==) intel(0): Backing store enabled
[  2582.942] (==) intel(0): Silken mouse enabled
[  2582.942] (II) intel(0): HW Cursor enabled
[  2582.942] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  2582.942] (==) intel(0): DPMS enabled
[  2582.942] (==) intel(0): Display hotplug detection enabled
[  2582.942] (II) intel(0): [DRI2] Setup complete
[  2582.942] (II) intel(0): [DRI2]   DRI driver: i965
[  2582.942] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[  2582.942] (II) intel(0): direct rendering: DRI2 enabled
[  2582.942] (II) intel(0): hardware support for Present enabled
[  2582.942] (--) RandR disabled
[  2582.955] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  2582.955] (II) AIGLX: enabled GLX_ARB_create_context
[  2582.955] (II) AIGLX: enabled GLX_ARB_create_context_profile
[  2582.955] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[  2582.955] (II) AIGLX: enabled GLX_INTEL_swap_event
[  2582.955] (II) AIGLX: enabled GLX_SGI_swap_control
[  2582.955] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[  2582.955] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[  2582.955] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[  2582.955] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  2582.955] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[  2582.955] (II) AIGLX: Loaded and initialized i965
[  2582.955] (II) GLX: Initialized DRI2 GL provider for screen 0
[  2582.961] (II) intel(0): switch to mode 1920x1080@50.0 on HDMI1 using pipe 0, position (0, 0), rotation normal, reflection none
[  2582.972] (II) intel(0): Setting screen physical size to 508 x 285
[  2583.128] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[  2583.128] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2583.128] (II) LoadModule: "evdev"
[  2583.128] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[  2583.129] (II) Module evdev: vendor="X.Org Foundation"
[  2583.129]    compiled for 1.19.2, module version = 2.10.5
[  2583.129]    Module class: X.Org XInput Driver
[  2583.129]    ABI class: X.Org XInput driver, version 24.1
[  2583.129] (II) Using input driver 'evdev' for 'Power Button'
[  2583.129] (**) Power Button: always reports core events
[  2583.129] (**) evdev: Power Button: Device: "/dev/input/event2"
[  2583.129] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2583.129] (--) evdev: Power Button: Found keys
[  2583.129] (II) evdev: Power Button: Configuring as keyboard
[  2583.129] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[  2583.129] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  2583.129] (**) Option "xkb_rules" "evdev"
[  2583.130] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[  2583.130] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[  2583.130] (II) Using input driver 'evdev' for 'Video Bus'
[  2583.130] (**) Video Bus: always reports core events
[  2583.130] (**) evdev: Video Bus: Device: "/dev/input/event3"
[  2583.130] (--) evdev: Video Bus: Vendor 0 Product 0x6
[  2583.130] (--) evdev: Video Bus: Found keys
[  2583.131] (II) evdev: Video Bus: Configuring as keyboard
[  2583.131] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input3/event3"
[  2583.131] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  2583.131] (**) Option "xkb_rules" "evdev"
[  2583.131] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[  2583.131] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  2583.131] (II) Using input driver 'evdev' for 'Power Button'
[  2583.131] (**) Power Button: always reports core events
[  2583.131] (**) evdev: Power Button: Device: "/dev/input/event0"
[  2583.132] (--) evdev: Power Button: Vendor 0 Product 0x1
[  2583.132] (--) evdev: Power Button: Found keys
[  2583.132] (II) evdev: Power Button: Configuring as keyboard
[  2583.132] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[  2583.132] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[  2583.132] (**) Option "xkb_rules" "evdev"
[  2583.132] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[  2583.132] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[  2583.132] (II) Using input driver 'evdev' for 'Sleep Button'
[  2583.132] (**) Sleep Button: always reports core events
[  2583.133] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[  2583.133] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[  2583.133] (--) evdev: Sleep Button: Found keys
[  2583.133] (II) evdev: Sleep Button: Configuring as keyboard
[  2583.133] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[  2583.133] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[  2583.133] (**) Option "xkb_rules" "evdev"
[  2583.134] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event4)
[  2583.134] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[  2583.134] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[  2583.134] (**) Logitech USB Receiver: always reports core events
[  2583.134] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event4"
[  2583.134] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[  2583.134] (--) evdev: Logitech USB Receiver: Found keys
[  2583.134] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[  2583.135] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2.3/1-2.3:1.0/0003:046D:C52B.0001/input/input7/event4"
[  2583.135] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 10)
[  2583.135] (**) Option "xkb_rules" "evdev"
[  2583.136] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event5)
[  2583.136] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
[  2583.136] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
[  2583.136] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
[  2583.136] (**) Logitech USB Receiver: always reports core events
[  2583.136] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event5"
[  2583.136] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b
[  2583.136] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
[  2583.136] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
[  2583.136] (--) evdev: Logitech USB Receiver: Found relative axes
[  2583.136] (--) evdev: Logitech USB Receiver: Found x and y relative axes
[  2583.136] (--) evdev: Logitech USB Receiver: Found absolute axes
[  2583.136] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
[  2583.136] (--) evdev: Logitech USB Receiver: Found keys
[  2583.136] (II) evdev: Logitech USB Receiver: Configuring as mouse
[  2583.136] (II) evdev: Logitech USB Receiver: Configuring as keyboard
[  2583.136] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
[  2583.136] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
[  2583.136] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  2583.136] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2.3/1-2.3:1.1/0003:046D:C52B.0002/input/input8/event5"
[  2583.136] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 11)
[  2583.136] (**) Option "xkb_rules" "evdev"
[  2583.137] (II) evdev: Logitech USB Receiver: initialized for relative axes.
[  2583.137] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
[  2583.137] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
[  2583.137] (**) Logitech USB Receiver: (accel) acceleration profile 0
[  2583.137] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
[  2583.137] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
[  2583.138] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
[  2583.138] (II) No input driver specified, ignoring this device.
[  2583.138] (II) This device may have been added with another device file.
[  2583.138] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event7)
[  2583.138] (II) No input driver specified, ignoring this device.
[  2583.138] (II) This device may have been added with another device file.
[  2583.139] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event8)
[  2583.139] (II) No input driver specified, ignoring this device.
[  2583.139] (II) This device may have been added with another device file.
[  2583.139] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event9)
[  2583.139] (II) No input driver specified, ignoring this device.
[  2583.139] (II) This device may have been added with another device file.
[  2583.140] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event6)
[  2583.140] (II) No input driver specified, ignoring this device.
[  2583.140] (II) This device may have been added with another device file.
[  2585.046] (--) intel(0): HDMI max TMDS frequency 190000KHz
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Thu Mar 16, 2017 10:54 pm    Post subject: Reply with quote

This is actually caused by sddm 0.14.0. After a manual downgrade to 0.13.0 (with the ebuild from http://gpo.zugaina.org/x11-misc/sddm/ChangeLog ), sddm works again … I'll file a bug about this.
Back to top
View user's profile Send private message
venz
n00b
n00b


Joined: 16 Mar 2017
Posts: 1

PostPosted: Thu Mar 16, 2017 11:41 pm    Post subject: Reply with quote

fighting with the same problem since days.
The only solution I came up with version 0.14.0-r2 is to config the "autologin" in

Code:
/etc/sddm.conf

Session=plasma.desktop
User="your.user"



hope that works for the moment
venz
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2309
Location: Konradsreuth (Germany)

PostPosted: Fri Mar 17, 2017 6:49 am    Post subject: Reply with quote

Join https://bugs.gentoo.org/show_bug.cgi?id=607726 so that the devs see this is no corner-case!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum