Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xfsettingsd segfault [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
squeegily
n00b
n00b


Joined: 17 Apr 2016
Posts: 57

PostPosted: Mon Mar 06, 2017 8:22 pm    Post subject: xfsettingsd segfault [solved] Reply with quote

Fresh installation, 13.0 amd64 desktop profile with XFCE4 12.0 (latest Gentoo-stable)

Most of my XFCE4 settings won't work (especially the "Display Settings"; I have to manually change those with xrandr)

Upon further investigation I'm getting this when I try to run xfsettingsd manually:
Code:
$ dbus-launch xfsettingsd --replace --no-daemon

(xfsettingsd:12374): libupower-glib-WARNING **: Couldn't connect to proxy: Could not connect: No such file or directory
Segmentation fault
$


What can I do to fix this?


Last edited by squeegily on Wed Mar 08, 2017 6:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
ShyPixie
n00b
n00b


Joined: 20 Nov 2015
Posts: 19
Location: Brazil

PostPosted: Wed Mar 08, 2017 5:38 pm    Post subject: Reply with quote

Related: https://bugs.gentoo.org/show_bug.cgi?id=598782
Back to top
View user's profile Send private message
squeegily
n00b
n00b


Joined: 17 Apr 2016
Posts: 57

PostPosted: Wed Mar 08, 2017 6:16 pm    Post subject: Reply with quote

Aha, mine was fixed by starting the system dbus service. (I was using XFCE + consolekit) Everything seems to be working well now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum