Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xfce systray not showing all icons
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sidamos
Apprentice
Apprentice


Joined: 16 Dec 2007
Posts: 210

PostPosted: Sat Mar 04, 2017 10:55 am    Post subject: [SOLVED] Xfce systray not showing all icons Reply with quote

I am trying to switch from KDE 5 to Xfce 4 and most of the things are working nicely so far.

However, the systray (notification area) is behaving unstable. These icons should always show:
- kbiff (I know, this is still KDE stuff)
- HP applet
- Parcellite (I also tried Clipman, but the icon was invisible)

Most of the time, only 1 of those 3 is displaying after login. Sometimes it's 2. Sometimes it's 0.

Each of them has at least shown once, so it's not that they are not working in general.

But the apps are all running.

libappindicator is already installed, which should help with not appearing systray icons.

Any hints? Thanks!


Last edited by sidamos on Sat Mar 04, 2017 4:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
sidamos
Apprentice
Apprentice


Joined: 16 Dec 2007
Posts: 210

PostPosted: Sat Mar 04, 2017 4:33 pm    Post subject: Reply with quote

Seems that this is a timing problem. I added "sleep 10" to the launch command of kbiff:
sh -c "sleep 10; exec kbiff -profile Inbox"

And I created a script with the same delay as "/usr/local/bin/hp-systray":
#!/bin/bash
sleep 10
/usr/bin/hp-systray

Solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum