Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XDM fails to start KDE desktop (NVIDIA)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
libfab
n00b
n00b


Joined: 17 Dec 2016
Posts: 4

PostPosted: Sun Feb 26, 2017 4:04 pm    Post subject: [SOLVED] XDM fails to start KDE desktop (NVIDIA) Reply with quote

There seemingly is an OpenGL incompatibilty between the new mesa ebuilds (version 12.01 recentlly sync'ed) and NVIDIA drivers.
I run a GTX 970 Nvidia card and driver is the latest from proprietary installer (NVIDIA-Linux-x86_64-375.39.run downloaded from NVIDIA's website)
Installing gentoo nvidia-drivers did not solve the issue, even by closely following the gentoo manual dedicated page.

Platform is stable branch amd64 built against g++-5.4.

Reverting to mesa 11.2.2 solved the issue completely without having to rebuild any external dependency or apps, so the issue is strictly mesa-related.

I just wanted to know if there were known ways out before possibly filing a bug report.


Last edited by libfab on Sat Mar 04, 2017 7:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
libfab
n00b
n00b


Joined: 17 Dec 2016
Posts: 4

PostPosted: Sat Mar 04, 2017 7:11 pm    Post subject: Solved with full rebuild Reply with quote

Issue was solved by rebuilding all gcc-related dependencies.
I conjecture that there may have been reverse dependencies that should have been rebuilt after the new mesa install yet remained undetected by portage and revdep-rebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum