Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem when printing from within Firefox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Fri Feb 17, 2017 4:59 pm    Post subject: Problem when printing from within Firefox Reply with quote

I have an HP Officejet 7410 printer that is working fine for years within my Gentoo enviroment.

But now I have a problem when printing web pages from within Firefox: white horizontal lines making the printed text unreadable. See https://www.dropbox.com/s/8auzcs8vx9y4f1x/image.jpeg?dl=0 for an example.

I do not have the same problem when printing for example with LibreOffice of when printing web pages from within Chrome. I have the problem (but to a much lesser extent) when printing from within Firefox in Windows.

Cleaning the printheads via HPLIP has not helped (was not expected as the problem is linked to the use of Firefox).

Searching the web has not give anything useful.

Any help from the Gentoo community?

Many thanks in advance.


Last edited by kdvgent on Sun Feb 19, 2017 11:23 am; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Feb 18, 2017 10:24 am    Post subject: Reply with quote

that file is not accessable

Usually it is a cups issue or a wrong configured printer.

Please print as pdf in firefox. and than open it (not in any browser of course) and check if the output is as desired.

what is the output of print preview in firefox?
Back to top
View user's profile Send private message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Sun Feb 19, 2017 11:37 am    Post subject: Reply with quote

Thanks for your reply.
  • I changed the link from Google drive to Dropbox and hope that it is OK.
  • If it should be a cups problem than I would have the problem independent from within which program I print but that is not the case. Printer is installed and configured via HPLIP
  • First printing from Firefox to PDF and then printing the PDF file gives the same problem
  • Print preview in Firefox is OK
  • Additional observation: the problem does not appear on the first page but only on the second page of the print-out
  • And as said the same webpage prints without any problem via Chrome
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sun Feb 19, 2017 12:37 pm    Post subject: Reply with quote

your firofox version is it the mozilla binary or self compiled from the ebuild
Back to top
View user's profile Send private message
kdvgent
Guru
Guru


Joined: 29 Sep 2004
Posts: 333
Location: Belgium

PostPosted: Sun Feb 19, 2017 6:34 pm    Post subject: Reply with quote

My firefox version is self compiled
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum