Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keymap on Plasma (konsole&generally) still US layout[SOLVED]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
vode
n00b
n00b


Joined: 16 Jul 2002
Posts: 26
Location: Finland

PostPosted: Mon Feb 20, 2017 9:04 pm    Post subject: Reply with quote

Me too have a same problem as you transsib. Thank you for your advice. By typing setxkbmap fi I get my finnish keyboard working in kde. In native console my keyboard is finnish. Tried re-compile ksystemsetting and kde-l10n packages. No help.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Mon Feb 20, 2017 9:15 pm    Post subject: Reply with quote

Do you also have "keyboard mouse" defined in INPUT_DEVICES, in addition to evdev? These two are long obsolete, I'm wondering if that is the real issue behind all this.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
vode
n00b
n00b


Joined: 16 Jul 2002
Posts: 26
Location: Finland

PostPosted: Mon Feb 20, 2017 9:58 pm    Post subject: Reply with quote

astrum:

No mouse. In make.cong for INPUT_DEVICES="evdev" only. As you are thinking, there might be something old left over in configs some where that should be cleaned away...
Back to top
View user's profile Send private message
vode
n00b
n00b


Joined: 16 Jul 2002
Posts: 26
Location: Finland

PostPosted: Mon Feb 20, 2017 10:02 pm    Post subject: Reply with quote

Sorry - I read your message a new. "evdev" obsolete - since when. But I try that.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Mon Feb 20, 2017 10:06 pm    Post subject: Reply with quote

evdev only is fine, though at some point we ought to move on to libinput. "keyboard" and "mouse" are the ones that are obsolete.

It would also be good to check in Xorg.0.log which of the X11 config dirs it is actually reading from.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 816

PostPosted: Tue Feb 21, 2017 2:36 pm    Post subject: Reply with quote

Keyboard & mouse in INPUT_DEVICES deprecated?
I must have missed out on this piece of information.
I still have those entries in make.conf but if they are deprecated
I think it is safe to remove them.

My layout seems to be ok for now. I still have wayland and libinput on the system
but no weston and no special config for wayland. It`s just there.

I have put -wayland in the make.conf; don't know whether or not it has any effect though.
Then reemerged world.

In case keymap reverts back again I know which workaround to use. And I can still
follow Fitzcarraldos advice on putting it into startup.

For now I will not mark this thread as solved; if I'm good until next week I might.

Thanks to all and greetings to Finland :) ; seems I was not alone with ths.
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 816

PostPosted: Wed Feb 22, 2017 8:29 am    Post subject: Reply with quote

When do I have to exchange evdev with libinput in the make.conf?
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 816

PostPosted: Wed Feb 22, 2017 8:52 pm    Post subject: Reply with quote

At the risk of unnerving all of you ... @asturm

I've read up on wayland and especially libinput.
Am I right to assume that wayland and libinput are supposed to slowly replace
the old xorg-server and that libinput is closely connected to Plasma?

I decided to give all this another try: I removed -wayland from make.conf (though wayland not use flag globally)
and replaced evdev with libinput.

The wiki for libinput wants to create a symlink
Code:
ln -s /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/

which I had to correct to 60-libinput.conf because there's no 40-libinput.conf in
/usr/share/X11/xorg.conf.d/ ; the file is called 60-libinput.conf .

I removed 10-evdev.conf from /etc/X11/xorg.conf.d/ and unmerged all xf86 -* drivers
including xf86-input-evdev so that there is no reference to evdev left on the system.

Libinput should work as is but it doesn't.

I still have to call run with ALT-F2 and setxkbmap de manually.

log file for xorg says
Code:
[  6103.602] (II) libinput:   wired keyboard: is a virtual subdevice
[  6103.602] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.1/0003:046A:01
80.0005/input/input9/event6"
[  6103.602] (II) XINPUT: Adding extended input device "  wired keyboard" (type: KEYBOARD, id 14)


[  6105.032] (EE) Error loading keymap /tmp/server-0.xkm
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 816

PostPosted: Fri Mar 03, 2017 12:19 pm    Post subject: Reply with quote

Did
Code:
emerge -1 $(qlist -CI kde-frameworks/*)


a few times.
Since then my proper keymap is set automatically.

That's how it should be.

Marked thread as solved now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum