Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireless connection keeps dropping on kernel 4.9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Mardok45
n00b
n00b


Joined: 21 Jun 2008
Posts: 68
Location: Right behind you

PostPosted: Sun Feb 12, 2017 10:10 pm    Post subject: Wireless connection keeps dropping on kernel 4.9 Reply with quote

I'm running ~amd64.

I'm not sure if the problem is in the kernel or NetworkManager, but after upgrading to kernel version 4.9 from 4.4, the connection keeps dropping for some unknown reason. It seems the interface is constantly being brought down and back up.

dmesg
Code:
[  654.808240] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  654.825789] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  654.827856] wlp3s0: authenticated
[  654.829768] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  654.833827] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  654.833934] wlp3s0: associated
[  674.736952] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  674.754411] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  674.756350] wlp3s0: authenticated
[  674.758249] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  674.762266] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  674.762371] wlp3s0: associated
[  711.801719] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  711.819376] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  711.821317] wlp3s0: authenticated
[  711.822179] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  711.826200] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  711.826305] wlp3s0: associated
[  742.794489] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  742.812235] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  742.815513] wlp3s0: authenticated
[  742.815862] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  742.819893] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  742.819996] wlp3s0: associated
[  748.786845] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  748.804152] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  748.806084] wlp3s0: authenticated
[  748.808024] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  748.812059] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  748.812173] wlp3s0: associated
[  758.786533] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  758.804051] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  758.805985] wlp3s0: authenticated
[  758.806190] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  758.810218] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  758.810328] wlp3s0: associated
[  769.803153] wlp3s0: authenticate with XX:XX:XX:XX:XX:XX
[  769.820549] wlp3s0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
[  769.822491] wlp3s0: authenticated
[  769.823406] wlp3s0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
[  769.829621] wlp3s0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x411 status=0 aid=2)
[  769.829725] wlp3s0: associated


NetworkManager: This message keeps repeating.
Code:

Feb 12 17:04:15 mardok-laptop-gentoo NetworkManager[2116]: <warn>  [1486937055.8134] sup-iface[0x1662ab0,wlp3s0]: connection disconnected (reason -4)
Feb 12 17:04:15 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937055.8276] device (wlp3s0): supplicant interface state: completed -> disconnected
Feb 12 17:04:15 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937055.9196] device (wlp3s0): supplicant interface state: disconnected -> scanning
Feb 12 17:04:16 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937056.9935] device (wlp3s0): supplicant interface state: scanning -> authenticating
Feb 12 17:04:17 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937057.0005] device (wlp3s0): supplicant interface state: authenticating -> associated
Feb 12 17:04:17 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937057.0137] device (wlp3s0): supplicant interface state: associated -> 4-way handshake
Feb 12 17:04:17 mardok-laptop-gentoo NetworkManager[2116]: <info>  [1486937057.0232] device (wlp3s0): supplicant interface state: 4-way handshake -> completed


I only get this problem when running the 4.9 kernel. 4.4 works fine. Any help will be appreciated.
Back to top
View user's profile Send private message
Mardok45
n00b
n00b


Joined: 21 Jun 2008
Posts: 68
Location: Right behind you

PostPosted: Mon Feb 20, 2017 12:26 am    Post subject: Reply with quote

My problem is very similar to these threads:

https://forum.manjaro.org/t/realtek-rtl8192ce-driver-issues-with-kernel-4-9-6/16906
https://bugs.archlinux.org/task/52741

Looks like I'm not the only one, and ath9k is not the only driver affected. Has anyone else experienced this issue and have you found a fix?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum