Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qtgui egl use flag both required and prohibited [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jesnow
Guru
Guru


Joined: 26 Apr 2006
Posts: 581

PostPosted: Sun Feb 12, 2017 5:18 pm    Post subject: qtgui egl use flag both required and prohibited [solved] Reply with quote

Posted here for general edification:
During a world update I had a small issue:
Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-qt/qtgui-5.6.1:5[egl] required by (kde-frameworks/kwayland-5.29.0:5/5.29::gentoo, installed)
                           ^^^
    ~dev-qt/qtgui-5.6.2[egl] required by (dev-qt/qtwayland-5.6.2:5/5.6::gentoo, installed)

OK fine whatever, switch that use flag off for qtgui (not that that's 'l' as in Lima, not the number '1')
And then I get:
Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,-egl,qt3support,abi_x86_32(-)] required by (dev-qt/qtopengl-4.8.6-r1:4/4::gentoo, installed)
                                   ^^^^                         

Wait, what? Some packages require qtgui to have 'egl' and others require '-egl'?
The astute among you have divined already that slots are involved. qt4 and qt5 to be precise.
The following lines in /etc/portage/package.use fix it:
Code:

dev-qt/qtwayland egl
dev-qt/qtgui:5 egl
dev-qt/qtgui:4 -egl

I don't even know what it does.
Done.


[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Sun Feb 12, 2017 7:19 pm    Post subject: Reply with quote

Quote:
Wait, what? Some packages require qtgui to have 'egl' and others require '-egl'?



In this case, it's not that some packages need ewgl and others do not, it's more of qtopengl needs to have the same setting for egl as qtgui...

From qtopengl-4.8.6-r1.ebuild:
Code:
~dev-qt/qtgui-${PV}[aqua=,debug=,egl=,qt3support=,${MULTILIB_USEDEP}]


This is a common issue, is packages needing the same USE flags as of it's dependency (also hard to notice from the error messages).

Otherwise you are correct in the qt4 and qt5 slot portion.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum