Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Not determined the sound card.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 6:47 pm    Post subject: [Solved] Not determined the sound card. Reply with quote

Not determined the sound card.
System selinux, hardened. Displays program card Dummy Output.
Kernel config there https://paste.pound-python.org/show/nN7zOxcYBP5xa0jFd3RU/
Linux localhost.localdomain 4.8.17-hardened-r2 #1 SMP Thu Feb 9 20:33:21 MSK 2017 x86_64 Intel(R) Core(TM)2 Duo CPU E8500 @ 3.16GHz GenuineIntel GNU/Linux
Please help!


Last edited by sergei on Fri Feb 10, 2017 12:03 am; edited 1 time in total
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 6:50 pm    Post subject: Reply with quote

Equipment:
0:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIB (ICH10) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9600 GT] (rev a1)
03:00.0 IDE interface: JMicron Technology Corp. JMB368 IDE controller
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 02)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 7:04 pm    Post subject: Reply with quote

sergei,

Its a
Code:
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller

Your kernel has CONFIG_SND_HDA_INTEL=m and all the codecs, which looks promising.

What does
Code:
ls -l /dev/snd
show?

What does groups show, when its run by your normal user?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 7:10 pm    Post subject: Reply with quote

ls -l /dev/snd:
drwxr-xr-x 2 root root 60 Feb 9 21:32 by-path
crw-rw----+ 1 root audio 116, 2 Feb 9 21:32 controlC0
crw-rw----+ 1 root audio 116, 8 Feb 9 21:32 hwC0D2
crw-rw----+ 1 root audio 116, 4 Feb 9 21:32 pcmC0D0c
crw-rw----+ 1 root audio 116, 3 Feb 9 21:32 pcmC0D0p
crw-rw----+ 1 root audio 116, 6 Feb 9 21:32 pcmC0D1c
crw-rw----+ 1 root audio 116, 5 Feb 9 21:32 pcmC0D1p
crw-rw----+ 1 root audio 116, 7 Feb 9 21:32 pcmC0D2c
crw-rw---- 1 root audio 116, 1 Feb 9 21:32 seq
crw-rw----+ 1 root audio 116, 33 Feb 9 21:32 timer

Groups:
wheel audio users vmware vboxusers ser12.


Last edited by sergei on Thu Feb 09, 2017 7:19 pm; edited 3 times in total
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 7:15 pm    Post subject: Reply with quote

Maybe the problem in selinuxs or hardened?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 7:21 pm    Post subject: Reply with quote

sergei.

As your normal user, give the groups command.
Code:
$ groups
tty wheel uucp audio cdrom video games kvm cdrw users vboxusers scanner wireshark plugdev


You must be in the audio group to use the sound card.

Your /dev/snd looks good and you have only one sound card. That simplifies things.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 7:30 pm    Post subject: Reply with quote

I in audio group but sound card Dummy Output. No hardware Output devices.

$ groups
wheel audio cdrom video users plugdev vmware vboxusers ser12
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 7:39 pm    Post subject: Reply with quote

sergei,

As root, run
Code:
alsa-info.sh
and put the output onto a pastebin please.
Its too big for a post. A tleast, it should be.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 7:41 pm    Post subject: Reply with quote

$ alsa-info.sh
bash: alsa-info.sh: command not found
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2546

PostPosted: Thu Feb 09, 2017 7:46 pm    Post subject: Reply with quote

Well at least that is an easy fix. Install media-sound/alsa-utils and try again.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 7:49 pm    Post subject: Reply with quote

sergei,

Open a root shell.
Code:
alsa-info.sh
Follow the on screen prompts.
At the end, choose UPLOAD/SHARE.

It will give you a link
Code:

Your ALSA information is located at http://www.alsa-project.org/db/?f=77b00af572cf26d5bd67cd7199e7ec4aab5a313f

Please inform the person helping you.

That's my alsa-info.sh

Post the link
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 7:59 pm    Post subject: Reply with quote

$ alsa-info.sh
ALSA Information Script v 0.4.64
--------------------------------

This script visits the following commands/files to collect diagnostic
information about your ALSA installation and sound related hardware.

dmesg
lspci
lsmod
aplay
amixer
alsactl
/proc/asound/
/sys/class/sound/
~/.asoundrc (etc.)

See '/usr/sbin/alsa-info.sh --help' for command line options.

pcilib: sysfs_read_vpd: read failed: Input/output error
cat: /sys/class/sound/hwC0D2/user_pin_configs: No such file or directory
cat: /sys/class/sound/hwC0D2/init_verbs: No such file or directory
cat: /sys/class/sound/hwC0D2/hints: No such file or directory
Automatically upload ALSA information to www.alsa-project.org? [y/N] : y
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://www.alsa-project.org/db/?f=efcc0496525396167f8f7e44e49013159abe6fea

Please inform the person helping you.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 8:14 pm    Post subject: Reply with quote

The ALSA-mixer has a map of 0 HDA Intel. But the sound is still there.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 8:15 pm    Post subject: Reply with quote

sergei,

You have alsa and pulseaudio installed. Pulseaudio is a wrapper around alsa.
If you want to use pulseaudio, some things insist on it, you need to configure your alsa apps to use it to.
I can't help there - I do not have pulseaudio installed.

If you run
Code:
alsamixer
it may only show you the pulseaudio controls.
If you can see your audio mixer controls, check that all controls with IEC or SPDI/F in their names are muted.
These are digital output controls and if both digital and analogue controls are enabled, digital takes priority and you get nothing out of your speakers.

Everything else looks good.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 8:21 pm    Post subject: Reply with quote

How to make a map of HDA Intel card default?
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 8:46 pm    Post subject: Reply with quote

pavucontrol says: No hardware output devices.
Sounds of cinnamon says: Dummy output.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 9:01 pm    Post subject: Reply with quote

sergei,

What does alsamixer say ?
Thats a terminal window command.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 9:21 pm    Post subject: Reply with quote

alsamixer, hit F6:
- (default)
0 HDA Intel
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 9:27 pm    Post subject: Reply with quote

sergei,

With lots of controls or just a pulseaudio slider?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 9:32 pm    Post subject: Reply with quote

$alsamixer F6: Select sound card.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42563
Location: 56N 3W

PostPosted: Thu Feb 09, 2017 10:02 pm    Post subject: Reply with quote

sergei,

It should show an image.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 11:26 pm    Post subject: Reply with quote

HDA INTEL

Card: HDA Intel F1: Help │
│ Chip: Realtek ALC888 F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: Master [dB gain: 0.00] Esc: Exit │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ ┌──┐ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ →
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │▒▒│ │
│ ├──┤ ├──┤ └──┘ ├──┤ ├──┤ └──┘ ├──┤ ├──┤ ├──┤ ├──┤ ├──┤ └──┘ ├──┤ ┌──┐ ┌──┐ │
│ │MM│ │MM│ │OO│ │MM│ │MM│ │MM│ │MM│ │MM│ │MM│ │OO│ │OO│ │OO│ │
│ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ └──┘ │
│ 100 100<>100 100<>100 100<>100 100<>100 100<>100 100<>100 100 100 100<>100 100<>100 100<>100 100<>100 │
│ < Master >Headphon PCM Front Front Mi Front Mi Surround Center LFE Side Line Line Boo CD S/PDIF S/PDIF D │
│ │
│ │
│ │
│ │
│ │
│ │
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Thu Feb 09, 2017 11:27 pm    Post subject: Reply with quote

Default
Card: PulseAudio F1: Help │
│ Chip: PulseAudio F2: System information │
│ View: F3:[Playback] F4: Capture F5: All F6: Select sound card │
│ Item: Master Esc: Exit │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ │
│ ┌──┐ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ │▒▒│ │
│ ├──┤ │
│ │OO│ │
│ └──┘ │
│ 100<>100 │
│ < Master > │
│ │
│ │
│ │
│ │
│ │
Back to top
View user's profile Send private message
sergei
n00b
n00b


Joined: 26 Jan 2017
Posts: 39
Location: Ukraine

PostPosted: Fri Feb 10, 2017 12:02 am    Post subject: Reply with quote

Introduced load-module module-alsa-sinc in /ets/pulse/default.pa.
The sound card is picked. Problem is solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum