Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas com o emerge
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
fsanches
n00b
n00b


Joined: 23 Jun 2003
Posts: 27
Location: Lisboa - Portugal

PostPosted: Fri Nov 14, 2003 5:44 pm    Post subject: Problemas com o emerge Reply with quote

Estava a instalar uns pacotes de updates e infelizmente fiquei sem espaco em disco.
Depois de libertar algum espaco tentei correr o "emerge -up world" e ate instalar alguns pacotes individuais e obtenho sempre este erro:

Code:
puma var # emerge -up world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
Traceback (most recent call last):
  File "/usr/bin/emerge", line 2133, in ?
    mydepgraph.display(mydepgraph.altlist())
  File "/usr/bin/emerge", line 1103, in display
    elif (not "--emptytree" in myopts) and portage.db[x[1]]["vartree"].exists_specific_cat(x[2]):
  File "/usr/lib/python2.2/site-packages/portage.py", line 3469, in exists_specific_cat
    self.invalidentry(self.root+"var/db/pkg/"+a[0]+"/"+x)
AttributeError: vartree instance has no attribute 'invalidentry'


ou este:


Code:
>>> Auto-cleaning packages ...
!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd!!! Invalid db entry: /var/db/pkg/*sys-fs/devfsd
>>> No outdated packages were found on your system.


 * GNU info directory index is up-to-date.


Aparentemente tenho o sistema portage corrompido de algum modo.
Ideias?

Já fiz fixpackages e emerge regen.

Help...
Back to top
View user's profile Send private message
mamsbrl
n00b
n00b


Joined: 16 May 2002
Posts: 53
Location: Boca Raton - Florida, USA

PostPosted: Fri Nov 14, 2003 6:11 pm    Post subject: Reply with quote

Ja tentou sincronizar de novo o portage?

emerge sync
Back to top
View user's profile Send private message
fsanches
n00b
n00b


Joined: 23 Jun 2003
Posts: 27
Location: Lisboa - Portugal

PostPosted: Mon Nov 17, 2003 10:27 am    Post subject: Reply with quote

Já. Funciona sem problemas. O que falha é o emerge world.
Dá sempre o erro referido acima.
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Mon Nov 17, 2003 3:39 pm    Post subject: Reply with quote

Já tentou dar uma olhada no seu arquivo world a procura de alguma entrada inválida?
Code:
cat /var/cache/edb/world | grep sys-fs

_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
psmmr
n00b
n00b


Joined: 10 Jan 2004
Posts: 11
Location: Portugal, Lisboa

PostPosted: Mon Jan 12, 2004 11:30 pm    Post subject: Reply with quote

o problema que estás a ter com /var/db/pkg/*sys-fs/devfsd já foi referido no forum geral: https://forums.gentoo.org/viewtopic.php?t=105082. O outro não sei...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum