Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Browser continues to redirect after website changes (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
wynn
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2421
Location: UK

PostPosted: Mon Feb 06, 2017 6:21 pm    Post subject: Browser continues to redirect after website changes (solved) Reply with quote

On Thursday last my bank has a problem with online banking and set up a redirection on their site from the login page to
a "Sorry" page.

Since then, although the bank has returned login to normal, the browsers on this machine all go to the redirected page.

Cache and history are set to be cleared when the browsers exit: I have tried uninstalling the browsers (Firefox and SeaMonkey), deleting the entry in .cache and deleting .mozilla and reinstalling them without changing their behaviour; I have installed other browsers (Chromium (4hrs!!) and Vivaldi) and they do the same thing. Even w3m, a text mode browser does it.

I tried to login on my laptop while the page was up and browsers on that are still showing the "Sorry" page.

The only machine which doesn't wasn't ever used to login to the site when the page was up.

Here is the emerge --info for this machine:
Code:

Portage 2.3.3 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.4, glibc-2.23-r3, 4.9.6-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.9.6-gentoo-r1-x86_64-AMD_A10-5800K_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.3
KiB Mem:    30847712 total,  24338616 free
KiB Swap:   17276916 total,  17276916 free
Timestamp of repository gentoo: Mon, 06 Feb 2017 10:45:01 +0000
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [enabled]
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.3_rc4::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.7.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://excession.etowers.net/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 AdobeFlash-10.3 AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.bytemark.co.uk/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 audiofile berkdb branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt cups cxx dbus directfb dri dts dvd dvdr emboss encode exif fam fbcon ffmpeg firefox flac fontconfig gdbm gif gimp glamor gpm gtk iconv imagemagick jpeg lcms libnotify lock loop-aes mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl nsplugin ogg openal opengl openmp pam pango pcre pdf png policykit postscript ppds qt3support qt4 readline scanner sdl seccomp session spell sse sse2 ssl startup-notification svg tcpd theora thunar tiff truetype udev udisks unicode upower usb vorbis wma wxwidgets x264 xattr xcb xft xml xpm xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="en_GB en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" SANE_BACKENDS="epson" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

_________________
The avatar is jorma, a "duck" from "Elephants Dream": the film and all the production materials have been made available under a Creative Commons Attribution 2.5 License, see orange.blender.org for details.


Last edited by wynn on Tue Feb 07, 2017 5:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Mon Feb 06, 2017 9:42 pm    Post subject: Reply with quote

Well, something is still cached...

Were all the machines rebooted (to clear DNS cache?)

Does your router cache something?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13509

PostPosted: Tue Feb 07, 2017 2:14 am    Post subject: Reply with quote

If a browser you never used before has the problem, then the problem is not on your system. HTTP caching is done in the individual client, not on the system as a whole. They probably have the bad page up somewhere and tried to redirect people away from the redirect, but failed at it. I would monitor network traffic when fetching the page to verify that your system talks to theirs. Use curl or wget to fetch their page. Those have no automatic cache, so if they hit a bad redirect, then that says the peer is still emitting bad redirects. My guess is that they have a load balancing scheme that relies on multiple co-equal Internet-accessible servers, that one of those servers still emits the bad redirect, and that when they tried to stop sending the redirect, they only updated some, but not all of the servers. It probably works just barely well enough that they think it is correct.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Tue Feb 07, 2017 9:01 am    Post subject: Reply with quote

cookie can do that too (combine with badly coded homepage)
- first log -> cookie set with "last visit="/accounting"
- next visit -> redirection base on cookie result, so trying to jump to /accounting", while your bank as change it to "/account"
that's why even your bank said, we have fix it, as long as you don't clear your cookie, their stupid homepage will load the cookie and try redirect to death to /accounting, and as /accounting no more exists, you'll get redirect to "sorry page".
it's so ugly, because if they change /accounting to /account, they should had also drop the cookie name to force using a new one, if cookie is name "lvisit" just handling a new cookie name would had fix that "l_visit", as your computer will have an "lvisit" cookie, but not yet a "l_visit".

and guess it: cookies are not clear by cache and history clear.
Back to top
View user's profile Send private message
wynn
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2421
Location: UK

PostPosted: Tue Feb 07, 2017 5:25 pm    Post subject: Reply with quote

Thank you all for your replies.

@krinn: I tried turning cookies off in Firefox but it didn't cure the problem

@Hu: I think your suggestion is probably the right one as the problem has disappeared after my telephone call to the bank yesterday.

@eccerr0r: ...or, as you suggest, the router. I don't know anything about its innards but I switched it off and on again because it had gone into a sulk and wasn't talking to anyone...

Thanks again -- it's nice to know that there's somewhere to turn to with an intractable problem.. :)
_________________
The avatar is jorma, a "duck" from "Elephants Dream": the film and all the production materials have been made available under a Creative Commons Attribution 2.5 License, see orange.blender.org for details.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum