Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ricompilazione pacchetti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Fri Feb 03, 2017 10:46 pm    Post subject: Ricompilazione pacchetti Reply with quote

Ciao a tutti... Ho un strano problema con emerge, mi chiede di ricompilare dei pacchetti ogni volta che aggiorno. Non capisco perche lo fa, oltre che ho anche un po di conflitti che non capisco come risolvere.

Code:

Calculating dependencies... done!
[ebuild  rR    ] dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo  USE="nls python threads -context -debug -doc -icu -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4" 0 KiB
[ebuild  rR    ] dev-libs/librevenge-0.0.4::gentoo  USE="-doc {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-util/mdds-1.2.2:1/1.2::gentoo  USE="-doc -valgrind" 0 KiB
[ebuild  rR    ] dev-libs/libixion-0.11.1:0/0.11::gentoo  USE="-python -static-libs" PYTHON_SINGLE_TARGET="python3_4 (-python3_5)" PYTHON_TARGETS="python3_4 (-python3_5)" 0 KiB
[ebuild  rR    ] dev-libs/liborcus-0.11.2:0/0.11::gentoo  USE="spreadsheet-model -python -static-libs -tools" PYTHON_SINGLE_TARGET="python3_4 (-python3_5)" PYTHON_TARGETS="python3_4 (-python3_5)" 0 KiB
[ebuild  rR    ] dev-cpp/libcmis-0.5.2_pre20160820:0.5::gentoo  USE="-man -static-libs {-test}" 0 KiB
[ebuild  rR    ] app-office/libreoffice-5.2.3.3-r1::gentoo  USE="branding cups dbus gnome gtk (-aqua) -bluetooth (-coinmp) -collada -debug -eds (-firebird) -gltf -googledrive -gstreamer -gtk3 -java -jemalloc -kde (-libressl) -mysql -odk -pdfimport -postgres -quickstarter (-telepathy) {-test} -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 0 KiB

Total: 7 packages (7 reinstalls), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libusb:1

  (dev-libs/libusb-1.0.19-r1:1/1::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libusb-1.0.19:1[udev(+),abi_x86_64(-)] required by (virtual/libusb-1-r2:1/1::gentoo, installed)
                                                     

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtgui-4.8.6[accessibility,-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                                   ^^^^^^^^^^               
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
                                          ^^^^^^^^^^               

virtual/libgudev:0

  (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge) conflicts with
    virtual/libgudev:=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^
    =virtual/libgudev-230[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^
    virtual/libgudev:0/0=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^

app-text/xmlto:0

  (app-text/xmlto-0.0.26-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/xmlto-0.0.26-r1[text(+)] required by (x11-misc/xdg-utils-1.1.1-r1:0/0::gentoo, installed)
                                       

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
                                           ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               

virtual/libusb:1

  (virtual/libusb-1-r2:1/1::gentoo, ebuild scheduled for merge) conflicts with
    virtual/libusb:1[udev,abi_x86_64(-)] required by (dev-libs/libgusb-0.2.9:0/0::gentoo, installed)
                     ^^^^               
    =virtual/libusb-1-r2[udev,abi_x86_64(-)] required by (dev-libs/libgusb-0.2.9:0/0::gentoo, installed)
                         ^^^^               


!!! The following update has been skipped due to unsatisfied dependencies:

dev-libs/boost:0

!!! All ebuilds that could satisfy "=dev-util/boost-build-1.62*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/boost-build-1.62.0-r1::gentoo (masked by: )

(dependency required by "dev-libs/boost-1.62.0-r1::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Would you like to merge these packages? [Yes/No]


_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sat Feb 04, 2017 12:45 pm    Post subject: Reply with quote

Hai mascherato to dev-util/boost-build-1.62 (controlla /etc/portage/package.mask)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Feb 04, 2017 4:26 pm    Post subject: Reply with quote

non ho niente

Code:
 

###############################
## Aggiornamento a Gnome3 #####
###############################
#=net-libs/libsoup-2.42.3.1
#=x11-themes/gnome-backgrounds-3.8.1

###############################
# problema con aggiornamenti ##
#=media-gfx/exiv2-0.24

################################
########## mesa ################
#=media-libs/mesa-10.2.8
#=x11-base/xorg-server-1.15.2-r1
#=x11-base/xorg-server-1.12.4-r3
###################################
#=dev-python/qscintilla-python-2.8.4

###################################
# per il blocco della compilazione #
#sys-fs/udev
#sys-fs/eudev
#sys-apps/gentoo-systemd-integration
#=virtual/udev-215
#=virtual/libudev-215-r1

###################################
#=net-libs/webkit-gtk-2.10.9



comunque se ci fai caso l'errore è strano perche non indica niente


Quote:

dev-util/boost-build-1.62.0-r1::gentoo ( masked by: )


_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sat Feb 04, 2017 4:53 pm    Post subject: Reply with quote

E se provi a dare in emerge -pv =dev-util/boost-build-1.62.0-r1 cosa dice portage?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Feb 04, 2017 5:50 pm    Post subject: Reply with quote

emerge -pv =dev-util/boost-build-1.62.0-r1 wrote:
[ebuild U ] dev-util/boost-build-1.62.0-r1::gentoo [1.55.0-r1::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="python2_7" 82533 KiB

Total: 1 package (1 upgrade), Size of downloads: 82533 KiB

* IMPORTANT: 5 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.


_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sat Feb 04, 2017 6:16 pm    Post subject: Reply with quote

Per prima cosa prova a vedere se le 5 news che hai da leggere se ti suggeriscono qualcosa.
E provare ad aggiornare boost-build e anche boost singolarmente e poi provare a fare un update world?
Code:
# emerge -u boost-build boost
# emerge --with-bdeps y -uDNUa @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Feb 04, 2017 7:45 pm    Post subject: Reply with quote

dopo aver aggiornato mi chiede di tornare di nuovo alla versione precedente
Code:

gentoo-laptop tani # emerge -u boost-build

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/boost-build-1.62.0-r1::gentoo [1.55.0-r1::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="python2_7" 55733 KiB

Total: 1 package (1 upgrade), Size of downloads: 55733 KiB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-util/boost-build-1.62.0-r1::gentoo
>>> Installing (1 of 1) dev-util/boost-build-1.62.0-r1::gentoo
>>> Recording dev-util/boost-build in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 1.17, 0.64, 0.44
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
gentoo-laptop tani # emerge --with-bdeps y -uDNUa @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD~] dev-util/boost-build-1.55.0-r1::gentoo [1.62.0-r1::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  rR    ] dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo  USE="nls python threads -context -debug -doc -icu -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4" 0 KiB
[ebuild  rR    ] dev-libs/librevenge-0.0.4::gentoo  USE="-doc {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  rR    ] dev-util/mdds-1.2.2:1/1.2::gentoo  USE="-doc -valgrind" 0 KiB
[ebuild  rR    ] dev-libs/libixion-0.11.1:0/0.11::gentoo  USE="-python -static-libs" PYTHON_SINGLE_TARGET="python3_4 (-python3_5)" PYTHON_TARGETS="python3_4 (-python3_5)" 0 KiB
[ebuild  rR    ] dev-libs/liborcus-0.11.2:0/0.11::gentoo  USE="spreadsheet-model -python -static-libs -tools" PYTHON_SINGLE_TARGET="python3_4 (-python3_5)" PYTHON_TARGETS="python3_4 (-python3_5)" 0 KiB
[ebuild  rR    ] dev-cpp/libcmis-0.5.2_pre20160820:0.5::gentoo  USE="-man -static-libs {-test}" 0 KiB
[ebuild  rR    ] app-office/libreoffice-5.2.3.3-r1::gentoo  USE="branding cups dbus gnome gtk (-aqua) -bluetooth (-coinmp) -collada -debug -eds (-firebird) -gltf -googledrive -gstreamer -gtk3 -java -jemalloc -kde (-libressl) -mysql -odk -pdfimport -postgres -quickstarter (-telepathy) {-test} -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_4 (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 0 KiB

Total: 8 packages (1 downgrade, 7 reinstalls), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-libs/libusb:1

  (dev-libs/libusb-1.0.19-r1:1/1::gentoo, ebuild scheduled for merge) conflicts with
    >=dev-libs/libusb-1.0.19:1[udev(+),abi_x86_64(-)] required by (virtual/libusb-1-r2:1/1::gentoo, installed)
                                                     

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtgui-4.8.6[accessibility,-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                                   ^^^^^^^^^^               
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
                                          ^^^^^^^^^^               

virtual/libgudev:0

  (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge) conflicts with
    virtual/libgudev:=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^
    =virtual/libgudev-230[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^
    virtual/libgudev:0/0=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^

app-text/xmlto:0

  (app-text/xmlto-0.0.26-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/xmlto-0.0.26-r1[text(+)] required by (x11-misc/xdg-utils-1.1.1-r1:0/0::gentoo, installed)
                                       

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
                                           ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               

virtual/libusb:1

  (virtual/libusb-1-r2:1/1::gentoo, ebuild scheduled for merge) conflicts with
    virtual/libusb:1[udev,abi_x86_64(-)] required by (dev-libs/libgusb-0.2.9:0/0::gentoo, installed)
                     ^^^^               
    =virtual/libusb-1-r2[udev,abi_x86_64(-)] required by (dev-libs/libgusb-0.2.9:0/0::gentoo, installed)
                         ^^^^               


!!! The following update has been skipped due to unsatisfied dependencies:

dev-libs/boost:0

!!! All ebuilds that could satisfy "=dev-util/boost-build-1.62*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/boost-build-1.62.0-r1::gentoo (masked by: )

(dependency required by "dev-libs/boost-1.62.0-r1::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Would you like to merge these packages? [Yes/No] No



_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sat Feb 04, 2017 8:36 pm    Post subject: Reply with quote

pare che c'è un bug aperto qui https://bugs.gentoo.org/show_bug.cgi?id=554838#c39
_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Sun Feb 05, 2017 9:39 am    Post subject: Reply with quote

Come workaround prova questo
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Sun Feb 05, 2017 5:35 pm    Post subject: Reply with quote

il problema l'ho risolto con il metodo del commento n 48 nel link del bug, mi sono rimasti solo questi conflitti

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
                                           ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^               

virtual/libgudev:0

  (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge) conflicts with
    virtual/libgudev:=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^
    =virtual/libgudev-230[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^
    virtual/libgudev:0/0=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^

app-text/xmlto:0

  (app-text/xmlto-0.0.26-r1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=app-text/xmlto-0.0.26-r1[text(+)] required by (x11-misc/xdg-utils-1.1.1-r1:0/0::gentoo, installed)
                                       

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtgui-4.8.6[accessibility,-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                                   ^^^^^^^^^^               
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
                                          ^^^^^^^^^^               


Nothing to merge; quitting.

_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Feb 06, 2017 6:55 am    Post subject: Reply with quote

Puoi postare l'output del comande
Code:
$ emerge -pv dev-qt/qtcore:4 virtual/libgudev

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 151
Location: Osimo(AN)

PostPosted: Tue Feb 07, 2017 1:44 am    Post subject: Reply with quote

il risultato è questo

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/qtcore-4.8.6-r2:4::gentoo  USE="exceptions glib iconv ssl (-aqua) -debug -icu (-pch) -qt3support*" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] virtual/libgudev-230::gentoo  USE="-introspection* -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB

Total: 2 packages (2 reinstalls), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, ebuild scheduled for merge) pulled in by
    dev-qt/qtcore:4 (Argument)

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^                                                                                                                                                                                                                                                                   
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,glib=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
                                            ^^^^^^^^^^^                                                                                                                                                                                                                                                               
    ~dev-qt/qtcore-4.8.6[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
                                      ^^^^^^^^^^^                                                                                                                                                                                                                                                               

virtual/libgudev:0

  (virtual/libgudev-230:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/libgudev (Argument)

  (virtual/libgudev-230:0/0::gentoo, installed) pulled in by
    virtual/libgudev:=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                       ^^^^^^^^^^^^^                                                                                                   
    virtual/libgudev:0/0=[introspection] required by (media-gfx/shotwell-0.23.7:0/0::gentoo, installed)
                          ^^^^^^^^^^^^^                                                                                                   


It might be possible to solve these slot collisions
by applying one of the following solutions:
   - dev-qt/qtgui-4.8.6-r4 (Change USE: +debug +aqua)
   - dev-qt/qt3support-4.8.6-r1 (Change USE: +debug +aqua)
   - dev-qt/qtscript-4.8.6-r2 (Change USE: +debug +aqua)
   - virtual/libgudev-230 (Change USE: +introspection)
   - dev-qt/qtsql-4.8.6-r1 (Change USE: +debug +aqua)
   - dev-qt/qtcore-4.8.6-r2 (Change USE: +debug +qt3support +aqua)


c'è da attivare qualcuna sembra
Code:

     Installed versions:  4.8.6-r4(4)(00:17:43 02/04/2016)(accessibility exceptions glib qt3support xv -aqua -cups -debug -egl -gtkstyle -mng -nas -nis -pch -tiff -trace -xinerama ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 5.6.2(5)^t(07:13:14 03/01/2017)(dbus gif png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -gtkstyle -ibus -jpeg -libinput -test -tslib -tuio)

_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.24.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Tue Feb 07, 2017 6:47 am    Post subject: Reply with quote

Ok il messaggio ti dice che devi attivare la use flag qt3support per dev-qt/qtcore e introspection per virtual/libgudev.
Le hai disabilitate in /etc/portage/package.use?
Se no basta dare i comandi:
Code:
# echo "dev-qt/qtcore:4 qt3support" >> /etc/portage/package.use
# echo "virtual/libgudev introspection" >> /etc/portage/package.use

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum