Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
QT-5.8 released, pondering it for Gentoo ~arch
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Sun Apr 16, 2017 9:13 am    Post subject: Reply with quote

Hm, quite odd then.

Looking at my logs, I had the same error back in December 2016, with 5.7.9999 and 5.8.9999, and looking at both the build and IRC logs, that seems like the only plausible solution I can think of right now...

But yeah, I completely understand staying with 5.7.1 currently. That's probably the more rational decision. :]
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Sun Apr 16, 2017 9:43 am    Post subject: Reply with quote

@Chiitoo, could you post a list of installed packages from qt-overlay ?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Sun Apr 16, 2017 11:10 am    Post subject: Reply with quote

I sort of cleaned that installation up just some moments ago, as I'm now building 5.9.9999... but in general the list should be something QupZilla (or QtWebEngine) would pull in.

Looking at the 'emerge.log', something like this:

Code:
dev-qt/qtwebengine-5.8.9999
dev-qt/qtgui-5.8.9999
dev-qt/qtsql-5.8.9999
dev-qt/qtsvg-5.8.9999
dev-qt/qtxml-5.8.9999
dev-qt/qtwayland-5.8.9999
dev-qt/qtprintsupport-5.8.9999
dev-qt/qtwidgets-5.8.9999
dev-qt/qtconcurrent-5.8.9999
dev-qt/qttest-5.8.9999
dev-qt/qtdbus-5.8.9999
dev-qt/qtcore-5.8.9999
dev-qt/qtnetwork-5.8.9999
dev-qt/qtxmlpatterns-5.8.9999
dev-qt/linguist-tools-5.8.9999
dev-qt/qtdeclarative-5.8.9999
dev-qt/qtchooser-0_p20151008
dev-qt/qtwebengine-5.8.9999
dev-qt/qtx11extras-5.8.9999
dev-qt/qtwebchannel-5.8.9999

The list may or may not be completely complete.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Sun Apr 16, 2017 11:15 am    Post subject: Reply with quote

could you, please, post
Code:
qlist -Iv --repo ::qt


And, what DE do you use ?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Sun Apr 16, 2017 11:24 am    Post subject: Reply with quote

Zarrro packages found.

That testing box mainly uses the console only, but it does have 'x11-wm/openbox' for the GUI tests currently (will likely be 'lxqt' when and if I get it to build with 5.8/5.9).
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Sun Apr 16, 2017 11:50 am    Post subject: Reply with quote

Chiitoo wrote:
Zarrro packages found.

do you use qt-overlay, don't you?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Sun Apr 16, 2017 12:00 pm    Post subject: Reply with quote

Yes, but like I mentioned previously, I removed 'dev-qt/*' because I wanted to give 5.9 a try, and having 5.8 installed while building them packages can, will, and did result into failures.

That said, the list would have been what I mentioned earlier, had I ran the command before I removed them.

Doing pretty good progress on 5.9.9999 by the by, even if I do say so myself. I've needed to make suspiciously little changes, so I'm almost sure I'm missing something. If all goes well, there will probably be a pull request regarding this sometimeprettysoon™. :]

(I'd almost bet I've now completely jinxed it.)
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Wed Apr 19, 2017 3:31 pm    Post subject: ><)))°€ Reply with quote

I've managed to build the dependencies for 'dev-qt/qtwebengine-5.9.9999', including QtWebEngine itself, but had some issues with QupZilla.

I also got 'dev-qt/qtgui[dbus]' to build, but the 'hack' we're using seems to be (possibly) causing issues with 'kde-plasma/libkscreen', as well as other packages.

So while the 5.9.0_beta and 5.9.9999 may appear in the overlay sooner rather than later, there is still at least one major puzzle to be solved before they're actually usable in most cases.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Apr 19, 2017 7:47 pm    Post subject: Reply with quote

Thanks for doing the pioneering ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Wed Apr 19, 2017 8:17 pm    Post subject: Reply with quote

Heh. I do wish I had more of the configure system figured out by now, after having so intently stared at it for quite a while.

I'm not even sure if their switch to “GN” internally for the QtWebEngine is throwing us off a bit as well. It does look like it's running at least some of the configure tests twice... but maybe that's to be expected.

Something I forgot to mention in my previous post, with regards to the

Code:
error: ‘ResourceTypeLast’ is not a member of ‘QWebEngineUrlRequestInfo’

issue.

I'm not sure if I ever noticed, but there is actually an open bug for it upstream: QTBUG-58547

(Or at least I think it's likely about the same issue.)
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1687
Location: Here and Away Again

PostPosted: Sun Apr 23, 2017 2:18 am    Post subject: €°(((>< Reply with quote

Another update: posting with 'Application version 2.1.99 (5e12180377) QtWebEngine version 5.9.0', heh!

So far more things than I expected seem to be working OK, though 'lxqt' seems to be a no go for now (or I need to rebuild some stuff).

The QtWebEngine configure needs some figuring out, but it somewhat works...

Edit:

Yeah, not sure what it was, but lxqt seems to work just fine so far.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Wed Apr 26, 2017 1:36 am    Post subject: Reply with quote

finally, i've managed to migrate to qt-5.8.9999 and build qtwebengine-5.8.9999, then reinstalled kde-frameworks, kde-plasma, kde-apps, kde-misc. everything is okay so far.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Thu May 04, 2017 10:42 am    Post subject: Reply with quote

Moved to QT-5.9_beta3, it's okay so far
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum