Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Playonlinux Fonts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jnack95
n00b
n00b


Joined: 28 Jun 2008
Posts: 17

PostPosted: Wed Feb 01, 2017 5:25 am    Post subject: Playonlinux Fonts Reply with quote

I use playonlinux to play diablo 3. Something in the latest update completely borked my playonlinux and now battle net will start with only the progress bar and no test or graphics then it gets stuck. When I try to install battle.net (after deleting my previous install) the debug out put is:

Code:
fixme:ver:GetCurrentPackageId (0x456ea08 (nil)): stub
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:wineconsole:WINECON_Fatal Couldn't find a decent font, aborting

fixme:wininet:InternetSetOptionW Option 77 STUB
err:wininet:open_http_connection create_netconn failed: 12029
err:ntdll:RtlpWaitForCriticalSection section 0x721cec "?" wait timed out in thread 0042, blocked by 0030, retrying (60 sec)


IT then gets stuck. Any ideas? I've tried many things and have not had much luck. It's something realted to freetype. I tried downgrading it and that didn't work either.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5304
Location: Room 101

PostPosted: Wed Feb 01, 2017 6:27 am    Post subject: Reply with quote

jnack95 ...

I would suspect this is a multilib issue, and that freetype (or some dependent package) is installed without use_expand ABI_X86="32 64", or there is some other subtle breakage where multilib is concerned. Perhaps the following will provide some clue as to what:

Code:
# EIX_LIMIT=0 eix '-I#' --installed-with-use abi_x86_32
# EIX_LIMIT=0 eix '-I#' --installed-without-use abi_x86_32

You might also look and see what packages might be re-merged on a --changed-use:

Code:
# USE="abi_x86_32" emerge -pvuD --with-bdeps=y --quiet=y --changed-use @world

HTH & best ... khay
Back to top
View user's profile Send private message
jnack95
n00b
n00b


Joined: 28 Jun 2008
Posts: 17

PostPosted: Wed Feb 01, 2017 4:16 pm    Post subject: Reply with quote

Thanks khay. It's definitely a multilib issue because I don't get the same errors with 64bit wine prefixes. I did
Quote:
USE="abi_x86_32" emerge -pvuD --with-bdeps=y --quiet=y --changed-use @world
and the output was :
Code:
office jnack # USE="abi_x86_32" emerge -pvuD --with-bdeps=y --quiet=y --changed-use @world
[ebuild     U ] sys-devel/dev86-0.16.21-r2 [0.16.21]
[ebuild     U ] app-text/openjade-1.3.2-r7 [1.3.2-r6] USE="-static-libs"
[ebuild     U ] dev-lang/swig-3.0.11 [3.0.10] USE="pcre -ccache -doc"
[ebuild  N    ] dev-python/typing-3.5.3.0  PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5"
[ebuild     U ] sys-devel/automake-1.13.4-r1 [1.13.4]
[ebuild  N    ] dev-python/m2crypto-0.25.1-r2  USE="-libressl" PYTHON_TARGETS="python2_7"
[ebuild     U ] dev-python/pygments-2.2.0 [2.1.3] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5"
[ebuild     U ] dev-python/docutils-0.13.1 [0.12-r1] PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5"
[ebuild     U ] dev-ruby/power_assert-1.0.1-r1 [0.4.1] USE="-doc {-test}" RUBY_TARGETS="ruby21 ruby23 -ruby22 -ruby24 (-ruby20%)"
[ebuild     U ] x11-misc/util-macros-1.19.1 [1.19.0]
[ebuild     U ] dev-libs/check-0.11.0 [0.10.0-r2] USE="-static-libs -subunit" ABI_X86="32 (64) (-x32)"
[ebuild     U ] x11-misc/xorg-cf-files-1.0.6 [1.0.5]
[ebuild     U ] kde-frameworks/extra-cmake-modules-5.30.0 [5.27.0] USE="-doc {-test}"

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


I am currently dealing with multilib with this line in my make.conf. Is this no longer the correct way to do it? Thanks for your help
Code:
ABI_X86="64 32"
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5304
Location: Room 101

PostPosted: Thu Feb 02, 2017 6:51 am    Post subject: Reply with quote

jnack95 ...

I don't see anything in that list triggered by a '--changed-use', they seem to all be bdeps. So, nothing there that suggests freetype is missing some 32bit component. You might want to update those packages anyway, but I don't think it will resolve the issue.

ABI_X86="64 32" is correct. I don't use multilib so I don't know what else to suggest, you might want to post the output of 'emerge -pvq app-emulation/wine'.

best ... khay
Back to top
View user's profile Send private message
jnack95
n00b
n00b


Joined: 28 Jun 2008
Posts: 17

PostPosted: Thu Feb 02, 2017 3:26 pm    Post subject: Reply with quote

Yea, I don't know what is going on. I thought it had something to do wit multilib, but now I think it is probably something with wine, playonlinux, or the versions of wine I'm trying to use. I hope it just gets fixed in a future update. It might have something to do with libvirt too. At any rate, playonlinux now just gets stuck creating a virtual drive or configuring wine so I am at loss to figure it out. It's always been picky about which wine version to use but I've never has this much trouble.

Code:
office jnack # emerge -pvq app-emulation/wine
[ebuild   R   ] app-emulation/wine-2.0  USE="X alsa cups fontconfig gecko jpeg lcms ldap mono mp3 ncurses nls opengl perl png pulseaudio realtime run-exes samba ssl threads truetype udev udisks v4l xcomposite xml -capi -custom-cflags -dos -gphoto2 -gsm -gstreamer -netapi -odbc -openal -opencl -osmesa -oss -pcap -prelink -scanner (-selinux) {-test} -xinerama" ABI_X86="32 64 (-x32)" LINGUAS="-ar -bg -ca -cs -da -de -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5304
Location: Room 101

PostPosted: Thu Feb 02, 2017 5:52 pm    Post subject: Reply with quote

jnack95 ...

I see both fontconfig and truetype useflags enabled, so I don't think there is anything missing from wine. You might try looking at 'strace -oout wine <app>' and see if whatever happens before the above error gives some further clue.

best ... khay
Back to top
View user's profile Send private message
jnack95
n00b
n00b


Joined: 28 Jun 2008
Posts: 17

PostPosted: Thu Feb 02, 2017 9:33 pm    Post subject: Reply with quote

Here is what happens when I try to install Hearthstone in Playonlinux. I'm clueless.....maybe it's looking for sudo?

Code:
jnack@office ~ $ playonlinux
Looking for python... 3.4.5 - skipped
Looking for python2.7... 2.7.12 - wxversion(s): 3.0-gtk2, 2.8-gtk2-unicode
selected
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[main] Message: PlayOnLinux (4.2.10) is starting
[clean_tmp] Message: Cleaning temp directory
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[Check_OpenGL] Warning: check_dd_x86 missing, test skipped
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[Check_OpenGL] Warning: check_dd_amd64 missing, test skipped
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[POL_System_CheckFS] Message: Checking filesystem for /home/jnack/.PlayOnLinux/
[main] Message: Filesystem is compatible
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[install_plugins] Message: Checking plugin: ScreenCap...
[install_plugins] Message: Checking plugin: PlayOnLinux Vault...
[update_check] Message: List is up to date
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[POL_GPG_auth_script] Message: Checking signature of /home/jnack/.PlayOnLinux//install
[POL_GPG_install_key] Message: Importing PlayOnLinux public key
[POL_Bash] Message: POL GPG : Good signature - Hearthstone
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[POL_SetupWindow_Init] Message: Creating new window for pid 24145
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
[POL_Wine_SelectPrefix] Message: Selecting prefix: hearthstone
[POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.9.18
[POL_Wine_PrefixCreate] Message: Creating prefix (1.9.18)...
[POL_Wine_PrefixCreate] Message: Using wine 1.9.18
[POL_Wine_InstallVersion] Message: Installing wine version path: 1.9.18, x86
Server sha1 : 1407dbc2f823ec9c7901e0e1881140f296a51f19
Client sha1 : 1407dbc2f823ec9c7901e0e1881140f296a51f19
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
PlayOnLinux package manager: 4.2.10

Opening /home/jnack/.PlayOnLinux/tmp/PlayOnLinux-wine-1.9.18-linux-x86.pol
Extracting: /home/jnack/.PlayOnLinux/tmp/PlayOnLinux-wine-1.9.18-linux-x86.pol...
Running...
which: no sudo in (/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
Cleaning...
[POL_Wine_Install_resources] Message: Installing gecko for wine 1.9.18 x86
[POL_Wine_Install_resources] Message: Linking gecko
[POL_Wine_Install_resources] Message: wine_gecko-2.40-x86.msi already installed. Skipping
[POL_Wine_Install_resources] Message: Installing mono for wine 1.9.18 x86
[POL_Wine_Install_resources] Message: Linking mono
[POL_Wine_Install_resources] Message: wine-mono-4.5.6.msi already installed. Skipping
[POL_Config_PrefixWrite] Message: Prefix config write: ARCH x86
[POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.9.18
[POL_Wine] Message: Running wine-1.9.18 --version (Working directory : /home/jnack/.PlayOnLinux/wine/mono)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See http://www.playonlinux.com/fr/page-26-Winemenubuilder.html
[POL_Wine] Message: Wine return: 0
which: no sudo in (/home/jnack/.PlayOnLinux//wine/linux-x86/1.9.18/bin/:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
which: no sudo in (/home/jnack/.PlayOnLinux//wine/linux-x86/1.9.18/bin/:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
which: no wineprefixcreate in (/home/jnack/.PlayOnLinux//wine/linux-x86/1.9.18/bin/:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/x86_64-pc-linux-gnu/avr/gcc-bin/4.2.4:/usr/lib64/opencascade-6.9.1/ros/lin/bin)
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
err:ole:get_local_server_stream Failed: 80004002
Wine cannot find the FreeType font library.  To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
err:syslink:SYSLINK_SetFont Failed to create link font!
Back to top
View user's profile Send private message
jnack95
n00b
n00b


Joined: 28 Jun 2008
Posts: 17

PostPosted: Fri Feb 03, 2017 3:08 am    Post subject: Reply with quote

Well, I installed battle.net on a 32 bit wine prefix without playonlinux and the game plays fine so not sure what is going on with playonlinux. I would mark this solved ...but it's not really.
Back to top
View user's profile Send private message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 449
Location: Huntsville, AL.

PostPosted: Mon Feb 20, 2017 9:00 am    Post subject: Reply with quote

I'm having this issue after updating as well. I did not change anything about my freetype configuration or any configuration for that matter. PlayOnLinux was working fine before. The problem occurs when I try to open winecfg or regedit for a game among other things. For me it is happening for 32-bit and 64-bit prefixes. This does not happen with the system installed wine.

Quote:
Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.

_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 449
Location: Huntsville, AL.

PostPosted: Mon Feb 20, 2017 8:23 pm    Post subject: Reply with quote

I am able to work around this issue by setting the wine version for the prefix I am configuring to 'system'. I can then run winecfg and regedit, make my changes, and then change the wine version to the one I want to use for that prefix. It appears this problem is limited to the wine builds PlayOnLinux downloads.
_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
gRuFtY
n00b
n00b


Joined: 24 Jul 2015
Posts: 7

PostPosted: Mon Feb 20, 2017 9:49 pm    Post subject: Reply with quote

It seems to be a problem with playonlinux, not wine. I just downgraded playonlinux to version 4.2.4-r1, which fixed this. I did not try other versions than 4.2.10-r1 and 4.2.4-r1 yet, although there are two more in the portage tree.
[EDIT:] Okay, that didn't fix all of the problems for me. However, starting wine from the commandline, setting the wineprefix playonlinux uses and using the wine version downloaded by playonlinux works. So it seems playonlinux currently messes with the environment or something?
Back to top
View user's profile Send private message
adcdam
n00b
n00b


Joined: 15 Jan 2015
Posts: 61

PostPosted: Tue Feb 21, 2017 8:44 pm    Post subject: Reply with quote

Hi i downgraded to playonlinux 4.2.8 and have the same problems can not launch some games, perhaps something to do with python? a new symlink to freetype, some games work and some that required fonts doesnt.
i cant believe no one can solve this...
Back to top
View user's profile Send private message
Wicla
n00b
n00b


Joined: 22 Aug 2004
Posts: 8
Location: Sweden

PostPosted: Sun Feb 26, 2017 12:15 pm    Post subject: Reply with quote

Just wanted to add that I'm also seeing this issue and have been for quite a while. It started occurring when freetype was updated to 2.7.1 I think. But it doesn't help to downgrade it back to 2.7.0 so I guess it's in combination with something else.
Back to top
View user's profile Send private message
adcdam
n00b
n00b


Joined: 15 Jan 2015
Posts: 61

PostPosted: Sun Feb 26, 2017 11:59 pm    Post subject: Reply with quote

Perhaps its a problem Gentoo/Funtoo related? i dont have this problem in Arch linux i have a triple boot, and the problem is only here.
i can t believe no one can solve this
Back to top
View user's profile Send private message
yollfeet
n00b
n00b


Joined: 13 Apr 2017
Posts: 1

PostPosted: Thu Apr 13, 2017 1:23 pm    Post subject: Reply with quote

I use antergos which is basically arch, and i have exactly the same problem. Just wanted to share this here.
Back to top
View user's profile Send private message
undef
n00b
n00b


Joined: 15 May 2017
Posts: 1

PostPosted: Mon May 15, 2017 12:35 pm    Post subject: Reply with quote

i also have this bug since several months with a funtoo desktop client.
additional to that, i got a new laptop some days ago and installed a fresh funtoo on it and also got the same behavior as on my desktop client.

i can also temporary workaround this issue by setting the wineprefix, but this makes playonlinux a little bit useless,
and it's annoying if you got many different tools/games which need different wineprefixes.

versions tested:
Code:
media-libs/freetype-2.6.3-r1
media-libs/freetype-2.6.5
media-libs/freetype-2.7.1-r1

app-emulation/playonlinux-4.2.4-r1
app-emulation/playonlinux-4.2.6-r1
app-emulation/playonlinux-4.2.8-r1
app-emulation/playonlinux-4.2.10-r1


are we really just this few people, which are affected by this?
Back to top
View user's profile Send private message
Hyper_Eye
Guru
Guru


Joined: 17 Aug 2003
Posts: 449
Location: Huntsville, AL.

PostPosted: Wed May 17, 2017 1:38 am    Post subject: Reply with quote

The problem appears to be caused by a zlib incompatibility. You can resolve it by removing the version of zlib included with the wine packages POL downloads. Run the following command as your desktop user. I recommend you copy and paste it as you can blow some things away unintentionally if you mess it up.

Code:
rm -f ~/.PlayOnLinux/wine/linux*/*/lib*/libz*


That should remove it from all of the currently installed engines. When you install new ones you will have to delete them again.
_________________
Gentoo Gaming Videos
Back to top
View user's profile Send private message
moosh
Tux's lil' helper
Tux's lil' helper


Joined: 17 Sep 2004
Posts: 147

PostPosted: Tue Jul 18, 2017 4:19 pm    Post subject: Reply with quote

Thanks. This solved the problem for me.
Back to top
View user's profile Send private message
mwojc
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jul 2005
Posts: 78
Location: Poland

PostPosted: Tue Aug 01, 2017 3:32 pm    Post subject: Reply with quote

yes that's working :)
_________________
gentoo@thinkpad
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum