Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Upgrading Portage to support EAPI 6
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
aerohk
n00b
n00b


Joined: 31 Jan 2017
Posts: 1

PostPosted: Tue Jan 31, 2017 2:42 am    Post subject: Upgrading Portage to support EAPI 6 Reply with quote

Hello! I am attempting to install Asterisk...
Code:

>> emerge asterisk

 * IMPORTANT: 25 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "asterisk" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-misc/asterisk-13.13.1::gentoo (masked by: EAPI 6)
- net-misc/asterisk-11.25.1::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Looks like I need to upgrade my Portage to support EAPI6... but I can't upgrade my Portage for some reasons:
Code:

>> emerge -1v portage

 * IMPORTANT: 25 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-python/certifi-2015.04.28[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/certifi-2017.1.23::gentoo (masked by: EAPI 6)
- dev-python/certifi-2016.9.26::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-python/setuptools-18.4" [ebuild])
(dependency required by "dev-python/pyxattr-0.5.5" [ebuild])
(dependency required by "sys-apps/portage-2.3.3[xattr,python_targets_python2_7]" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


It appears to me that my python may be out-of-date, but I have already updated it by running python-updater.
Code:

>> equery list -i python

* Searching for python ...
[I--] [??] dev-lang/python-2.7.9-r1:2.7
[I--] [??] dev-lang/python-3.3.5-r1:3.3
[I--] [??] dev-lang/python-3.4.1:3.4

I am new to Gentoo (Linux in general), done some research but still can't get pass the error. I am wondering if anyone have any idea what is going on. Thank you for your time!
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 469
Location: Brazil

PostPosted: Tue Jan 31, 2017 3:12 am    Post subject: Reply with quote

Well, this is funny.

Apparently all the available versions of dev-python/certifi are EAPI=6, and that's needed in order to update portage in order to... install EAPI6 packages. Apparently the EAPI=5 versions were removed yesterday.

I don't know the correct way to solve this, but considering that package is very simple and small, simply setting EAPI=5 in order to install it would PROBABLY work.

I guess it would be wise for the Gentoo devs to keep this package as EAPI=5 for cases like this.

*edit* - Submitted a bug: https://bugs.gentoo.org/show_bug.cgi?id=607768

*edit* - package.provided might be a valid workaround for you. Just add any current version of dev-python/certifi to package.provided, upgrade portage and then upgrade dev-python/certifi. More info here:

https://wiki.gentoo.org/wiki//etc/portage/profile/package.provided
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14184

PostPosted: Tue Jan 31, 2017 3:42 am    Post subject: Reply with quote

Before you can update Portage, you must already have updated Portage. ;) Your system must be moderately outdated for this to have happened. What is the output of emerge --info? When did you last update the installed packages?
Back to top
View user's profile Send private message
floppymaster
Developer
Developer


Joined: 07 Jul 2010
Posts: 222
Location: Detroit, MI, USA

PostPosted: Tue Jan 31, 2017 3:44 am    Post subject: Reply with quote

Disable the xattr USE flag to work around this.
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2803
Location: Richmond, BC, Canada

PostPosted: Tue Jan 31, 2017 6:56 am    Post subject: Reply with quote

Hu wrote:
Before you can update Portage, you must already have updated Portage. ;) Your system must be moderately outdated for this to have happened. What is the output of emerge --info? When did you last update the installed packages?


Looking at the NEWS file, portage had the first eapi 6 patches starting in the 2.2.16 release (2 years ago) with the final eapi 6 patches in the 2.2.25 release(1.25 yr. ago)

There are many ways to work around a problem such as this. But disabling xattr is the easiest. then after it is updated re-enable it and re-emerge portage and continue with updating your system
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7170

PostPosted: Tue Jan 31, 2017 10:33 am    Post subject: Reply with quote

you should just not upgrade to latest portage version but to a transitional one, and step up from this one.
and portage has told you what to do already.
Code:
The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage

newer doesn't mean latest

while it seems you have an easy way for portage, when upgrading an old system, that's something you should keep in mind, look at what other packages versions exists in your tree.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Jan 31, 2017 11:04 am    Post subject: Reply with quote

Why not reinstall. you will have to replace anyway anything when it is such a dated box.
A lot has changed. you will have a lot of lint in /etc also becasue of changes.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14184

PostPosted: Wed Feb 01, 2017 2:42 am    Post subject: Reply with quote

Reinstallation is a drastic and very disruptive step, especially if the user has non-trivial content outside Portage control. Badly outdated systems seem to come up most often with some system that was installed, customized to an unusual purpose, and then left alone for years. Recreating those customizations may be difficult. Sometimes, a reinstall is the right solution, but until we know more about the system's update history, I think recommending reinstallation is premature.
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Thu Feb 02, 2017 6:20 pm    Post subject: Reply with quote

I have a portage git repository, which contains 1.5 years of portage :) Maybe this helps... the earliest commit is 20150625

https://portage.schorsch-tech.de/cgit/portage.git/

You can clone it and jump to each day in the past :)

Code:
git clone https://portage.schorsch-tech.de/portage.git

_________________
// valid again: I forgot about the git access. Now 1.2GB big. Start: 2015-06-25
git daily portage tree
Web: https://portage.schorsch-tech.de
git clone https://portage.schorsch-tech.de/portage.git
Back to top
View user's profile Send private message
lamz138138
n00b
n00b


Joined: 21 Feb 2017
Posts: 41

PostPosted: Tue Feb 21, 2017 8:25 am    Post subject: Reply with quote

Hi, I have the same problem, did you solve it?

Any suggestion would be grateful!


*edit": OK, I had solved the problem as saboya mentioned in https://bugs.gentoo.org/show_bug.cgi?id=607768 by 'USE="-xattr" emerge -lv portage'.


Best wishes!
Back to top
View user's profile Send private message
peakeyed
n00b
n00b


Joined: 18 Nov 2004
Posts: 58

PostPosted: Sun Mar 05, 2017 12:06 am    Post subject: solved Reply with quote

The following worked:

*edit* - package.provided might be a valid workaround for you. Just add any current version of dev-python/certifi to package.provided, upgrade portage and then upgrade dev-python/certifi. More info here:

https://wiki.gentoo.org/wiki//etc/portage/profile/package.provided
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Sun Mar 26, 2017 11:00 am    Post subject: Reply with quote

Hi all, I have the very same problem with a system that hasn't been updated for over a year. I've tried all of the suggestions in this thread and still end up going in circles. Any ideas?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43794
Location: 56N 3W

PostPosted: Sun Mar 26, 2017 11:27 am    Post subject: Reply with quote

NotExcessive,

The cause of this problem gets more complex with time. Please post your error messages.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Sun Mar 26, 2017 1:42 pm    Post subject: Reply with quote

This is what I get, with dev-python/certifi-2017.1.23 added to /etc/portage/profile/package.provided.

Code:
# emerge --oneshot portage

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-portage/elt-patches-20170317" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-portage/elt-patches-20170317::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-lang/python-2.7.13" [ebuild])
(dependency required by "dev-python/packaging-15.3-r2[python_targets_python2_7]" [ebuild])
(dependency required by "dev-python/setuptools-18.4" [ebuild])
(dependency required by "dev-python/pyxattr-0.6.0" [ebuild])
(dependency required by "sys-apps/portage-2.3.5[xattr,python_targets_python2_7,-python_targets_pypy]" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14184

PostPosted: Sun Mar 26, 2017 4:14 pm    Post subject: Reply with quote

Based on that output, you did not try (or did not implement correctly) the workaround proposed by both floppymaster and dol-sen. Did you try that yet? If so, what is the output of cat -n /etc/portage/package.use ; emerge --pretend --verbose --nodeps sys-apps/portage ; emerge --info? If you have not tried that, please try it now. If it fails, then post that output.
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Mon Mar 27, 2017 3:33 am    Post subject: Reply with quote

Yes, trying USE="-xattr" didn't have any effect.

This is the output of cat -n /etc/portage/package.use:
Code:
peacekeeper ~ # cat -n /etc/portage/package.use
     1  #required by media-gfx/graphviz-2.26.3-r4, required by dev-perl/GraphViz-2.40.0, required by net-dns/dnssec-tools-1.14, required by app-admin/webmin-1.620, required by webmin (argument)
     2  >=media-libs/gd-2.0.35-r3 truetype jpeg png fontconfig
     3  #required by virtual/httpd-php-5.4-r1, required by www-apps/postfixadmin-2.3.5, required by postfixadmin (argument)
     4  =dev-lang/php-5.4.8 mysqli imap apache2
     5  #required by app-text/gnome-doc-utils-0.20.10, required by dev-util/gtk-doc-1.18-r1, required by dev-libs/gobject-introspection-1.32.1[doc], required by dev-libs/atk-2.4.0[introspection], required by x11-libs/gtk+-2.24.12, required by app-text/ghostscript-gpl-9.05-r1[gtk], required by app-doc/doxygen-1.7.6.1, required by x11-libs/libXdmcp-1.1.1[doc], required by x11-libs/libxcb-1.9, required by x11-libs/libX11-1.5.0, required by x11-libs/libXcursor-1.1.13
     6  =dev-libs/libxml2-2.8.0-r3 python
     7  #required by x11-drivers/xf86-video-vmware-12.0.2-r1, required by x11-base/xorg-drivers-1.13[video_cards_vmware], required by x11-base/xorg-server-1.13.1[xorg], required by x11-drivers/xf86-video-glint-1.2.8
     8  =x11-libs/libdrm-2.4.40 libkms
     9  #required by x11-drivers/xf86-video-vmware-12.0.2-r1, required by x11-base/xorg-drivers-1.13[video_cards_vmware], required by x11-base/xorg-server-1.13.1[xorg], required by x11-drivers/xf86-video-glint-1.2.8
    10  =media-libs/mesa-9.0.1 xa
    11  # required by dev-php/securimage-3.0.1
    12  # required by securimage (argument)
    13  =dev-lang/php-5.4.8 truetype
peacekeeper ~ #


and this is the output of emerge --pretend --verbose --nodeps sys-apps/portage:
Code:
peacekeeper ~ #  emerge --pretend --verbose --nodeps sys-apps/portage

These are the packages that would be merged, in order:

[ebuild     U  ] sys-apps/portage-2.3.5 [2.2.7] USE="(ipc) native-extensions%* xattr* -build -doc* -epydoc (-selinux) (-pypy2_0%) (-python2%) (-python3%)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4* -pypy% -python3_5% -python3_6% (-pypy2_0%) (-python2_6%) (-python3_2%*) (-python3_3%)" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

peacekeeper ~ #


emerge --info reveals

Code:
peacekeeper ~ #  emerge --info
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.6.3, glibc-2.15-r3, 3.7.9-gentoo x86_64)
=================================================================
System uname: Linux-3.7.9-gentoo-x86_64-Intel-R-_Xeon-TM-_CPU_3.20GHz-with-gentoo-2.1
KiB Mem:     6047716 total,   1737520 free
KiB Swap:    5732348 total,   5732348 free
Timestamp of tree: Sun, 26 Mar 2017 13:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/perl:            5.12.4-r1
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo http://gentoo.inode.at/ ftp://gentoo.chem.wisc.edu/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="X accessibility acl amd64 aoss berkdb bzip2 cli community cracklib crypt cxx dbus dri exceptions extraengine fam fortran fpm gdbm glib gtk hal iconv introspection ipv6 jit kde libkms lto modules multilib mysql ncurses netapi nls nptl opengl openmp pam pcre qt3support qt4 readline samba seccomp server session sqlite ssl svg symlink tcpd threads udev unicode winbind xa xattr xcb xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10342
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Mar 27, 2017 11:25 am    Post subject: Reply with quote

The earliest versions of Portage that are kept in the tree are kept there to ease EAPI transitions (and sometimes other upgrades). Let's check:
Code:
ceres ~ # equery list -p portage
 * Searching for portage ...
[-P-] [  ] sys-apps/portage-2.2.28:0
[-P-] [  ] sys-apps/portage-2.3.0:0
[IP-] [  ] sys-apps/portage-2.3.3:0
[-P-] [ ~] sys-apps/portage-2.3.4:0
[-P-] [ ~] sys-apps/portage-2.3.5:0
[-P-] [ -] sys-apps/portage-9999:0
ceres ~ # equery which -e sys-apps/portage-2.2.28 | grep EAPI
EAPI=5
ceres ~ # equery which -e sys-apps/portage-2.3.0 | grep EAPI
EAPI=5
Yep. Try installing 2.2.28:
Code:
emerge -1v =portage-2.2.28
(and then possibly 2.3.0) and report back.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Mon Mar 27, 2017 12:22 pm    Post subject: Reply with quote

I've tried this, and end up with the following errors:
Code:
peacekeeper ~ # emerge -1v =portage-2.2.28

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/install-xattr-0.5  16 kB
[ebuild     U  ] sys-devel/automake-wrapper-10 [7] 0 kB
[ebuild  N     ] dev-lang/python-exec-2.4.5:2  PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6)" 86 kB
[ebuild  NS    ] sys-libs/ncurses-6.0-r1:0/6 [5.9-r2:5] USE="cxx threads unicode -ada -debug -doc -gpm -minimal -profile -static-libs {-test} -tinfo -trace" ABI_X86="(64) -32 (-x32)" 3,059 kB
[uninstall     ] app-emulation/emul-linux-x86-baselibs-20121202  USE="-development"
[blocks b      ] app-emulation/emul-linux-x86-baselibs ("app-emulation/emul-linux-x86-baselibs" is blocking sys-libs/ncurses-6.0-r1)
[uninstall     ] sys-libs/ncurses-5.9-r2:5  USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace"
[blocks b      ] <=sys-libs/ncurses-5.9-r4:5 ("<=sys-libs/ncurses-5.9-r4:5" is blocking sys-libs/ncurses-6.0-r1)
[ebuild  N     ] app-eselect/eselect-python-20160516  46 kB
[ebuild     U  ] app-arch/tar-1.29-r3 [1.26] USE="acl%* nls xattr%* -minimal% (-selinux) -static" 2,653 kB
[ebuild  NS    ] sys-devel/automake-1.15-r2:1.15 [1.10.3:1.10, 1.11.6:1.11, 1.12.6:1.12] 1,462 kB
[ebuild     U  ] dev-lang/python-2.7.13:2.7 [2.7.3-r2:2.7] USE="gdbm ipv6 ncurses readline sqlite* ssl (threads) (wide-unicode) xml (-berkdb*) -build -doc -examples -hardened% -libressl% -tk -wininst" 12,216 kB
[blocks b      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking dev-lang/python-exec-2.4.5)
[ebuild  NS    ] dev-lang/python-3.4.6:3.4/3.4m [2.6.8:2.6, 2.7.3-r2:2.7, 3.2.3:3.2] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst" 14,146 kB
[ebuild  N     ] dev-python/packaging-15.3-r2  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6" 34 kB
[ebuild     U  ] dev-python/setuptools-18.4 [0.6.30-r1] USE="{-test%}" PYTHON_TARGETS="python2_7 python3_4%* -pypy% -pypy3% -python3_5% (-python2_5%) (-python2_6%) (-python3_1%) (-python3_2%*)" 612 kB
[ebuild  N     ] dev-python/pyxattr-0.6.0  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5" 31 kB
[ebuild     U  ] sys-apps/portage-2.2.28 [2.2.7] USE="(ipc) xattr* -build -doc* -epydoc (-selinux) (-pypy2_0%) (-python2%) (-python3%)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4* -pypy% -python3_5% (-pypy2_0%) (-python2_6%) (-python3_2%*) (-python3_3%)" 947 kB
[blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is hard blocking dev-lang/python-3.4.6)

Total: 13 packages (5 upgrades, 5 new, 3 in new slots, 2 uninstalls), Size of downloads: 35,303 kB
Conflict: 4 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

  (dev-python/setuptools-18.4::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.6.0::gentoo, ebuild scheduled for merge)

  (dev-python/setuptools-0.6.30-r1::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_2(-),-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)] required by (dev-python/numpy-1.6.2-r2::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.4.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.6.0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (app-admin/python-updater-0.10::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (app-admin/hp-health-9.1.0.42::gentoo, installed)
    dev-lang/python required by (x11-proto/xcb-proto-1.8::gentoo, installed)
    dev-lang/python:3.4[ssl(+)] required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)
    dev-lang/python required by @selected

  (sys-apps/sandbox-2.5::gentoo, installed) pulled in by
    >=sys-apps/sandbox-2.2 required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-perl/DBD-mysql-4.01.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Kent Fredric <kentnl@gentoo.org> (04 Feb 2017)
# Unsecure versions that have been only restored to tree
# to resolve compatibility problems with mail-filter/amavisd-new
# Use with caution due to these being removed for CVE-2016-1251
# Bug: #601144
# Bug: #604678

- net-nds/openldap-2.4.30::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

peacekeeper ~ #
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10342
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Mar 27, 2017 1:23 pm    Post subject: Reply with quote

There's only one blocking error there:
Code:
blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is hard blocking dev-lang/python-3.4.6)
Try masking dev-lang/python-3.4.6 temporarily. Do you need instructions on that?

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Mon Mar 27, 2017 10:33 pm    Post subject: Reply with quote

I have created the file /etc/portage/package.mask with the following line in it: dev-lang/python-3.4.6 but I'm still getting the following output.

Code:
peacekeeper ~ # emerge -1v =portage-2.2.28
--- Invalid atom in /etc/portage/profile/package.mask: dev-lang/python-3.4.6
--- Invalid atom in /etc/portage/package.mask: dev-lang/python-3.4.6

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-apps/install-xattr-0.5  16 kB
[ebuild     U  ] sys-devel/automake-wrapper-10 [7] 0 kB
[ebuild  N     ] dev-lang/python-exec-2.4.5:2  PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6)" 86 kB
[ebuild  NS    ] sys-libs/ncurses-6.0-r1:0/6 [5.9-r2:5] USE="cxx threads unicode -ada -debug -doc -gpm -minimal -profile -static-libs {-test} -tinfo -trace" ABI_X86="(64) -32 (-x32)" 3,059 kB
[uninstall     ] app-emulation/emul-linux-x86-baselibs-20121202  USE="-development"
[blocks b      ] app-emulation/emul-linux-x86-baselibs ("app-emulation/emul-linux-x86-baselibs" is blocking sys-libs/ncurses-6.0-r1)
[uninstall     ] sys-libs/ncurses-5.9-r2:5  USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs -tinfo -trace"
[blocks b      ] <=sys-libs/ncurses-5.9-r4:5 ("<=sys-libs/ncurses-5.9-r4:5" is blocking sys-libs/ncurses-6.0-r1)
[ebuild  N     ] app-eselect/eselect-python-20160516  46 kB
[ebuild     U  ] app-arch/tar-1.29-r3 [1.26] USE="acl%* nls xattr%* -minimal% (-selinux) -static" 2,653 kB
[ebuild  NS    ] sys-devel/automake-1.15-r2:1.15 [1.10.3:1.10, 1.11.6:1.11, 1.12.6:1.12] 1,462 kB
[ebuild     U  ] dev-lang/python-2.7.13:2.7 [2.7.3-r2:2.7] USE="gdbm ipv6 ncurses readline sqlite* ssl (threads) (wide-unicode) xml (-berkdb*) -build -doc -examples -hardened% -libressl% -tk -wininst" 12,216 kB
[blocks b      ] <dev-lang/python-2.7.10-r4:2.7 ("<dev-lang/python-2.7.10-r4:2.7" is blocking dev-lang/python-exec-2.4.5)
[ebuild  NS    ] dev-lang/python-3.4.6:3.4/3.4m [2.6.8:2.6, 2.7.3-r2:2.7, 3.2.3:3.2] USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl -tk -wininst" 14,146 kB
[ebuild  N     ] dev-python/packaging-15.3-r2  USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_5 -python3_6" 34 kB
[ebuild     U  ] dev-python/setuptools-18.4 [0.6.30-r1] USE="{-test%}" PYTHON_TARGETS="python2_7 python3_4%* -pypy% -pypy3% -python3_5% (-python2_5%) (-python2_6%) (-python3_1%) (-python3_2%*)" 612 kB
[ebuild  N     ] dev-python/pyxattr-0.6.0  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5" 31 kB
[ebuild     U  ] sys-apps/portage-2.2.28 [2.2.7] USE="(ipc) xattr* -build -doc* -epydoc (-selinux) (-pypy2_0%) (-python2%) (-python3%)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4* -pypy% -python3_5% (-pypy2_0%) (-python2_6%) (-python3_2%*) (-python3_3%)" 947 kB
[blocks B      ] <sys-apps/sandbox-2.6-r1 ("<sys-apps/sandbox-2.6-r1" is hard blocking dev-lang/python-3.4.6)

Total: 13 packages (5 upgrades, 5 new, 3 in new slots, 2 uninstalls), Size of downloads: 35,303 kB
Conflict: 4 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

  (dev-python/setuptools-18.4::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/setuptools[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)] required by (dev-python/pyxattr-0.6.0::gentoo, ebuild scheduled for merge)

  (dev-python/setuptools-0.6.30-r1::gentoo, installed) pulled in by
    dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_2(-),-python_single_target_python2_5(-),-python_single_target_python2_6(-),-python_single_target_python2_7(-),-python_single_target_python3_1(-),-python_single_target_python3_2(-)] required by (dev-python/numpy-1.6.2-r2::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-lang/python-3.4.6::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/python:3.4 required by (dev-python/pyxattr-0.6.0::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4 required by (dev-python/setuptools-18.4::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (app-admin/python-updater-0.10::gentoo, installed)
    dev-lang/python:3.4 required by (dev-python/packaging-15.3-r2::gentoo, ebuild scheduled for merge)
    dev-lang/python required by (app-admin/hp-health-9.1.0.42::gentoo, installed)
    dev-lang/python required by (x11-proto/xcb-proto-1.8::gentoo, installed)
    dev-lang/python:3.4[ssl(+)] required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)
    dev-lang/python:3.4[bzip2(+)] required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)
    dev-lang/python required by @selected

  (sys-apps/sandbox-2.5::gentoo, installed) pulled in by
    >=sys-apps/sandbox-2.2 required by (sys-apps/portage-2.2.28::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- dev-perl/DBD-mysql-4.01.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Kent Fredric <kentnl@gentoo.org> (04 Feb 2017)
# Unsecure versions that have been only restored to tree
# to resolve compatibility problems with mail-filter/amavisd-new
# Use with caution due to these being removed for CVE-2016-1251
# Bug: #601144
# Bug: #604678

- net-nds/openldap-2.4.30::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (20 Mar 2014)
# Security mask of vulnerable versions, wrt bug #424167

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Am I using the mask incorrectly?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3207
Location: Illinois, USA

PostPosted: Mon Mar 27, 2017 10:48 pm    Post subject: Reply with quote

Quote:
dev-lang/python-3.4.6
should be =dev-lang/python-3.4.6 or >=dev-lang/python-3.4.6

It's a syntax error.
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Mon Mar 27, 2017 11:30 pm    Post subject: Reply with quote

Correcting the syntax, and moving the file to /etc/portage/profile (which it seems it wanted), now results in

Code:
peacekeeper portage # emerge -1v =portage-2.2.28

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-python/certifi-2015.04.28[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-)]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/certifi-2017.1.23::gentoo (masked by: EAPI 6)
- dev-python/certifi-2016.9.26::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-python/setuptools-18.4" [ebuild])
(dependency required by "dev-python/pyxattr-0.6.0" [ebuild])
(dependency required by "sys-apps/portage-2.2.28[xattr,python_targets_python2_7,-python_targets_pypy]" [ebuild])
(dependency required by "=portage-2.2.28" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

peacekeeper portage #
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14184

PostPosted: Tue Mar 28, 2017 1:25 am    Post subject: Reply with quote

You still have USE=xattr enabled. Your prior output shows no sign of it in /etc/portage/package.use. What method did you use to try to disable xattr support?
Back to top
View user's profile Send private message
NotExcessive
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 235

PostPosted: Tue Mar 28, 2017 1:35 am    Post subject: Reply with quote

This is the output from the following command:

Code:
peacekeeper portage # USE="-xattr" emerge -1v =portage-2.2.28

 * IMPORTANT: 32 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=app-portage/elt-patches-20170317" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-portage/elt-patches-20170317::gentoo (masked by: EAPI 6)

The current version of portage supports EAPI '5'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "dev-lang/python-2.7.13" [ebuild])
(dependency required by "sys-apps/portage-2.2.28[python_targets_python2_7]" [ebuild])
(dependency required by "=portage-2.2.28" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

peacekeeper portage #
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 3207
Location: Illinois, USA

PostPosted: Tue Mar 28, 2017 2:18 am    Post subject: Reply with quote

NotExcessive wrote:
Code:
peacekeeper portage # USE="-xattr" emerge -1v =portage-2.2.28
That only disabled xattr for the duration of that single emerge. You need to put it in /etc/portage.make.conf or add an entry in /etc/portage/package.use for portage with -xattr.

Your new problem can be fixed by downloading and extracting a portage snapshot from 20170323 or earlier. That's before the blocked application existed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum