Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
black screen with startx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Jan 27, 2017 10:12 am    Post subject: black screen with startx Reply with quote

I have created a gentoo virtual machine, with qxl graphics card, installed the xorg driver for qxl, and have compiled the kernel with qxl built in
I have installed twm and when I try to startx I get a black screen only, I have tried clicking the left and right mouse button but no results.

00:02.0 VGA compatible controller: Red Hat, Inc. QXL paravirtual graphic card (rev 04)
Subsystem: Red Hat, Inc QEMU Virtual Machine
Kernel driver in use: qxl


Calculating dependencies... done!
[ebuild R ] x11-drivers/xf86-video-qxl-0.1.4::gentoo USE="-xspice" 0 KiB
[ebuild R ] x11-base/xorg-drivers-1.18-r1::gentoo INPUT_DEVICES="mouse -acecad -aiptek -elographics -evdev -fpit -hyperpen -joystick -keyboard -libinput -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom" VIDEO_CARDS="qxl -amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -intel -mach64 -mga -neomagic -nouveau -nv -nvidia (-omap) (-omapfb) -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB



Xorg.log:
http://pastebin.com/UCFqkS7G

thanks


Last edited by Adel Ahmed on Sun Jan 29, 2017 4:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Jan 29, 2017 4:32 pm    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Jan 29, 2017 4:38 pm    Post subject: Reply with quote

blakc box is working fine, my mistake.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Mon Jan 30, 2017 1:27 am    Post subject: Reply with quote

You may start reading those guides about set up X-server first please. I see a lot of warnings / error messages.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Mon Jan 30, 2017 7:52 am    Post subject: Reply with quote

will do thanks for the heads up
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum