Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
portage lentissimo!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Wed Jan 18, 2017 3:11 pm    Post subject: portage lentissimo! Reply with quote

Salve ho dei problemi quando eseguo l'aggiornamento di world
Code:
emerge -uDNt --with-bdeps y --verbose y --backtrack=300  @world

rimane a lavorare su "calculating dependencies" per un ora 8O qualcuno ha qualche idea del perche` grazie in anticipo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Wed Jan 18, 2017 5:51 pm    Post subject: Reply with quote

Puoi postare in emerge --info per favore?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Wed Jan 18, 2017 7:10 pm    Post subject: Reply with quote

Code:
 [root@quad-Gentoo /home/drudox]# emerge --info
Portage 2.3.2 (python 2.7.12-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.23-r3, 4.8.10-gentoo x86_64)
=================================================================
System uname: Linux-4.8.10-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.3
KiB Mem:     8184280 total,   6424784 free
KiB Swap:    4095996 total,   4095996 free
Timestamp of repository gentoo: Wed, 18 Jan 2017 10:30:01 +0000
sh bash 4.4_p5
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.4_p5::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo, 3.5.2::gentoo
dev-util/cmake:           3.7.0::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.3::gentoo
sys-apps/openrc:          0.22.4::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.26.1::gentoo, 2.27::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.8::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

nightmare
    location: /var/lib/layman/nightmare
    masters: gentoo
    priority: 50

posativ
    location: /var/lib/layman/posativ
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.ovh.net/gentoo-distfiles/"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="!qt4 X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dri driver dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kms lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pcre16 pdf png policykit ppds pulseaudio qt3support qt4 qt5 readline sdl seccomp session spell sse sse2 ssl startup-notification svg tcpd tiff truetype type1 udev udisks unicode upower usb uvm vorbis wxwidgets x264 xattr xcb xft xml xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



Grazie per l aiuto
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Wed Jan 18, 2017 8:01 pm    Post subject: Reply with quote

Ma da quando ci mette cosi' tanto? E' collegato all'altro tuo problema?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Thu Jan 19, 2017 9:15 am    Post subject: Reply with quote

No anche quando tutto va bene e` lentissimo ... praticamente dalle prime volte che ho aggiornato
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Thu Jan 19, 2017 9:28 am    Post subject: Reply with quote

Come prima idea potresti lanciare il comando con --debug e vedere dove si blocca (se si blocca).
Attenzione che questo comando crea un output lunghissimo magari lancialo e rindirizza l'output in un file emerge -uDNt --with-bdeps y --verbose y --backtrack=300 @world | tee /path/emerge-debug.out.
Un'altra cosa che mi viene in mente e' che magari hai qualche casino nei vari file /etc/portage/package.*, quindi potresti tentare di fare pulizia in quelli.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Thu Jan 19, 2017 5:04 pm    Post subject: Reply with quote

ecco il risultrato del file di debug https://paste.pound-python.org/show/JSrJ2w2Y0Zo7m6t7LUlj/ per i package mi sembrano abbastanza puliti magari puoi darci uno sguardo al file di debug ?

Ti ringrazio infinitamente
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Thu Jan 19, 2017 5:18 pm    Post subject: Reply with quote

humm ho copiato il tuo comando senza mettere --debug ... :\ finisce di fare l'update e lo rilancio in maniera corretta
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Fri Jan 20, 2017 9:05 am    Post subject: Reply with quote

Non ho capito allora se ancora ci mette cosi' tanto a fare il "calculating dependencies"
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Fri Jan 20, 2017 9:58 am    Post subject: Reply with quote

Si si tantissimo
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 706

PostPosted: Fri Jan 20, 2017 8:47 pm    Post subject: Reply with quote

drudox wrote:
Si si tantissimo


guarda , puoi rimuovere questo mirror

GENTOO_MIRRORS="http://gentoo.mirrors.ovh.net/gentoo-distfiles/"

ovh non è che tenga molto aggiornato il portage tree... ho avuto brutte esperienze con un dedicato 8O

commenta la riga dei mirrors , e lascia che si prenda quelli suoi di default. (oopure utilizza mirrorselect)
Code:
# emerge app-portage/mirrorselect --ask
...

# mirrorselect -i -r


dovrebbe risolversi (bada al condizionale)
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 3:58 pm    Post subject: Reply with quote

Il problema e` che ho cancellato involontariamente il file /usr/lib64/python2.7/ssl.py
potresti darmi gentilmente una copia del file ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Tue Jan 24, 2017 4:13 pm    Post subject: Reply with quote

drudox wrote:
Il problema e` che ho cancellato involontariamente il file /usr/lib64/python2.7/ssl.py
potresti darmi gentilmente una copia del file ?

Non puoi semplicemente fare in re-emerge di python?
Code:
# emerge -1 dev-lang/python:2.7

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 4:26 pm    Post subject: Reply with quote

si giusto :D non sapevo se fosse python o il suo modulo ssl
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 5:39 pm    Post subject: Reply with quote

sto provando ad usare wgetpaste per il file di debug di emerge @world ... il file e` bello grande .. e ricevo questo messaggio

Code:
 wgetpaste emerge2.out --verbose
^[[AApparently nothing was received. Perhaps the connection failed.
--2017-01-24 18:32:34--  https://paste.pound-python.org/
Resolving paste.pound-python.org... 173.255.203.121
Connecting to paste.pound-python.org|173.255.203.121|:443... connected.
Retrying.

--2017-01-24 18:33:05--  (try: 2)  https://paste.pound-python.org/
Connecting to paste.pound-python.org|173.255.203.121|:443... connected.
Retrying.

--2017-01-24 18:33:38--  (try: 3)  https://paste.pound-python.org/
Connecting to paste.pound-python.org|173.255.203.121|:443... connected.
Retrying.

--2017-01-24 18:34:12--  (try: 4)  https://paste.pound-python.org/
Connecting to paste.pound-python.org|173.255.203.121|:443... connected.
Retrying.

--2017-01-24 18:34:47--  (try: 5)  https://paste.pound-python.org/
Connecting to paste.pound-python.org|173.255.203.121|:443... connected.
Giving up.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 5:41 pm    Post subject: Reply with quote

il file e` di 232M ... pensi possa essere quello il problema ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Tue Jan 24, 2017 5:52 pm    Post subject: Reply with quote

drudox wrote:
il file e` di 232M ... pensi possa essere quello il problema ?

Sicuramente e' per quello che non te lo lascia caricare. Vedi se riesci te a scorrere il file e capire cosa succede.
Ma e' ancora cosi' lento a fare emerge -uDNt --with-bdeps y --verbose y @world? (prova a farlo senza --backtrack=300 e senza --debug, visto che --backtrack=300 si usa solitamente quando non riesce a risolvere dei conflitti e questo rallenta molto)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 6:14 pm    Post subject: Reply with quote

no in questo caso no ... pero` mi da` problemi tipo :
Code:

 emerge -uDNt --with-bdeps y --verbose y --backtrack=300 @world

These are the packages that would be merged, in reverse order:

Calculating dependencies |

!!! Problem resolving dependencies for net-libs/libvncserver from @selected                        ... done!

!!! The ebuild selected to satisfy "net-libs/libvncserver" has unmet requirements.
- net-libs/libvncserver-0.9.11-r1::gentoo USE="24bpp ipv6 jpeg png ssl zlib -gcrypt -gnutls -libressl -static-libs -systemd -test -threads" ABI_X86="32 64 -x32"

  The following REQUIRED_USE flag constraints are unsatisfied:
    !gnutls? ( ssl? ( threads ) )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
e non solo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Tue Jan 24, 2017 6:42 pm    Post subject: Reply with quote

Questo e' solo un problema di use flag. Portage ti dice che per installare libvncserver con ssl devi anche attivare threads, quindi baste che dai il comando
Code:
# echo "net-libs/libvncserver ssl threads" >> /etc/portage/package.use

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 7:09 pm    Post subject: Reply with quote

e questo di texlive ??

Code:
[blocks B      ] <dev-texlive/texlive-basic-2016 ("<dev-texlive/texlive-basic-2016" is hard blocking dev-texlive/texlive-basic-2016)
[blocks B      ] <dev-texlive/texlive-latex-2016 ("<dev-texlive/texlive-latex-2016" is hard blocking dev-texlive/texlive-latex-2016)

Total: 16 packages (10 upgrades, 5 downgrades, 1 reinstall, 4 uninstalls), Size of downloads: 117538 KiB
Conflict: 6 blocks (2 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/kpathsea:0

  (dev-libs/kpathsea-6.2.2_p20160523:0/6.2.2::gentoo, installed) pulled in by
    >=dev-libs/kpathsea-6.2.1:0/6.2.2= required by (dev-tex/bibtexu-3.71_p20160523:0/0::gentoo, installed)
                             ^^^^^^^^^                                                                                                       

  (dev-libs/kpathsea-6.2.1_p20150521-r2:0/6.2.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/kpathsea:0/6.2.1= required by (app-text/dvipng-1.15:0/0::gentoo, installed)
                     ^^^^^^^^^                                                                                             

dev-lang/perl:0

  (dev-lang/perl-5.24.1_rc4:0/5.24::gentoo, installed) pulled in by
    dev-lang/perl:0/5.24=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    =dev-lang/perl-5.24* required by (virtual/perl-Compress-Raw-Bzip2-2.69.0-r1:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                     
    (and 308 more with the same problems)

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Test-Simple-1.1.2-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    (and 3 more with the same problem)

  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.22.3* required by (virtual/perl-ExtUtils-Command-1.200.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                       
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-texlive/texlive-latex required by (dev-tex/latex-beamer-3.36:0/0::gentoo, installed)
    >=dev-texlive/texlive-latex-2016 required by (dev-texlive/texlive-latexrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-latex-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    dev-texlive/texlive-latex required by (dev-tex/xcolor-2.11:0/0::gentoo, installed)

  (dev-texlive/texlive-basic-2016:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-plainextra-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontsrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-genericrecommended-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (app-text/texlive-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-fontutils-2016:0/0::gentoo, ebuild scheduled for merge)
    >=dev-texlive/texlive-basic-2016 required by (dev-texlive/texlive-latex-2016:0/0::gentoo, ebuild scheduled for merge)

grazie dell'aiuto
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Tue Jan 24, 2017 7:12 pm    Post subject: Reply with quote

bada che l'aggiornamento va avanti per gli altri pacchetti .... ma non per texlive !
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Tue Jan 24, 2017 7:50 pm    Post subject: Reply with quote

Leggendo qua sembra che bisogna disinstallare la vecchia versione.
Magari prima creati i pacchetti binari della versione installata con quickpkg dev-texlive/* cosi' da avere un backup.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22023
Location: here

PostPosted: Wed Jan 25, 2017 12:56 pm    Post subject: Reply with quote

Qua hanno postato una soluzione che sembra funzionare.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 618

PostPosted: Wed Jan 25, 2017 5:04 pm    Post subject: Reply with quote

grazie 1000 funziona :)

senti io per questo messaggio di errore
Code:
!!! Problem resolving dependencies for media-libs/libmediaart                                      ... done!

!!! The ebuild selected to satisfy "media-libs/libmediaart" has unmet requirements.
- media-libs/libmediaart-1.9.0-r1::gentoo USE="gtk introspection qt5 -test -vala" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    at-most-one-of ( gtk qt5 )

  The above constraints are a subset of the following complete expression:
    at-most-one-of ( gtk qt5 ) vala? ( introspection )


ho messo in package.use:
Code:
 =media-libs/libmediaart gtk vala introspection


ma non cambia nulla ! [/code]
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 706

PostPosted: Wed Jan 25, 2017 5:25 pm    Post subject: Reply with quote

drudox wrote:

ho messo in package.use:
Code:
 =media-libs/libmediaart gtk vala introspection


ma non cambia nulla ! [/code]


quando indichi "=" ci devi mettere la versione completa e vale solo per quella versione

se vuoi che il cambiamento valga per tutte le versio basta indicare solo il categoria+pacchetto


puoi indicare anche per slot , ma senza "="

media-libs/libmediaart --> vale per tutte le versioni

=media-libs/libmediaart -x.y --> vale solo per la versione X.Y

>media-libs/libmediaart -X.Y --> vale solo per la versione superiore a X.Y

>=media-libs/libmediaart -X.Y --> vale solo per la versione superiore a X.Y (compresa)

media-libs/libmediaart:3 --> vale solo per la versione con slot 3 (è un esempio)

quindi quello da te indicato è un errore di sintassi e portage non lo interpreta

PS : c'è il comando Euse
Code:
# euse -E gtk vala introspection -p media-libs/libmediaart


Abilita (-E) le use indicate per il pacchetto (-p))....

Disabilita (-D) le use indicate per il pacchetto (-p) indicato

se non indichi il nome del pacchetto (-p) , il cambiamento sarà globale (USE nel make.conf)
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum