Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] problemi con perlcleaner (conflitti)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 9:06 am    Post subject: [RISOLTO] problemi con perlcleaner (conflitti) Reply with quote

Salve a tutti .. sto provando a dare il comando

Code:
perlcleaner --reallyall
dopo aver dato il comando
Code:
emerge -ua --nodeps =dev-lang/perl-5.22.3_rc4


pero risultano dei conflitti e non va` quindi a buon fine l'output e` :

Code:
Total: 120 packages (7 upgrades, 5 downgrades, 108 reinstalls), Size of downloads: 15301 KiB
Conflict: 5 blocks (5 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, installed) pulled in by
    =dev-lang/perl-5.22.3* required by (virtual/perl-Digest-1.170.100_rc-r1:0/0::gentoo, installed)
    ^              ^^^^^^^                                                                                                                               
    (and 12 more with the same problem)

  (dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Test-Simple-1.1.2-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-ExtUtils-Command-1.200.100_rc:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-ExtUtils-Command-1.160.0 required by (perl-core/ExtUtils-MakeMaker-7.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-Command:0

  (perl-core/ExtUtils-Command-1.180.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-Command:0

  (virtual/perl-Sys-Syslog-0.330.100_rc-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Sys-Syslog:0
    >=virtual/perl-Sys-Syslog-0.170.0 required by (dev-perl/DBI-1.634.0:0/0::gentoo, ebuild scheduled for merge)

  (virtual/perl-Test-Simple-1.1.2-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Test-Simple:0
    virtual/perl-Test-Simple required by (dev-perl/Test-Deep-1.120.0:0/0::gentoo, ebuild scheduled for merge)

  (virtual/perl-JSON-PP-2.272.30-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-JSON-PP:0
    >=virtual/perl-JSON-PP-2.272.0 required by (perl-core/CPAN-Meta-2.143.240:0/0::gentoo, ebuild scheduled for merge)
    =virtual/perl-JSON-PP-2.272.30-r1 required by (perl-core/CPAN-Meta-2.143.240:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-JSON-PP-2.271.30 required by (virtual/perl-CPAN-Meta-2.143.240-r1:0/0::gentoo, ebuild scheduled for merge)

  (perl-core/JSON-PP-2.273.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/JSON-PP:0

  (perl-core/Sys-Syslog-0.330.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Sys-Syslog:0

  (perl-core/Test-Simple-1.1.14-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Test-Simple:0

  (perl-core/CPAN-Meta-Requirements-2.125.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/CPAN-Meta-Requirements:0

  (virtual/perl-CPAN-Meta-Requirements-2.132.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-CPAN-Meta-Requirements-2.132.0-r1 required by (perl-core/CPAN-Meta-2.143.240:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-CPAN-Meta-Requirements-2.121.0 required by (perl-core/CPAN-Meta-2.143.240:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-CPAN-Meta-Requirements:0


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-perl/File-BaseDir:0 (argument)
# /etc/portage/package.mask/Perl:
=dev-perl/File-BaseDir-0.30.0-r1

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.unmask' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

!!! The following installed packages are masked:
- dev-ruby/ruby-glib2-3.0.8::gentoo (masked by: package.mask)
- x11-libs/vte-0.28.2-r207::gentoo (masked by: package.mask)
- app-text/dvipng-1.15::gentoo (masked by: package.mask)
/etc/portage/package.mask/kpathsea:
#=dev-libs/kpathsea-6.2.1_p20150521-r2

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.


Qualcuno puo` darmi una mano ? Grazie :)


Last edited by drudox on Mon Jan 23, 2017 3:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 23, 2017 10:05 am    Post subject: Reply with quote

Puoi postare con un emerge -ua --nodeps =dev-lang/perl-5.22.3_rc4 --verbose-conflicts?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 10:12 am    Post subject: Reply with quote

Si un attimo .. sto aggiornando world e vedo che sta installando perl-5.24.1_rc4 , credi sia un problema ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 11:10 am    Post subject: Reply with quote

quindi ora dovrei postare
emerge -ua --nodeps =dev-lang/perl-5.24.1_rc4 --verbose-conflicts ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 11:12 am    Post subject: Reply with quote

oppure indipendentemente dal fatto che ha aggiornato alla 5.24 posto emerge -ua --nodeps =dev-lang/perl-5.22.3_rc4 --verbose-conflicts ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jan 23, 2017 11:58 am    Post subject: Reply with quote

Devi postare lo stesso comando che ti dava quell'errore ma con --verbose-conflicts
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 668

PostPosted: Mon Jan 23, 2017 1:34 pm    Post subject: Reply with quote

io nell'altro topic ho indicato chiaramente sul comando da em postato il pacchetto e versione ultima in quel momento disponibile.
mi sembrava scontato (ma evidentemente non lo è stato) che se avevi un keyword ~amd64 dovevi utilizzare la ultima disponibile versione testing

con il --nodeps e poi via di cleaner
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 3:07 pm    Post subject: Reply with quote

Il comando che mi dava quell errore e` perl-cleaner --all che non accetta l'opzione --verbose-conflict
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 23, 2017 3:15 pm    Post subject: Reply with quote

comunque seguendo il consiglio di sabayonino (grazie) ho risolto il problema ! e ora apro un altro topic per un altro problemino :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum