Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
plasma-desktop: black screen with mouse cursor [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fikiz
Apprentice
Apprentice


Joined: 07 Mar 2005
Posts: 282
Location: Italy

PostPosted: Fri Jan 20, 2017 1:48 pm    Post subject: plasma-desktop: black screen with mouse cursor [solved] Reply with quote

Hi all.

Weird things down here. I installed plasma-desktop, and when I run startx inside a virtual console X starts correctly, the tipical kde mouse cursor appears in the middle of a black screen (and it correctly moves as I move my mouse), my faithful spinning harddisk makes its scratchy sounds for a few seconds, then it stops and... that's it. No plasma desktop.

my .xinitrc:
Code:
# exec startxfce4
exec startkde


xfce4 starts and runs correctly.

I suppose emerging plasma-desktop brings all needed dependancies with it. Honestly I have no idea of what I should check. I need some hints.

Thanks.


Last edited by fikiz on Sun Jan 29, 2017 7:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 515
Location: Italia

PostPosted: Fri Jan 20, 2017 2:23 pm    Post subject: Reply with quote

In my .xinitrc file i have:

Code:
ck-launch-session dbus-launch --exit-with-session startkde
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Fri Jan 20, 2017 2:26 pm    Post subject: Re: plasma-desktop: black screen with mouse cursor Reply with quote

fikiz wrote:
I suppose emerging plasma-desktop brings all needed dependancies with it.

An extremely minimal set of dependencies. Not even systemsettings and powerdevil. Better use plasma-meta.

Check xorg.log and .xsession-errors for errors.

Other things to check:
Remove ~/.Xauthority
Remove kscreen cache

This has come up before though, so please also use the forum search.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
fikiz
Apprentice
Apprentice


Joined: 07 Mar 2005
Posts: 282
Location: Italy

PostPosted: Sun Jan 29, 2017 7:11 am    Post subject: Reply with quote

Thanks for your hints. Sadly I found nothing useful in log files and the ck-launch-session command for .xinitrc didn't change a thing, as well deleting .Xauthority and kscreen cache.

I cloned my Gentoo installation to a virtual machine in order to play freely with it.

Once cloned, same behaviour: black screen and mouse pointer.
Emerged kde-meta, still the same thing.

Rolled back to the just cloned state, I ran emerge --update --newuse --deep @world (first time I had to do this in 12+ years of Gentoo, btw :-) ); after that, I emerged plasma-desktop and finally I got my desktop working.

Now I'm going to rebuild everything on the real installation.

Thank you for your time.

Bye!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum