Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kwalletmanager5 does not allow me to change settings
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Thu Jan 05, 2017 6:04 am    Post subject: kwalletmanager5 does not allow me to change settings Reply with quote

When I open up kwallet settings through the kwalletmanager5's settings menu, it says:

Quote:
KDE Wallet Configuration
You are not allowed to save the configuration
Indeed, I can not save the settings. I click on "show manager in systray", the "OK" button remains grey, although "Apply" button allows me to apply. If I cancel and get back into settings, the previously applied setting is cleared. I can never see my wallet manager in systray because of this. So, I have to keep the window of the kwalletmanager5 open all the time. This was working fine with kwallet:4 (*).

This has me stumped for a while. Any KDE maestro around here knows what's going on?

(*): I only have kdewallet:5 and only kwalletd5 and kwalletmanager5 are running.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Jan 05, 2017 8:59 am    Post subject: Reply with quote

It's the same on my system, and everything I found in the internet is about directory permissions of ~/.local/share/kwalletd and /home/sed/.config/kwalletrc, but those are fine.

I ended up editing my kwalletrc by hand:
Code:
 $ cat /home/sed/.config/kwalletrc
[Wallet]
Close When Idle=false
Close on Screensaver=false
Default Wallet=kwallet
Enabled=true
First Use=false
Idle Timeout=10
Launch Manager=true
Leave Manager Open=false
Leave Open=false
Local Wallet=pwstore
Prompt on Open=true
Use One Wallet=false
Your "show manager in systray" is the "Launch Manager" entry.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3711
Location: Hamburg

PostPosted: Thu Jan 05, 2017 9:56 am    Post subject: Reply with quote

I do just have this (KDE 5) - which works fine :
Code:
$ cat /home/tfoerste/.config/kwalletrc
[Wallet]
First Use=false
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Jan 05, 2017 1:12 pm    Post subject: Reply with quote

toralf wrote:
I do just have this (KDE 5) - which works fine :
Code:
$ cat /home/tfoerste/.config/kwalletrc
[Wallet]
First Use=false
And can you edit those settings using systemsettings5?
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3711
Location: Hamburg

PostPosted: Thu Jan 05, 2017 1:29 pm    Post subject: Reply with quote

Yamakuzure wrote:
toralf wrote:
I do just have this (KDE 5) - which works fine :
Code:
$ cat /home/tfoerste/.config/kwalletrc
[Wallet]
First Use=false
And can you edit those settings using systemsettings5?
Yes - I activated "system tray" - was asked for the root password and that's all :
Code:
tfoerste@t44 ~ $ cat /home/tfoerste/.config/kwalletrc
[Wallet]
Close When Idle=false
Close on Screensaver=false
Default Wallet=kdewallet
Enabled=true
First Use=false
Idle Timeout=10
Launch Manager=true
Leave Manager Open=false
Leave Open=true
Prompt on Open=false
Use One Wallet=true
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Thu Jan 05, 2017 5:52 pm    Post subject: Reply with quote

Code:

$ cat ~/.config/kwalletrc
[Migration]
alreadyMigrated=true

[Wallet]
First Use=false
so, @toralf, it should have worked for me too? But it does not. Are you sure you have only kwallet:5 and not kwallet:4 as well? To me it looks like you are using kwallet4. I could edit settings in kwallet4, but not in kwallet5.

just to be sure, I am using framework 5.29 and apps 16.12, with plasma at 5.8.4 sitting on top of QT 5.7.1
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Thu Jan 05, 2017 5:54 pm    Post subject: Reply with quote

Quote:
... was asked for the root password and that's all
root password? You mean the wallet password, right?

Why would editing my wallet settings require root password? Is that the root (no pun) of the problem?
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Fri Jan 06, 2017 10:24 am    Post subject: Reply with quote

devsk wrote:
just to be sure, I am using framework 5.29 and apps 16.12, with plasma at 5.8.4 sitting on top of QT 5.7.1
It is the same on my system. A root password should not be required, as all files are owned by me anyway.

...this is really weird...
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Fri Jan 06, 2017 5:06 pm    Post subject: Reply with quote

@toralf: can you please confirm the questions above? you left us with a shocker of root password...:-D
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3711
Location: Hamburg

PostPosted: Fri Jan 06, 2017 5:51 pm    Post subject: Reply with quote

devsk wrote:
@toralf: can you please confirm the questions above? you left us with a shocker of root password...:-D
Hhm, I must admit, the root pw is the same as the pw of mine, so my comment was wrong wrt this.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Fri Jan 06, 2017 7:50 pm    Post subject: Reply with quote

I don't know if it's any help but the situation on my laptop running Gentoo Stable is shown below, and the KWallet 5 functionality works as expected:

Code:
$ cat ~/.config/kwalletrc
[Wallet]
Close When Idle=false
Close on Screensaver=false
Default Wallet=kdewallet
Enabled=true
First Use=false
Idle Timeout=10
Launch Manager=true
Leave Manager Open=false
Leave Open=true
Prompt on Open=false
Use One Wallet=true


Code:
$ eix -I kwallet
[I] kde-apps/kwalletmanager
     Available versions: 
     (4)    15.04.3-r1(4/15.04)
     (5)    16.08.3 ~16.12.0
       {aqua debug +handbook}
     Installed versions:  16.08.3(5)(17:19:46 19/12/16)(handbook -debug)
     Homepage:            https://www.kde.org/
     Description:         KDE Wallet management tool

[I] kde-apps/signon-kwallet-extension
     Available versions:  (5) 16.08.3 ~16.12.0
       {debug}
     Installed versions:  16.08.3(5)(16:58:44 19/12/16)(-debug)
     Homepage:            https://01.org/gsso/
     Description:         KWallet extension for signond

[I] kde-frameworks/kwallet
     Available versions:  (5) 5.26.0(5/5.26) ~5.29.0(5/5.29) ~5.29.0-r1(5/5.29)
       {debug gpg +man test}
     Installed versions:  5.26.0(5)(18:17:25 08/10/16)(man -debug -gpg -test)
     Homepage:            https://www.kde.org/
     Description:         Framework providing desktop-wide storage for passwords

[I] kde-plasma/kwallet-pam
     Available versions:  (5) 5.8.3 ~5.8.5
       {debug +oldwallet}
     Installed versions:  5.8.3(5)(20:46:21 15/12/16)(oldwallet -debug)
     Homepage:            https://www.kde.org/
     Description:         KWallet PAM module to not enter password again

Found 4 matches


If I look at System Settings > Account Details > KDE Wallet > Wallet Preferences > Launch Wallet Manager, under 'These applications are currently connected to this wallet:' on the Applications tab it shows three items: 'kwalletmanager5', 'kiod5' and 'ownCloud' (the ownCloud client is currently running).
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Sat Jan 07, 2017 2:13 am    Post subject: Reply with quote

What is the difference between ~/.config/kwalletrc and ~/.config/kwalletmanager5rc? Which one is being used by kwallet:5? I don't have kwallet:4 (the KDE4 version of the wallet).
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Sat Jan 07, 2017 2:44 pm    Post subject: Reply with quote

Code:
$ ls -la --time-style=long-iso ~/.config/kwalletrc
-rw------- 1 fitzcarraldo fitzcarraldo 230 2016-10-09 01:36 /home/fitzcarraldo/.config/kwalletrc
$ ls -la --time-style=long-iso ~/.config/kwalletmanager5rc
-rw------- 1 fitzcarraldo fitzcarraldo 194 2016-09-17 03:33 /home/fitzcarraldo/.config/kwalletmanager5rc

Code:
$ cat ~/.config/kwalletrc
[Wallet]
Close When Idle=false
Close on Screensaver=false
Default Wallet=kdewallet
Enabled=true
First Use=false
Idle Timeout=10
Launch Manager=true
Leave Manager Open=false
Leave Open=true
Prompt on Open=false
Use One Wallet=true

Code:
$ cat ~/.config/kwalletmanager5rc
[MainWindow]
Height 1080=584
State=AAAA/wAAAAD9AAAAAAAAA1YAAAIqAAAABAAAAAQAAAAIAAAACPwAAAAA
ToolBarsMovable=Disabled
Width 1920=854

[WalletEditor]
AlwaysShowContents=false
SplitterSize=385,448

I don't have kwallet:4 either. Perhaps kwallet:5 uses both those config files?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Sat Jan 07, 2017 4:50 pm    Post subject: Reply with quote

@Fitzcarraldo: I killed the kwalletd5, and copied your ~/.config/kwalletrc. Started kwalletmanager5. It still showed

Quote:
KDE Wallet Configuration
You are not allowed to save the configuration
in settings. But at least it goes to the tray and sits there.

My RC files are exactly like yours but I still can't edit the settings. Do I need the user to be in some special group or something?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Sat Jan 07, 2017 5:47 pm    Post subject: Reply with quote

My user is in the following groups, and has been since I was using KDE 4:

Code:
$ groups
disk lp wheel floppy uucp cron cdrom video games cdrw usb users plugdev crontab android wireshark vboxusers scanner fitzcarraldo


I can remember following the instructions in the Plasma 5 upgrade article in the Wiki, which I assume you did too:

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#KWallet

I can't remember for sure now, but I have a feeling the wallet was not working properly after doing that so I unmerged all wallet-related packages and re-installed the :5 packages.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Sat Jan 07, 2017 7:40 pm    Post subject: Reply with quote

I am surprised that a simple migration plan could not be created by KDE folks. I could edit and save settings in kde:4.

kdewallet is full of bugs (410 open bugs) if you query bugs.kde.org. And nobody cares over there. I don't see a developer around.

The following bug talks about auth and saving of config:

https://bugs.kde.org/show_bug.cgi?id=357039

The following is the exact bug we are talking about here in this thread:

https://bugs.kde.org/show_bug.cgi?id=356624

And guess what? No developer around. Is this abandoned or what? does anybody know the kwallet's maintainer?
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Sun Jan 08, 2017 1:05 am    Post subject: Reply with quote

Hmm, I wonder if it's something to do with the kwallet settings in the /etc/pam.d/ directory? I've just had a look at the Arch Linux Wiki article on KDE Wallet and it makes interesting reading. But then I looked at the files in my /etc/pam.d/ directory and they don't look correct either, even though the wallet appears to be working correctly and I definitely don't have kwallet:4 installed (see eix output in one of my earlier posts). Anyway, here is what I have on my Clevo laptop (OpenRC only, and USE="-systemd"), just so you can compare it with what you have:

Code:
# ls -1 /etc/pam.d/
chage
chfn
chgpasswd
chpasswd
chsh
crond
cups
groupadd
groupdel
groupmems
groupmod
imap
imap4
imap4s
imaps
kde
kde-np
lightdm
lightdm-autologin
lightdm-greeter
login
newusers
other
passwd
polkit-1
pop
pop3
pop3s
pops
ppp
qingy
saslauthd
shadow
sshd
start-stop-daemon
su
sudo
supervise-daemon
system-auth
system-local-login
system-login
system-remote-login
system-services
useradd
userdel
usermod

Code:
# locate kwallet5 | grep -v doc
/etc/dbus-1/system.d/org.kde.kcontrol.kcmkwallet5.conf
/lib64/security/pam_kwallet5.so
/usr/lib64/qt5/plugins/kcm_kwallet5.so
/usr/share/dbus-1/system-services/org.kde.kcontrol.kcmkwallet5.service
/usr/share/polkit-1/actions/org.kde.kcontrol.kcmkwallet5.policy

Code:
# grep kwallet /etc/pam.d/*
/etc/pam.d/kde:-auth      optional     pam_kwallet.so kdehome=.kde4
/etc/pam.d/kde:-session   optional     pam_kwallet.so

Let me know if you want me to list the contents of any of those files.
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Mon Jan 09, 2017 2:47 pm    Post subject: Reply with quote

Fitzcarraldo wrote:
I don't know if it's any help but the situation on my laptop running Gentoo Stable is shown below, and the KWallet 5 functionality works as expected:
Yes. Your are on
kde-frameworks-5.26.0 using
kde-apps-16.08.3

Everything was fine back then.

We, who are no longer allowed to edit our own files through systemsettings5, are on
kde-frameworks-5.29.0 using
kde-apps-16.12.0
;-)

Well, kde-frameworks-5.30.0 is starting to appear in kde overlay today. Hopefully this wretched bug is squished then.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7140
Location: Austria

PostPosted: Mon Jan 09, 2017 8:27 pm    Post subject: Reply with quote

Not necessarily. Everything's fine for me on ~arch packages as well...

Fitzcarraldo wrote:
even though the wallet appears to be working correctly and I definitely don't have kwallet:4 installed
Code:
# grep kwallet /etc/pam.d/*
/etc/pam.d/kde:-auth      optional     pam_kwallet.so kdehome=.kde4
/etc/pam.d/kde:-session   optional     pam_kwallet.so

OK, two things:
- kwallet-pam is only required for auto-unlock (if you share your login password with the wallet password). If you wish to rule out any bad effect of it, you can just remove it. It is also being pulled in by plasma-meta[pam].
- your kwallet-pam configuration is wrong (it is for kwalletd:4). However, it has no effect because 'kde' is from KDM, and you will likely be on SDDM or lightdm, if you use any login mgr at all?

So here's what kde-plasma/kwallet-pam would have to say to you if you have kde-frameworks/kwallet:5, but not kde-apps/kwalletd:4 installed:
Code:
$ ebuild kwallet-pam-5.8.5.ebuild postinst
 *
 * This package enables auto-unlocking of kde-frameworks/kwallet:5.
 * List of things to make it work:
 * 1.  Use standard blowfish encryption instead of GPG
 * 2.  Use same password for login and kwallet
 * 3.  A display manager with support for PAM
 * 4.a Have the following lines in the display manager's pam.d file:
 *     -auth        optional        pam_kwallet5.so
 *     -session     optional        pam_kwallet5.so auto_start

Change your DM's pam.d file accordingly if you wish to have that auto-unlock feature. See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Jan 10, 2017 1:14 pm    Post subject: Reply with quote

asturm wrote:
Not necessarily. Everything's fine for me on ~arch packages as well...
Hmmm... So how can we find out what the matter is, then?

These lines appear in /var/log/messages when I first start the personal settings pane in systemsettings5 after login:
Code:
Jan 10 14:12:28 sed-notebook dbus[6665]: [system] Activating service name='org.freedesktop.Accounts' (using servicehelper)
Jan 10 14:12:28 sed-notebook accounts-daemon[1211]: started daemon version 0.6.43                     
Jan 10 14:12:28 sed-notebook dbus[6665]: [system] Successfully activated service 'org.freedesktop.Accounts'
That's from sys-apps/accountsservice right?

Do you have USE="introspection" enabled?
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1763
Location: United Kingdom

PostPosted: Wed Jan 11, 2017 2:57 am    Post subject: Reply with quote

asturm wrote:
Fitzcarraldo wrote:
even though the wallet appears to be working correctly and I definitely don't have kwallet:4 installed
Code:
# grep kwallet /etc/pam.d/*
/etc/pam.d/kde:-auth      optional     pam_kwallet.so kdehome=.kde4
/etc/pam.d/kde:-session   optional     pam_kwallet.so

OK, two things:
- kwallet-pam is only required for auto-unlock (if you share your login password with the wallet password). If you wish to rule out any bad effect of it, you can just remove it. It is also being pulled in by plasma-meta[pam].
- your kwallet-pam configuration is wrong (it is for kwalletd:4). However, it has no effect because 'kde' is from KDM, and you will likely be on SDDM or lightdm, if you use any login mgr at all?

So here's what kde-plasma/kwallet-pam would have to say to you if you have kde-frameworks/kwallet:5, but not kde-apps/kwalletd:4 installed:
Code:
$ ebuild kwallet-pam-5.8.5.ebuild postinst
 *
 * This package enables auto-unlocking of kde-frameworks/kwallet:5.
 * List of things to make it work:
 * 1.  Use standard blowfish encryption instead of GPG
 * 2.  Use same password for login and kwallet
 * 3.  A display manager with support for PAM
 * 4.a Have the following lines in the display manager's pam.d file:
 *     -auth        optional        pam_kwallet5.so
 *     -session     optional        pam_kwallet5.so auto_start

Change your DM's pam.d file accordingly if you wish to have that auto-unlock feature. See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking

Thank you for the advice.

Even thought I followed the Plasma 5 Wiki article's instructions:

Code:
# cat /etc/portage/package.use/kdebase-runtime-meta
kde-apps/kdebase-runtime-meta -oldwallet

I have just noticed that the oldwallet USE flag is set in kde-plasma/kwallet-pam:

Code:
 # eix -I kwallet-pam
[I] kde-plasma/kwallet-pam
     Available versions:  (5) 5.8.3 ~5.8.5
       {debug +oldwallet}
     Installed versions:  5.8.3(5)(20:46:21 15/12/16)(oldwallet -debug)
     Homepage:            https://www.kde.org/
     Description:         KWallet PAM module to not enter password again

so I will now create a file /etc/portage/package.use/kwallet-pam containing the following, then rebuild the package:

Code:
kde-plasma/kwallet-pam -oldwallet


I'm using LightDM. I don't want the auto-unlock feature, so I'll leave the LightDM pam.d files as they were installed:

Code:
# cat /etc/pam.d/lightdm
# File autogenerated by pamd_mimic in pam eclass


auth            include         system-local-login
account         include         system-local-login
password        include         system-local-login
session         include         system-local-login

Code:
# cat /etc/pam.d/lightdm-autologin
auth    optional        pam_env.so
auth    required        pam_nologin.so
auth    required        pam_permit.so

account include         system-local-login
session include         system-local-login

Code:
# cat /etc/pam.d/lightdm-greeter
# File autogenerated by pamd_mimic in pam eclass


auth            include         system-local-login
account         include         system-local-login
password        include         system-local-login
session         include         system-local-login


<off-topic>
I don't like LightDM but SDDM does not work on my Clevo W230SS laptop with Optimus hardware, only on my Compal NBLB2 laptop with AMD GPU. LightDM only supports Suspend and Hibernate for systemd-logind or UPower <0.99. The LightDM KDE Greeter code is several years old and only supports UPower <0.99. So I had to patch LightDM 1.18.3 itself and switch to the LightDM GTK Greeter (LightDM login screen: Suspend button is greyed-out [Solved]).
</off-topic>


EDIT (2017-01-12 17:58 UTC): OK, I succumbed in the end:

Code:
# rm /etc/pam.d/kde # Can delete this file as it is for KDM (KDE 4).
# eix -I kwallet-pam
[I] kde-plasma/kwallet-pam
     Available versions:  (5) 5.8.3 ~5.8.5
       {debug +oldwallet}
     Installed versions:  5.8.3(5)(03:02:09 11/01/17)(-debug -oldwallet)
     Homepage:            https://www.kde.org/
     Description:         KWallet PAM module to not enter password again

# cd /usr/portage/kde-plasma/kwallet-pam/
# ebuild kwallet-pam-5.8.3.ebuild postinst
 *
 * This package enables auto-unlocking of kde-frameworks/kwallet:5.
 * List of things to make it work:
 * 1.  Use standard blowfish encryption instead of GPG
 * 2.  Use same password for login and kwallet
 * 3.  A display manager with support for PAM
 * 4.a Have the following lines in the display manager's pam.d file:
 *     -auth        optional        pam_kwallet5.so
 *     -session     optional        pam_kwallet5.so auto_start
 * 4.b Checking installed DMs...
 *     LightDM - /etc/pam.d/lightdm ...GOOD
 *
# cat /etc/pam.d/lightdm
# File autogenerated by pamd_mimic in pam eclass


auth            include         system-local-login
account         include         system-local-login
password        include         system-local-login
session         include         system-local-login

-auth           optional        pam_kwallet5.so
-session        optional        pam_kwallet5.so auto_start
# cat /etc/pam.d/lightdm-autologin
auth    optional        pam_env.so
auth    required        pam_nologin.so
auth    required        pam_permit.so

account include         system-local-login
session include         system-local-login
# cat /etc/pam.d/lightdm-greeter
# File autogenerated by pamd_mimic in pam eclass


auth            include         system-local-login
account         include         system-local-login
password        include         system-local-login
session         include         system-local-login



EDIT (2017-01-17 09:32 UTC): I reinstated /etc/pam.d/kde with the contents below, otherwise I have to start a new session from the Lock Screen to get back to the desktop:

Code:
#%PAM-1.0

auth       required     pam_nologin.so

auth       include      system-local-login

account    include      system-local-login

password   include      system-local-login

session    include      system-local-login

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog


Last edited by Fitzcarraldo on Tue Jan 17, 2017 9:34 am; edited 1 time in total
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Sun Jan 15, 2017 8:20 am    Post subject: Reply with quote

kf5 5.30 drops. Does anybody wanna bet this bug is fixed?

Edit: Whoever bet the bug won't be fixed, has won the bet. Congratulations!
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2870
Location: Bay Area, CA

PostPosted: Mon Jan 16, 2017 6:12 am    Post subject: Reply with quote

The good folks who are not able to change settings, can you please go over this bug and report: https://bugs.kde.org/show_bug.cgi?id=356624
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Tue Jan 17, 2017 10:32 am    Post subject: Reply with quote

devsk wrote:
The good folks who are not able to change settings, can you please go over this bug and report: https://bugs.kde.org/show_bug.cgi?id=356624
Done. Thank you for finding this!

However, I will not only update to Frameworks 5.30 today, but will also remove USE="-introspection" from my make.conf.
...it doesn't really hurt and maybe the introspection code in sys-apps/accountsservice has something to do with it.
Yes, that's really far fetched, but as I am doing a big world update anyway, I'll try it.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Wed Jan 18, 2017 11:42 am    Post subject: Reply with quote

USE="introspection" has nothing to do with it.

@devsk: Which session tracker do you use? ConsoleKit, systemd-logind or elogind?
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum