Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sddm segfaults when starting [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
gibus92
n00b
n00b


Joined: 27 Dec 2016
Posts: 12
Location: France

PostPosted: Tue Dec 27, 2016 1:31 pm    Post subject: sddm segfaults when starting [SOLVED] Reply with quote

Hello,

I am running gentoo in virtualbox 5.1.12 and all packages are up to date. I checked with revdep-rebuild that all dependencies are consistent. I was able to start plasma 5 with last 5.1.8 virtualbox guest additions. Now I take morning updates with 4.4.39 kernel sources, have to remove app-emulation/virtualbox-guest-additions and x11-drivers/xf86-video-virtualbox, installed latest kernel and video/guest additions again.

sddm segfaults at multiple times. I thought sddm was crashing because of guest additions and removed both guest additions and virtualbox video, but still no luck. I had hope to start plasma 5 at the price of no guest additions functions, but still no luck.

Then I have followed gentoo debug guide, emerged again sddm with source code and symbols, tried to use coredumpctl with gdb but no core found. Finally, I tried to launch sddm from gdb to get a stack trace, but I don't know if it is useful. Hereis the output : https://bpaste.net/show/3266f48ff1fc

I am not a software developer and don't know how to go further, so any help would be greatly appreciated.


Last edited by gibus92 on Tue Dec 27, 2016 4:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21687
Location: here

PostPosted: Tue Dec 27, 2016 2:31 pm    Post subject: Reply with quote

Can help this?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gibus92
n00b
n00b


Joined: 27 Dec 2016
Posts: 12
Location: France

PostPosted: Tue Dec 27, 2016 2:49 pm    Post subject: Reply with quote

Well I forget to say that I am using systemd, not openrc. I've followed the thread, but no, still not able to start sddm. Directory /var/lib/sddm is here. I have even no sddm log at all.
Back to top
View user's profile Send private message
gibus92
n00b
n00b


Joined: 27 Dec 2016
Posts: 12
Location: France

PostPosted: Tue Dec 27, 2016 4:33 pm    Post subject: Reply with quote

I think this issue has nothing to do with gentoo. Short way : I managed to go to 5.1.8 and back to 5.1.12 Virtualbox installation under my windows host...

Long way : I have backed up my Gentoo virtual machine, uninstalled both app-emulation/virtualbox-guest-additions and x11-drivers/xf86-video-virtualbox 5.1.12 packages. Next, I have uninstalled Virtualbox 5.1.12 under my windows 7 host. I installed Virtualbox 5.1.8 since this last used to work with gentoo, and installed guest additions from Oracle Virtualbox CD since 5.1.8 guest additions package have been removed from Gentoo portage tree. Starting again. No way : this is not working any more! Stopped again my VM, uninstalled Virtualbox 5.1.8 under Windows and go back to 5.1.12 ; I have restored my virtual machines and now, gentoo plasma 5 can start!

I anyone has understood what has happened, I won't refuse any explanation ...

Guess what? under Windows host, 5.1.8 / 5.1.12 Virtualbox files were badly messed up... Next time I won't update my virtualbox installation : I'll remove everything and will install from scratch...

Sorry for the annoyance here and thanks for your help, fedeliallalinea...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum