Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WLAN , get no IP but i cant find an error [solved]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Fri Dec 30, 2016 3:01 pm    Post subject: Reply with quote

Here are the infos:

Code:
[code]neueKiste ~ # dhcpcd wlp2s0
wlp2s0: waiting for carrier
timed out
dhcpcd exited
[/code]neueKiste ~ # ifconfig -a
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.22  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::8946:4542:f614:8c3a  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8108:1c0:4910:31e6:66bd:7ddb:be8e  prefixlen 64  scopeid 0x0<global>
        ether 70:8b:cd:a4:7a:93  txqueuelen 1000  (Ethernet)
        RX packets 1362  bytes 1265094 (1.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1101  bytes 136711 (133.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 2040  bytes 166216 (162.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2040  bytes 166216 (162.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether ae:ee:1c:fe:be:ba  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0



Code:
route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.178.1   0.0.0.0         UG    100    0        0 enp4s0
192.168.178.0   0.0.0.0         255.255.255.0   U     100    0        0 enp4s0
[

dmesg here https://paste.pound-python.org/show/VWziipIbfCd6ZZD05wUC/
---------------
I would like to tell you how great I find it to learn from you. By your explanations in a thread I get better in the solution

EDIT: i found at checks a folllwing info. There are 2 names of the network. thats an error?
Code:
neueKiste ~ # ls -lha /etc/NetworkManager/system-connections/
total 16K
drwxr-xr-x 2 root root 4.0K Dec 20 10:47 .
drwxr-xr-x 4 root root 4.0K Dec 23 13:55 ..
-rw------- 1 root root    0 Dec 23 13:55 .keep_net-misc_networkmanager-0
-rw------- 1 root root  416 Dec 29 12:20 'FRITZ!Box 7490'
-rw------- 1 root root  462 Dec 20 10:47 databoxspeeddragon
neueKiste ~ # systemctl restart network-manager.service
Failed to get D-Bus connection: Operation not permitted
neueKiste ~ # systemctl restart networking restart
Failed to get D-Bus connection: Operation not permitted

_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Fri Dec 30, 2016 4:58 pm    Post subject: Reply with quote

michi-monster,

Code:
neueKiste ~ # dhcpcd wlp2s0
wlp2s0: waiting for carrier
timed out


Tells that wlp2s0 did not start. There is nothing in dmesg that shows it even tried.
That's ok. Lets try the manual way.

Code:
cd /etc/init.d

Does
Code:
ls -l
show
Code:
net.wlp2s0 -> net.lo

if not, make the symbolic link.
Code:
ln -s net.lo net.wlp2s0

Check again.

If all is well, try
Code:
/etc/init.d/net.wlp2s0 start

What does
Code:
ifconfig -a
route
dmesg
show now?
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Sat Dec 31, 2016 7:30 am    Post subject: Reply with quote

The link for net.wlp2s0 was aktiv

Code:

ls -l /etc/init.d
neueKiste init.d # ls -l
total 308
-rwxr-xr-x 1 root root  1774 Dec 23 13:55 NetworkManager
-rwxr-xr-x 1 root root  4848 Dec 23 10:05 apache2
-rwxr-xr-x 1 root root   462 Dec 23 10:13 avahi-daemon
-rwxr-xr-x 1 root root   456 Dec 23 10:13 avahi-dnsconfd
-rwxr-xr-x 1 root root   800 Dec 27 15:54 binfmt
-rwxr-xr-x 1 root root   461 Dec 27 14:35 bluetooth
-rwxr-xr-x 1 root root  5846 Dec 27 15:54 bootmisc
-rwxr-xr-x 1 root root   270 Dec 27 15:48 busybox-ntpd
-rwxr-xr-x 1 root root   230 Dec 27 15:48 busybox-watchdog
-rwxr-xr-x 1 root root  1850 Dec 27 15:54 consolefont
-rwxr-xr-x 1 root root   859 Dec 21 10:39 dbus
-rwxr-xr-x 1 root root  3549 Dec 27 15:54 devfs
-rwxr-xr-x 1 root root  3714 Dec 27 15:20 device-mapper
-rwxr-xr-x 1 root root   328 Dec 20 10:42 dhcpcd
-rwxr-xr-x 1 root root  2886 Dec 23 09:32 dhcpd
-rwxr-xr-x 1 root root   705 Dec 23 09:32 dhcrelay
-rwxr-xr-x 1 root root   705 Dec 23 09:32 dhcrelay6
-rwxr-xr-x 1 root root   747 Dec 27 15:54 dmesg
-rwxr-xr-x 1 root root   572 Dec 27 15:20 dmeventd
-rwxr-xr-x 1 root root  3152 Dec 27 15:54 fsck
lrwxrwxrwx 1 root root    25 Dec 27 15:54 functions.sh -> /lib64/rc/sh/functions.sh
-rwxr-xr-x 1 root root   560 Dec 21 10:06 gpm
-rwxr-xr-x 1 root root  1133 Dec 27 15:54 hostname
-rwxr-xr-x 1 root root  3310 Dec 27 15:54 hwclock
-rwxr-xr-x 1 root root  2773 Dec 15 03:49 ip6tables
-rwxr-xr-x 1 root root  2773 Dec 15 03:49 iptables
-rwxr-xr-x 1 root root  2164 Dec 27 15:54 keymaps
-rwxr-xr-x 1 root root   800 Dec 27 15:54 killprocs
-rwxr-xr-x 1 root root   507 Dec 15 03:48 kmod-static-nodes
-rwxr-xr-x 1 root root  2623 Dec 27 15:54 local
-rwxr-xr-x 1 root root  3598 Dec 27 15:54 localmount
-rwxr-xr-x 1 root root  1060 Dec 27 15:54 loopback
-rwxr-xr-x 1 root root  3778 Dec 27 15:20 lvm
-rwxr-xr-x 1 root root   970 Dec 27 15:20 lvm-monitoring
-rwxr-xr-x 1 root root   355 Dec 27 15:20 lvmetad
-rwxr-xr-x 1 root root  2285 Dec 27 15:54 modules
-rwxr-xr-x 1 root root  1639 Dec 27 15:54 modules-load
-rwxr-xr-x 1 root root  1566 Dec 27 15:54 mount-ro
-rwxr-xr-x 1 root root  1489 Dec 27 15:54 mtab
-rwxr-xr-x 1 root root  2043 Dec 27 15:54 net-online
lrwxrwxrwx 1 root root     6 Dec 30 15:45 net.enp4s0 -> net.lo
-rwxr-xr-x 1 root root 18514 Dec 15 05:36 net.lo
lrwxrwxrwx 1 root root     6 Dec 22 11:39 net.wlp2s0 -> net.lo
-rwxr-xr-x 1 root root  2049 Dec 27 15:54 netmount
-rwxr-xr-x 1 root root   727 Dec 20 15:01 ntp-client
-rwxr-xr-x 1 root root   496 Dec 20 15:01 ntpd
-rwxr-xr-x 1 root root  1136 Dec 27 15:54 numlock
-rwxr-xr-x 1 root root   642 Dec 27 15:54 osclock
-rwxr-xr-x 1 root root  1270 Dec 27 15:54 procfs
-rwxr-xr-x 1 root root   610 Dec 21 10:04 pydoc-2.7
-rwxr-xr-x 1 root root   610 Dec 21 10:10 pydoc-3.4
-rwxr-xr-x 1 root root   553 Dec 27 14:35 rfcomm
-rwxr-xr-x 1 root root  1407 Dec 27 15:54 root
-rwxr-xr-x 1 root root   254 Dec 27 16:00 rsyncd
-rwxr-xr-x 1 root root  1110 Dec 27 15:54 runsvdir
-rwxr-xr-x 1 root root  1030 Dec 27 15:54 s6-svscan
-rwxr-xr-x 1 root root  1881 Dec 27 15:54 savecache
-rwxr-xr-x 1 root root   491 Dec 20 15:01 sntp
-rwxr-xr-x 1 root root  2115 Dec 21 11:24 sshd
-rwxr-xr-x 1 root root  1019 Dec 27 15:54 swap
-rwxr-xr-x 1 root root   970 Dec 27 15:54 swclock
-rwxr-xr-x 1 root root  1323 Dec 27 15:54 sysctl
-rwxr-xr-x 1 root root  4789 Dec 27 15:54 sysfs
-rwxr-xr-x 1 root root  1470 Dec 27 15:54 termencoding
-rwxr-xr-x 1 root root   364 Dec 27 15:54 tmpfiles.dev
-rwxr-xr-x 1 root root   340 Dec 27 15:54 tmpfiles.setup
-rwxr-xr-x 1 root root  4700 Dec 15 05:37 udev
-rwxr-xr-x 1 root root  1370 Dec 27 15:54 urandom
-rwxr-xr-x 1 root root  1250 Dec 21 17:54 wpa_supplicant
-rwxr-xr-x 1 root root  6028 Dec 21 15:45 xdm



If i manually start wlp2s0 i get an error. But if i start and stop by ifconfig wlp2s0 i dont get an error
Code:
neueKiste init.d # /etc/init.d/net.wlp2s0 start
 * WARNING: net.wlp2s0 has already started, but is inactive
neueKiste init.d # /etc/init.d/net.wlp2s0 stop
 * Bringing down interface wlp2s0
 *   Stopping wpa_cli on wlp2s0 ...                                                     [ ok ]
 *   Stopping wpa_supplicant on wlp2s0 ...                                              [ ok ]
RTNETLINK answers: No such file or directory
Error talking to the kernel
neueKiste init.d # /etc/init.d/net.wlp2s0 start
 * Bringing up interface wlp2s0
 *   Starting wpa_supplicant on wlp2s0 ...
Successfully initialized wpa_supplicant
rfkill: WLAN soft blocked                                                               [ ok ]
 *   Starting wpa_cli on wlp2s0 ...                                                     [ ok ]
 *   Backgrounding ... ...
 * WARNING: net.wlp2s0 has started, but is inactive
neueKiste init.d #
-rwxr-xr-x 1 root root   232 Dec 21 15:45 xdm-setup


Code:
ifconfig -a
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.20  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fd00::4993:a27:5c75:6676  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::8946:4542:f614:8c3a  prefixlen 64  scopeid 0x20<link>
        inet6 2a02:8108:1c0:4910:31e6:66bd:7ddb:be8e  prefixlen 64  scopeid 0x0<global>
        ether 70:8b:cd:a4:7a:93  txqueuelen 1000  (Ethernet)
        RX packets 16562  bytes 15892463 (15.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 10986  bytes 1368855 (1.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 48  bytes 3312 (3.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 48  bytes 3312 (3.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether ae:3c:10:e8:3d:87  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Code:
neueKiste init.d # route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         fritz.box       0.0.0.0         UG    100    0        0 enp4s0
192.168.178.0   0.0.0.0         255.255.255.0   U     100    0        0 enp4s0


dmesg here https://paste.pound-python.org/show/CHm4cMxoh2twANYrMkID/
_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42596
Location: 56N 3W

PostPosted: Sat Dec 31, 2016 3:57 pm    Post subject: Reply with quote

michi-monster,

Code:
rfkill: WLAN soft blocked
That's useful. Your wifi transmitter is switched off in software.
Use rfkill to turn it on. Then start wlp2s0 again.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
michi-monster
Apprentice
Apprentice


Joined: 16 Aug 2016
Posts: 175
Location: Germany

PostPosted: Mon Jan 02, 2017 6:29 am    Post subject: Reply with quote

Many thanks - i am online with wlan :-)
i am happy.
_________________
www.edv-bildung.de
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum