Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amavisd-new doesn't start after world update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 965
Location: Dinslaken, Germany

PostPosted: Fri Dec 23, 2016 11:28 am    Post subject: amavisd-new doesn't start after world update Reply with quote

Hello!

Today I had a world update and after that amavisd doesn't start anymore. What I can find in the logs is the following:

Code:

amavis[4499]: (!)Net::Server: 2016/12/23-12:21:05 Pid_file already exists for running process (4565)... aborting\n\n  at line 144 in file /usr/lib64/perl5/vendor_perl/5.22.2/Net/Server.pm


A lot of perl packages were updated. I don't know if that is the reason. I can start the daemon but amavis is actually not running. In Netstat -tap I don't see amavis listening on port 10024. Any ideas?
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
aZZe
l33t
l33t


Joined: 20 Feb 2003
Posts: 965
Location: Dinslaken, Germany

PostPosted: Fri Dec 23, 2016 11:56 am    Post subject: Reply with quote

I also trid to rebuild all perl packages by using

Code:

perl-cleaner --allmodules


But I still get thos error messages when I try to start amavis in debug mode:

Code:

/usr/sbin/amavisd[4204]: (!)Net::Server: 2016/12/23-12:52:10 Unable to load module for proto "Net::Server::Proto::UNIX": Can't locate Net/Server/Proto/UNIX.pm:   lib/Net/Server/Proto/UNIX.pm: Permission denied at /usr/lib64/perl5/vendor_perl/5.22.3/Net/Server/Proto.pm line 198.\n\n  at line 198 in file /usr/lib64/perl5/vendor_perl/5.22.3/Net/Server/Proto.pm


And that is just one module to give you guys an example. There are many other perl modules which don't seem to work anymore.
_________________
ASUS 4A785TD-V EVO with AMD Phenom(tm) II X4 965
4GB RAM DDR3-1333
ATI Radeon HD4870
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum