Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] firefox-50 ocassionally does not refresh its window
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Fri Nov 25, 2016 5:48 pm    Post subject: [solved] firefox-50 ocassionally does not refresh its window Reply with quote

Ever since I upgraded to firefox-50 a couple of days ago, I have noticed that occasionally when the firefox window does Not have the mouse focus that the firefox window is not refreshed. (ex: when I move an xterm window over the firefox window the xterm window leaves black rectangles on the firefox window.) As soon as the firefox window has the mouse focus, the firefox window refreshes and firefox works normally.

Installed versions: 50.0^d(19:39:59 11/21/16)(dbus gmp-autoupdate hwaccel jemalloc jit skia)

firefox is one of the few applications that I use keywords for to give me an 'unstable' application. In this case my /etc/portage/package.keywords contains:
Code:
=dev-libs/nss-3.27.1 ~amd64
=www-client/firefox-50.0 ~amd64


Any ideas???


Last edited by jagdpanther on Sat Dec 31, 2016 7:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Mon Nov 28, 2016 7:54 am    Post subject: Reply with quote

Sorry, I don't have answer to your question. Just wanted to say, that after upgrade to version 50 I couldn't watch any video in Firefox. So I had to downgrade to stable version. Looks like version 50 is too buggy.
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Mon Nov 28, 2016 1:49 pm    Post subject: Reply with quote

v_andal: Thanks for the reply. I do not have any issues watching videos (youtube, etc) in firefox-50; just the refresh issue.
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Tue Nov 29, 2016 8:05 am    Post subject: Reply with quote

I suspect it all depends on the video drivers that are in use. On one computer newer Firefox had problems with refresh when I was using fglrx driver for ATI video card. When I've switched to radeon driver, firefox started to refresh correctly. On another pc I'm using Intel video card, as I said here after upgrading to firefox-50 videos stopped working. They would endlessly loop over first few frames, only sound was correct. So, what is your video card and driver?
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Tue Nov 29, 2016 2:38 pm    Post subject: Reply with quote

Quote:
So, what is your video card and driver?

Guess this is not just an ATI or Nvidia issue.

I am using:
Nvidia (Evga) GTX 970
x11-drivers/nvidia-drivers-361.28

Later this week, I'll be able to test on another Gentoo system with an older Nvidia Card (same driver) and see if the same Firefox-50 issue happens there.
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Sat Dec 03, 2016 3:29 am    Post subject: Reply with quote

I upgraded (emerge) from firefox-50.0 to firefox-50.0.2 and still have the refresh issue.

Edit: I upgraded to firefox-50.1.0 and still have the refresh issue.


Last edited by jagdpanther on Sat Dec 17, 2016 1:49 am; edited 1 time in total
Back to top
View user's profile Send private message
numlock
n00b
n00b


Joined: 17 Sep 2004
Posts: 58

PostPosted: Tue Dec 13, 2016 12:51 pm    Post subject: Reply with quote

Same issue here, on a Skylake laptop with Intel (i915) graphics, using xf86-video-intel.
Before Firefox 50, this issue didn't happen for me.

EDIT: Still happens with Firefox 50.1.0.


Last edited by numlock on Wed Dec 14, 2016 9:47 am; edited 1 time in total
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Wed Dec 14, 2016 8:52 am    Post subject: Reply with quote

Have you tried to disable hardware acceleration in Firefox?
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Sat Dec 17, 2016 1:54 am    Post subject: Reply with quote

v_andal wrote:
Have you tried to disable hardware acceleration in Firefox?


Yes I tried disabling hardware acceleration and restarting firefox ... I still have the refresh issue when my mouse focus is on any window other than the firefox window.

I have also tried disabling all of my addons ... same issue.

The interesting tidbit is that if I create a new user, su to that user and start up firefox (50.1.0) the refresh issue does NOT occur. I wonder if I set something in about:config (perhaps years ago) that is now causing me this strange issue?
Back to top
View user's profile Send private message
numlock
n00b
n00b


Joined: 17 Sep 2004
Posts: 58

PostPosted: Sun Dec 18, 2016 11:28 pm    Post subject: Reply with quote

jagdpanther wrote:
The interesting tidbit is that if I create a new user, su to that user and start up firefox (50.1.0) the refresh issue does NOT occur. I wonder if I set something in about:config (perhaps years ago) that is now causing me this strange issue?

Strange indeed!
Just a totally random guess: do you happen to have a high DPI (4k) display, by any chance?
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Mon Dec 19, 2016 2:02 am    Post subject: Reply with quote

Quote:
Strange indeed!
Just a totally random guess: do you happen to have a high DPI (4k) display, by any chance?


No 4k display. I have two 1920x1200 displays. (I typically only use one, the second is a wide gamut NEC used exclusively for photo post processing.)
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Mon Dec 19, 2016 6:32 am    Post subject: Reply with quote

Have-you try the xf86-video-intel driver options SwapbufferWait and VSync and the options EXAVSync and SwapbuffersWait of the xf86-video-radeon driver in the Xorg configuration?

These options do a vertical refresh when the screen is out of the refreshing area and help to advoid tearing. The xf86-video-nouveau driver have options related to this too. You can set it in $HOME/.drirc, Xfce4 and Kde4 have an option for VSync to Blank mode. The environment variable vblank_mode do it when set to 0.
_________________
Paul
Back to top
View user's profile Send private message
numlock
n00b
n00b


Joined: 17 Sep 2004
Posts: 58

PostPosted: Mon Dec 19, 2016 5:07 pm    Post subject: Reply with quote

Logicien wrote:
Have-you try the xf86-video-intel driver options SwapbufferWait and VSync and the options EXAVSync and SwapbuffersWait of the xf86-video-radeon driver in the Xorg configuration?

These options do a vertical refresh when the screen is out of the refreshing area and help to advoid tearing. The xf86-video-nouveau driver have options related to this too. You can set it in $HOME/.drirc, Xfce4 and Kde4 have an option for VSync to Blank mode. The environment variable vblank_mode do it when set to 0.

Personally I don't think the problem could be related to VSYNC timing. But (just in case) with xf86-video-intel I have this line in my xorg.conf:
Option "TearFree" "true"

EDIT: I'm using the default SNA acceleration method at the moment. Haven't tried with UXA yet.


Last edited by numlock on Tue Dec 20, 2016 8:53 am; edited 2 times in total
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Mon Dec 19, 2016 6:41 pm    Post subject: Reply with quote

With xf86-video-intel you have choice between UXA and SNA as AccelMethod. Have-you try both? TearFree, SwapbufferWait and VSync are different options.
_________________
Paul
Back to top
View user's profile Send private message
acmondor
n00b
n00b


Joined: 08 Aug 2014
Posts: 35
Location: Canadian Prairies

PostPosted: Thu Dec 29, 2016 3:08 pm    Post subject: Reply with quote

I had the exact same refresh problem as originally described by jagdpanther. At the same time I also had problem with youtube video as described in https://forums.gentoo.org/viewtopic-t-1055310-highlight-firefox+video.html. I tried various different things to solve these problems but only one that worked was that described in the video post, namely:

Code:
layers.acceleration.force-enabled = false


After changing this setting in about:config and then closing an re-opening firefox the refresh problem was gone along with the youtube video problem.
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Sat Dec 31, 2016 6:03 pm    Post subject: Reply with quote

Quote:


[quote="jagdpanther"]
v_andal wrote:
Have you tried to disable hardware acceleration in Firefox?


Yes I tried disabling hardware acceleration and restarting firefox ... I still have the refresh issue when my mouse focus is on any window other than the firefox window.


Disabling hardware acceleration from the firefox preferences menue and restarting firefox did NOT fix the refresh issue. However, I just re-compiled (via emerge) with the -hwaccel use flag and the refresh issue went away.

I think I'll try emergeing firefox again with the hwaccel use flag back on and try acmondor's about:config suggestion:
Code:
layers.acceleration.force-enabled = false
Back to top
View user's profile Send private message
jagdpanther
Guru
Guru


Joined: 22 Nov 2003
Posts: 514

PostPosted: Sat Dec 31, 2016 7:14 pm    Post subject: Reply with quote

There seems to be two ways to fix the "firefox window not refreshing when firefox does not have mouse focus" issue:

1. Re-emerge firefox with the "-hwaccel" use flag.
(turning off hardware acceleration from firefox preferences -> Advanced does not fix the issue)

OR

2. In about:config (thank you acmondor)
Code:
layers.acceleration.force-enabled = false
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum