Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-editors/mousepad-0.4.0 displays poorly on XFCE?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pixel27
n00b
n00b


Joined: 10 May 2016
Posts: 4

PostPosted: Tue Dec 20, 2016 1:14 am    Post subject: app-editors/mousepad-0.4.0 displays poorly on XFCE? Reply with quote

I'm using XFCE, and installed the editor mousepad....It's display as basically a grey window, the menu has no definition it just shows:

"FileEditSearchViewDocumentHelp"

Just like that with no spaces between the items. Clicking on a word a submenu "appears", but there is no lines defining the border of the submenu, just the list of menu items. So everything seems to work but the display is just text on a featureless grey square.

I was thinking I needed to re-compile something so I ran:

equery g --depth=1 app-editors/mousepad

To see what libraries could possibly be handling the rendering and I get:

Code:

 * dependency graph for app-editors/mousepad-0.4.0
 `--  app-editors/mousepad-0.4.0  amd64
   `--  dev-libs/glib-2.48.2  (>=dev-libs/glib-2.30) amd64
   `--  dev-libs/dbus-glib-0.102  (>=dev-libs/dbus-glib-0.100) amd64
   `--  x11-libs/gtk+-2.24.31  (>=x11-libs/gtk+-2.24) amd64
   `--  x11-libs/gtksourceview-2.10.5-r3  (x11-libs/gtksourceview) amd64
   `--  x11-libs/gtk+-3.20.9  (x11-libs/gtk+) amd64
   `--  x11-libs/gtksourceview-3.20.4  (x11-libs/gtksourceview) amd64
   `--  dev-lang/perl-5.22.3_rc4  (dev-lang/perl) amd64
   `--  dev-util/intltool-0.51.0-r1  (dev-util/intltool) amd64
   `--  sys-devel/gettext-0.19.7  (sys-devel/gettext) amd64
   `--  virtual/pkgconfig-0-r1  (virtual/pkgconfig) amd64
   `--  sys-apps/sed-4.2.2  (>=sys-apps/sed-4) amd64
[ app-editors/mousepad-0.4.0 stats: packages (12), max depth (1) ]


gtk+ is listed twice as version 2.24.31 and 3.20.9 which seems odd, but I have no clue if that could be the issue.

dev-vcs/gitg is also experiencing the same issue (and has never displayed correctly) but it only uses gtk+-3.20.9 when I do an equery.

Those are the only 2 application that display funny. Any clues on how I track down the issue?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum