Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Konqueror-16-12.0 crashes with WebEngine
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 228

PostPosted: Mon Dec 19, 2016 3:23 am    Post subject: Konqueror-16-12.0 crashes with WebEngine Reply with quote

The new Konqueror crashes every time I load any web page.
Before it crashes it emits this error message:
Code:
WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.

It even crashes when I attempt to view a man page (eg. #portage).

This does not happen if select KHTML as the default Web browser engine.

Is it worth filling a bug report?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Mon Dec 19, 2016 1:24 pm    Post subject: Reply with quote

I have the same crash

I was kind of hoping that konqueror might be revitalized as a good
browser, but maybe not
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Mon Dec 19, 2016 3:45 pm    Post subject: Reply with quote

On my system it crashes immediately when started.
I'm running ~amd64.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 228

PostPosted: Mon Dec 19, 2016 5:41 pm    Post subject: Reply with quote

It is rendering webpages even slower and crappier than the previous versions.
Konqueror is only good for #manpages and ##infopages.
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3648
Location: Hamburg

PostPosted: Mon Dec 19, 2016 7:32 pm    Post subject: Reply with quote

workaround: switch to KHTML webengine
Back to top
View user's profile Send private message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 156

PostPosted: Mon Dec 19, 2016 10:35 pm    Post subject: Reply with quote

Thanks, but I don't really care about konqueror, its just one of those things that make me wonder how many other (security!) issues are lurking under the surface.

Sorry I have mixed topics.
Back to top
View user's profile Send private message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 228

PostPosted: Mon Dec 19, 2016 11:25 pm    Post subject: Reply with quote

Konqueror is only good for viewing man pages and info pages.
I'd be sorry to go back to viewing man pages from the Konsole.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Wed Dec 21, 2016 1:11 pm    Post subject: Reply with quote

Upstream fix: https://bugs.kde.org/show_bug.cgi?id=373781
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum