Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx blank screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
godof4dchess
n00b
n00b


Joined: 18 Dec 2016
Posts: 5

PostPosted: Sun Dec 18, 2016 12:48 am    Post subject: startx blank screen Reply with quote

Hello all, I'm new to linux and I followed the gentoo hand book and had a successful install. I tried to install xorg, which just gives me a blank black screen when I give the command startx, then I am forced to reboot. And if you have a solution can you give me your reasoning? if i should solve this myself, how would i go about it? i can give logs, this install is on a laptop.

Last edited by godof4dchess on Sun Dec 18, 2016 1:06 am; edited 1 time in total
Back to top
View user's profile Send private message
jonathan183
Guru
Guru


Joined: 13 Dec 2011
Posts: 308

PostPosted: Sun Dec 18, 2016 1:06 am    Post subject: Re: startx blank screen Reply with quote

godof4dchess wrote:
Hello all, I'm new to linux and I followed the gentoo hand book and had a successful install. I tried to install xorg, which just gives me a blank black screen when I give the command startx, then I am forced to reboot. And if you have a solution can you give me your reasoning? Very much appreciated.


Check /var/log/Xorg.0.log on your system for clues. Some information on hardware and contents of .xinitrc etc may also help narrow things down a bit ;)
Back to top
View user's profile Send private message
godof4dchess
n00b
n00b


Joined: 18 Dec 2016
Posts: 5

PostPosted: Sun Dec 18, 2016 1:08 am    Post subject: Re: startx blank screen Reply with quote

jonathan183 wrote:
godof4dchess wrote:
Hello all, I'm new to linux and I followed the gentoo hand book and had a successful install. I tried to install xorg, which just gives me a blank black screen when I give the command startx, then I am forced to reboot. And if you have a solution can you give me your reasoning? Very much appreciated.


Check /var/log/Xorg.0.log on your system for clues. Some information on hardware and contents of .xinitrc etc may also help narrow things down a bit ;)


no errors were reported, last thing that happened was synaptics being loaded. how would i paste my log here??
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Sun Dec 18, 2016 1:28 am    Post subject: Reply with quote

What WM/DE are you trying to start? Note, there is none if you didn't install one.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
godof4dchess
n00b
n00b


Joined: 18 Dec 2016
Posts: 5

PostPosted: Sun Dec 18, 2016 1:35 am    Post subject: Reply with quote

Jaglover wrote:
What WM/DE are you trying to start? Note, there is none if you didn't install one.


i was following the xorg guide cause the other tutorial said it was necessary for xfce
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2873
Location: Illinois, USA

PostPosted: Sun Dec 18, 2016 2:27 am    Post subject: Re: startx blank screen Reply with quote

godof4dchess wrote:
how would i paste my log here??
Use wgetpaste (emerge -a wgetpaste) then run "wgetpaste /var/log/Xorg.O.log" for example and copy and paste the URL here. That's the best way to post big files.
Back to top
View user's profile Send private message
godof4dchess
n00b
n00b


Joined: 18 Dec 2016
Posts: 5

PostPosted: Sun Dec 18, 2016 3:00 am    Post subject: Reply with quote

Xorgconfig:https://paste.pound-python.org/show/J0fJgUwx49nug0Glm9DM/
Lspci: https://paste.pound-python.org/show/BtmKIg4GulFA3ZuDAroo
Xorg car log:https://pasted.pound-python.org/show/XvSCthpwV7QKrJeXzurW/


Last edited by godof4dchess on Sun Dec 18, 2016 3:08 am; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6957
Location: Saint Amant, Acadiana

PostPosted: Sun Dec 18, 2016 3:08 am    Post subject: Reply with quote

Xorg starts normally and then seems to be killed instead of shutdown. It looks like Xorg is working but Xfce is not loaded.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
godof4dchess
n00b
n00b


Joined: 18 Dec 2016
Posts: 5

PostPosted: Sun Dec 18, 2016 3:11 am    Post subject: Reply with quote

Jaglover wrote:
Xorg starts normally and then seems to be killed instead of shutdown. It looks like Xorg is working but Xfce is not loaded.


I figured out you can get out of the blank screen with ctrl alt f1, when I do this I get an message saying /etc/X11/xinit/xinitrc line 59 xclock is missing. Would you say everything seems in order for the installation of xfce?
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2873
Location: Illinois, USA

PostPosted: Sun Dec 18, 2016 10:11 pm    Post subject: Reply with quote

You can emerge xclock if you want. IIRC you will see the clock at startx. I would just go ahead and install your DE.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum