Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kde pim [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Sat Dec 17, 2016 2:22 pm    Post subject: Kde pim [SOLVED] Reply with quote

It looks like - at long last - KDE has updated the PIM apps to plasma 5

Nightmare time:

Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-libs/libsrtp-1.4.4_p20121108-r1 USE="-aesicm -console -debug -doc -static-libs -syslog"
[ebuild U ~] dev-libs/xapian-1.4.1 [1.2.22] USE="glass%*"
[ebuild R ~] media-libs/libvpx-1.6.0-r1 USE="svc* -postproc*"
[ebuild N ] media-libs/opus-1.1 USE="-custom-modes -doc -static-libs"
[ebuild U ~] dev-libs/protobuf-3.1.0 [3.0.0_beta3] PYTHON_TARGETS="python3_4*"
[ebuild U ] x11-libs/libXpm-3.5.12 [3.5.11]
[ebuild N ~] kde-apps/kmime-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/kcontacts-16.12.0 USE="-debug {-test}"
[ebuild U ~] kde-apps/kholidays-16.12.0 [16.08.3]
[ebuild N ~] dev-libs/kdiagram-2.6.0 USE="-debug"
[ebuild N ~] dev-qt/qtwebchannel-5.7.1 USE="qml -debug {-test}"
[ebuild U ~] kde-apps/libkexiv2-16.12.0 [16.08.3]
[ebuild N ~] kde-apps/kmbox-16.12.0 USE="-debug {-test}"
[ebuild U ~] dev-db/mariadb-10.1.20 [10.1.19-r1]
[ebuild R ~] dev-qt/qtsql-5.7.1 USE="mysql*"
[ebuild U ~] x11-drivers/xf86-video-intel-2.99.917_p20161206 [2.99.917_p20161118] USE="-dri3*"
[ebuild U ~] app-crypt/gpgme-1.8.0-r1 [1.5.5] USE="cxx%* qt5%* -python%" PYTHON_TARGETS="python2_7%* python3_4%*"
[ebuild U ~] kde-apps/libkipi-16.12.0 [16.08.3-r1]
[ebuild N ~] dev-qt/qtwebengine-5.7.1 USE="system-ffmpeg system-icu widgets -bindist -debug -geolocation -pax_kernel {-test}"
[ebuild U ~] kde-frameworks/kwallet-5.29.0-r1 [5.29.0]
[ebuild NS ~] kde-apps/akonadi-16.12.0 [1.13.1_pre20160203-r1] USE="mysql -debug -designer -postgres -sqlite {-test} -tools -xml"
[ebuild N ~] kde-apps/kpimtextedit-16.12.0 USE="-debug -designer (-speech) {-test}"
[ebuild N ~] kde-apps/kldap-16.12.0 USE="handbook ssl -debug {-test}"
[ebuild N ~] kde-apps/kimap-16.12.0 USE="-debug {-test}"
[ebuild U ~] kde-apps/kcron-16.12.0 [16.08.3]
[ebuild N ~] kde-apps/akonadi-mime-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/kidentitymanagement-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/grantleetheme-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/libkleo-16.12.0 USE="-debug"
[ebuild N ~] kde-apps/kontactinterface-16.12.0 USE="-debug"
[ebuild N ~] kde-apps/akonadi-notes-16.12.0 USE="-debug {-test}"
[ebuild U ~] kde-apps/spectacle-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/ark-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/baloo-widgets-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/kcalc-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/kstars-16.12.0 [16.08.3] USE="-raw%"
[ebuild U ~] kde-apps/konsole-16.12.0 [16.08.3-r1]
[ebuild N ~] kde-apps/akonadi-contacts-16.12.0 USE="-debug -prison {-test}"
[ebuild N ~] kde-apps/kmailtransport-16.12.0 USE="handbook ssl -debug {-test}"
[ebuild NS ~] kde-apps/okular-16.12.0 [16.08.3] USE="crypt handbook jpeg pdf postscript tiff -chm -debug -djvu -ebook -mobi (-speech) {-test}"
[ebuild U ~] kde-apps/kwalletmanager-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/kwrite-16.12.0 [16.08.3]
[ebuild N ~] kde-apps/kcalcore-16.12.0 USE="-debug {-test}"
[ebuild U ~] kde-apps/kio-extras-16.12.0 [16.08.3] USE="-exif* -htmlthumbs% -samba*"
[ebuild NS ~] kde-apps/kfind-16.12.0 [16.08.3] USE="handbook -debug"
[ebuild U ~] kde-apps/gwenview-16.12.0 [16.08.3]
[ebuild N ~] kde-apps/kcalutils-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/akonadi-search-16.12.0 USE="-debug"
[ebuild U ~] kde-apps/khelpcenter-16.12.0 [16.08.3]
[ebuild N ~] kde-apps/kalarmcal-16.12.0 USE="-debug"
[ebuild NS ~] kde-apps/konqueror-16.12.0 [16.08.3] USE="X handbook -activities -debug (-speech) {-test} -tidy"
[ebuild U ~] kde-apps/kmix-16.12.0 [16.08.3] USE="-alsa* -pulseaudio*"
[ebuild U ~] kde-apps/dolphin-16.12.0 [16.08.3] USE="-thumbnail*"
[ebuild N ~] kde-apps/akonadi-calendar-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/libktnef-16.12.0 USE="-debug {-test}"
[ebuild U ~] kde-base/kdelibs-4.14.27 [4.14.26] USE="-spell*"
[ebuild U ~] kde-apps/zeroconf-ioslave-16.12.0 [16.08.3]
[ebuild U ~] kde-apps/kwalletd-16.04.3-r1 [16.04.3]
[ebuild NS ~] kde-apps/kdepim-runtime-16.12.0 [4.14.11_pre20160211] USE="handbook ssl -debug -google {-test}"
[uninstall ] kde-apps/kdepim-runtime-4.14.11_pre20160211
[blocks b ] kde-apps/kdepim-runtime:4 ("kde-apps/kdepim-runtime:4" is blocking kde-apps/kdepim-runtime-16.12.0)
[ebuild NS ~] kde-apps/kdialog-16.12.0 [16.08.3] USE="X -debug"
[uninstall ] kde-apps/kdialog-16.08.3
[blocks b ] kde-apps/kdialog:4 ("kde-apps/kdialog:4" is blocking kde-apps/kdialog-16.12.0)
[ebuild N ~] kde-apps/libkdepim-16.12.0 USE="-debug -designer {-test}"
[ebuild N ~] kde-apps/pimcommon-16.12.0 USE="-debug -designer {-test}"
[ebuild N ~] kde-apps/mailimporter-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/kdepim-apps-libs-16.12.0 USE="-debug -prison {-test}"
[ebuild N ~] kde-apps/libgravatar-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/libksieve-16.12.0 USE="handbook ssl -debug {-test}"
[ebuild N ~] kde-apps/calendarsupport-16.12.0 USE="-debug"
[ebuild N ~] kde-apps/eventviews-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/incidenceeditor-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/messagelib-16.12.0 USE="-debug {-test}"
[ebuild N ~] kde-apps/mailcommon-16.12.0 USE="-debug -designer {-test}"
[ebuild NS ~] kde-apps/kaddressbook-16.12.0 [4.14.11_pre20160211] USE="handbook -debug -prison {-test}"
[uninstall ] kde-apps/kaddressbook-4.14.11_pre20160211
[blocks b ] kde-apps/kaddressbook:4 ("kde-apps/kaddressbook:4" is blocking kde-apps/kaddressbook-16.12.0)
[ebuild NS ~] kde-apps/kmail-16.12.0 [4.14.11_pre20160211] USE="handbook -debug {-test}"
[uninstall ] kde-apps/kdepim-common-libs-4.14.11_pre20160211
[blocks b ] kde-apps/kdepim-common-libs:4 ("kde-apps/kdepim-common-libs:4" is blocking kde-apps/libkdepim-16.12.0, kde-apps/messagelib-16.12.0, kde-apps/kmail-16.12.0)
[uninstall ] kde-apps/kmail-4.14.11_pre20160211
[blocks b ] kde-apps/kmail:4 ("kde-apps/kmail:4" is blocking kde-apps/kmail-16.12.0)
[ebuild NS ~] kde-apps/akonadiconsole-16.12.0 [4.14.11_pre20160211] USE="handbook -debug"
[uninstall ] kde-apps/akonadiconsole-4.14.11_pre20160211
[blocks b ] kde-apps/akonadiconsole:4 ("kde-apps/akonadiconsole:4" is blocking kde-apps/akonadiconsole-16.12.0)
[blocks B ] kde-apps/kfind:4 ("kde-apps/kfind:4" is blocking kde-apps/kfind-16.12.0)
[blocks B ] kde-apps/okular:4 ("kde-apps/okular:4" is blocking kde-apps/okular-16.12.0)
[blocks B ] kde-apps/konqueror:4 ("kde-apps/konqueror:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/konq-plugins ("kde-apps/konq-plugins" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-16.12.0)
[blocks B ] kde-apps/kfmclient:4 ("kde-apps/kfmclient:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/akonadi-mime-16.12.0, kde-apps/kmailtransport-16.12.0, app-crypt/gpgme-1.8.0-r1)
[blocks B ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-16.12.0)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

kde-apps/libkipi:5

(kde-apps/libkipi-16.12.0:5/32::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(kde-apps/libkipi-16.08.3-r1:5/31::gentoo, installed) pulled in by
>=kde-apps/libkipi-14.12.0:5/31= required by (media-plugins/kipi-plugins-5.3.0:5/5::gentoo, installed)
^^^^^^


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed) pulled in by
>=kde-apps/kdepimlibs-4.4:4[aqua=] (>=kde-apps/kdepimlibs-4.4:4[-aqua]) required by (kde-misc/basket-1.81:4/4::gentoo, installed)
>=kde-apps/kdepimlibs-4.14.3:4[aqua=] (>=kde-apps/kdepimlibs-4.14.3:4[-aqua]) required by (kde-apps/drkonqi-16.04.3:4/16.04::gentoo, installed)

(kde-apps/okular-16.08.3:4/16.08::gentoo, installed) pulled in by
>=kde-apps/okular-4.4:4[aqua=,pdf?,postscript] (>=kde-apps/okular-4.4:4[-aqua,pdf,postscript]) required by (app-editors/kile-2.1.3-r2:4/4::gentoo, installed)

(app-crypt/gpgme-1.8.0-r1:1/11::gentoo, ebuild scheduled for merge) pulled in by
>=app-crypt/gpgme-1.7.1[cxx,qt5] required by (kde-apps/kaddressbook-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=app-crypt/gpgme-1.7.1[cxx,qt5] required by (kde-apps/kmail-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=app-crypt/gpgme-1.0 required by (kde-misc/basket-1.81:4/4::gentoo, installed)
>=app-crypt/gpgme-1.7.1[cxx,qt5] required by (kde-apps/libkleo-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=app-crypt/gpgme-1.7.1[cxx,qt5] required by (kde-apps/messagelib-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=app-crypt/gpgme-1.1.6 required by (kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed)

(kde-apps/akonadi-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadi-notes-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kaddressbook-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadi-search-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/libksieve-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/libkdepim-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kdepim-apps-libs-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadi-contacts-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/eventviews-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kalarmcal-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadiconsole-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/mailcommon-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/pimcommon-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kdepim-runtime-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/incidenceeditor-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadi-calendar-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/messagelib-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kmail-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/calendarsupport-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/mailimporter-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/kmailtransport-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-16.12.0:5 required by (kde-apps/akonadi-mime-16.12.0:5/5::gentoo, ebuild scheduled for merge)

(kde-apps/kfmclient-16.08.3:4/16.08::gentoo, installed) pulled in by
>=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-apps/konqueror-16.08.3:4/16.08::gentoo, installed)
>=kde-apps/kfmclient-4.14.3:4[aqua=] (>=kde-apps/kfmclient-4.14.3:4[-aqua]) required by (kde-base/kdelibs-4.14.27:4/4.14::gentoo, ebuild scheduled for merge)

(kde-apps/konqueror-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
kde-apps/konqueror required by @selected

(kde-apps/konq-plugins-16.08.3:4/16.08::gentoo, installed) pulled in by
kde-apps/konq-plugins required by @selected

(kde-apps/akonadi-mime-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/pimcommon-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/akonadi-search-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/kmail-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/calendarsupport-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/kdepim-runtime-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/messagelib-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/mailimporter-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/akonadi-calendar-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/mailcommon-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/akonadi-contacts-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/incidenceeditor-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/akonadi-mime-16.12.0:5 required by (kde-apps/kmailtransport-16.12.0:5/5::gentoo, ebuild scheduled for merge)

(kde-apps/okular-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
kde-apps/okular required by @selected

(kde-apps/kmailtransport-16.12.0:5/5::gentoo, ebuild scheduled for merge) pulled in by
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/akonadi-calendar-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/kdepim-runtime-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/mailcommon-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/kmail-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/incidenceeditor-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/messagelib-16.12.0:5/5::gentoo, ebuild scheduled for merge)
>=kde-apps/kmailtransport-16.12.0:5 required by (kde-apps/libksieve-16.12.0:5/5::gentoo, ebuild scheduled for merge)


Don't even know where to begin ... :(
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)


Last edited by albright on Sun Dec 18, 2016 6:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
jam666
n00b
n00b


Joined: 19 Apr 2012
Posts: 5
Location: Belarus

PostPosted: Sat Dec 17, 2016 3:20 pm    Post subject: Reply with quote

Same story here...

Too lazy to solve it all by myself in manual mode. Let's wait for some good advice from gentoo gurus :)
Back to top
View user's profile Send private message
marax_faraii
n00b
n00b


Joined: 11 Apr 2016
Posts: 40

PostPosted: Sat Dec 17, 2016 3:22 pm    Post subject: Reply with quote

I just went through this myself and I finally got all working. Honestly I can't remember all the steps I took but I'll try to help out how I did it.
Obviously I have my history output if you want ;)

Also follow this guide
https://docs.kde.org/stable5/en/pim/kmail/clean-start-after-a-failed-migration.html


I removed all things related to akonadi and kdepim. I use kmail and I ended up with these keywords
Once done, reinstall kde-apps/kdepim-runtime

kde-apps/kmail ~amd64
kde-apps/kontactinterface ~amd64
kde-apps/akonadi-mime ~amd64
dev-libs/xapian ~amd64
app-crypt/gpgme ~amd64
kde-apps/mailimporter ~amd64
dev-libs/kdiagram ~amd64
kde-apps/kcontacts ~amd64
kde-apps/kmime ~amd64

kde-apps/kidentitymanagement ~amd64
kde-apps/libkdepim ~amd64
kde-apps/akonadi-calendar ~amd64
kde-apps/pimcommon ~amd64
kde-apps/akonadi-search ~amd64
kde-apps/kdepim-apps-libs ~amd64
kde-apps/kmail-account-wizard ~amd64
kde-apps/akonadi-import-wizard ~amd64
kde-apps/akonadiconsole ~amd64
kde-apps/kdepim-runtime ~amd64
kde-apps/calendarsupport ~amd64
kde-apps/kpimtextedit ~amd64
kde-apps/akonadi-notes ~amd64
kde-apps/libktnef ~amd64
kde-apps/libkleo ~amd64
kde-apps/mailcommon ~amd64
kde-apps/kcalcore ~amd64
kde-apps/akonadi ~amd64
kde-apps/libgravatar ~amd64
kde-apps/kldap ~amd64
kde-apps/akonadi-contacts ~amd64
kde-apps/libksieve ~amd64
kde-apps/messagelib ~amd64
kde-apps/grantleetheme ~amd64
kde-apps/incidenceeditor ~amd64
kde-apps/eventviews ~amd64
kde-apps/kimap ~amd64
kde-apps/kcalutils ~amd64
kde-apps/kmailtransport ~amd64
kde-apps/kmbox ~amd64
kde-apps/kalarmcal ~amd64
kde-apps/kdepim-runtime ~amd64
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Dec 17, 2016 6:54 pm    Post subject: Re: Kde pim Reply with quote

albright wrote:
[blocks B ] kde-apps/kfind:4 ("kde-apps/kfind:4" is blocking kde-apps/kfind-16.12.0)
[blocks B ] kde-apps/okular:4 ("kde-apps/okular:4" is blocking kde-apps/okular-16.12.0)
[blocks B ] kde-apps/konqueror:4 ("kde-apps/konqueror:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/konq-plugins ("kde-apps/konq-plugins" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/akonadi:4 ("kde-apps/akonadi:4" is blocking kde-apps/akonadi-16.12.0)
[blocks B ] kde-apps/kfmclient:4 ("kde-apps/kfmclient:4" is blocking kde-apps/konqueror-16.12.0)
[blocks B ] kde-apps/kdepimlibs:4 ("kde-apps/kdepimlibs:4" is blocking kde-apps/akonadi-mime-16.12.0, kde-apps/kmailtransport-16.12.0, app-crypt/gpgme-1.8.0-r1)
[blocks B ] kde-apps/kdepimlibs ("kde-apps/kdepimlibs" is blocking kde-apps/akonadi-16.12.0)

Clean up your world file from slot 4 entries (why are they there?).

albright wrote:
(kde-apps/kdepimlibs-4.14.11_pre20160211-r2:4/4.14::gentoo, installed) pulled in by
>=kde-apps/kdepimlibs-4.4:4[aqua=] (>=kde-apps/kdepimlibs-4.4:4[-aqua]) required by (kde-misc/basket-1.81:4/4::gentoo, installed)

Remove basket.
albright wrote:
>=kde-apps/kdepimlibs-4.14.3:4[aqua=] (>=kde-apps/kdepimlibs-4.14.3:4[-aqua]) required by (kde-apps/drkonqi-16.04.3:4/16.04::gentoo, installed)

Remove drkonqi (why is it even there?).

albright wrote:
(kde-apps/okular-16.08.3:4/16.08::gentoo, installed) pulled in by
>=kde-apps/okular-4.4:4[aqua=,pdf?,postscript] (>=kde-apps/okular-4.4:4[-aqua,pdf,postscript]) required by (app-editors/kile-2.1.3-r2:4/4::gentoo, installed)

Remove kile:4 (unrelated to PIM).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Sat Dec 17, 2016 10:20 pm    Post subject: Reply with quote

Quote:
Clean up your world file from slot 4 entries (why are they there?).


good point (old computer);

can *all* kde slot 4 apps now be removed safely?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sat Dec 17, 2016 10:21 pm    Post subject: Reply with quote

That was not my question, why do you have slot deps in your world file? ;) That's what is keeping e.g. kfind:4 from upgrading to kfind:5.

If you depend on kile, hopefully it gets a kf5-based release soon.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Sun Dec 18, 2016 4:03 pm    Post subject: Reply with quote

OK - the world file contained only two slot 4

Quote:
dev-qt/qttranslations:4
dev-qt/qtwebkit:4


removing them (and a few other packages, e.g. kile ...) got
the system to begin its giant emerge / reemerge job

right now on 46 of 103 packages

thanks for the help
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Dec 18, 2016 4:27 pm    Post subject: Reply with quote

Great ;)

Coming back to your slot 4 question, the latest KDE Applications release still contains plenty slot 4 deps. I'd say in 16.12.0 it is perfectly possible to get by without them, but you can't use the meta packages (at least not those that have slot 4 deps left).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Sun Dec 18, 2016 4:35 pm    Post subject: Reply with quote

Quote:
Coming back to your slot 4 question,


for what it is worth, you can install kile but it force the kde-4 version
of okular to replace the -5 version and then the system will
complain that it wants to upgrade okular

I need kile a bit and there seems to be no sign of an updated
version in the works :cry:
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 276

PostPosted: Sun Dec 18, 2016 4:46 pm    Post subject: Reply with quote

Concerning kile, I had run into the same problem. As I use kile on a daily basis, I came up with the following solution. I created my own new version of kile in a local overlay where I just commented out the part of the ebuild that refers to okular. Doing so, kile compiled without any problem and when started it also works flawlessly. Perhaps this is not that surprising because okular is only used as an external programm to view your pdf files, so if it is okular 4 or 5 does not really matter to kile.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Sun Dec 18, 2016 5:34 pm    Post subject: Reply with quote

albright wrote:
I need kile a bit and there seems to be no sign of an updated
version in the works :cry:

Well, it was assumed to be pretty much done and only waiting for okular:5 release. So it should be there soon, if not, maybe we'll get a snapshot.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2539
Location: Near Toronto

PostPosted: Sun Dec 18, 2016 6:40 pm    Post subject: Reply with quote

Quote:
I created my own new version of kile in a local overlay


that's clever idea - works for me too
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1170
Location: Stuttgart, Germany

PostPosted: Sat Dec 24, 2016 11:56 am    Post subject: Reply with quote

asturm wrote:
Coming back to your slot 4 question, the latest KDE Applications release still contains plenty slot 4 deps. .


Coming back to this: I've found that trying to use Dolphin:5 outside of KDE's DE ends up being severely sub-functional (services don't exist, the UI is much slower, icons are missing, the right-click menu is missing lots of options, etc. etc.). So I have Dolphin hard-masked to force it to stay on :4. However, now I have package blockage between kdepimlibs:4 and akonadi (which appears to be moving to :5 with the -16 versions).

So what's my option here? Is Dolphin any better lately? Is there another file-manager that works cleanly and robustly? This is the one thing from KDE that I've found really valuable (mostly because encrypting/compressing files can be reached from the right-click menu). If I had an alternative file-manager, I could just get rid of it.

Any advice?

Cheers,

EE
UPDATE: Spacefm seems to have all these qualities, so I guess I can ditch dolphin:4 altogether. So long, sucker!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum