Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problème de mise à jour du world
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Fri Dec 16, 2016 7:59 pm    Post subject: Reply with quote

k-root wrote:
Quote:

[blocks b ] <net-dialup/ppp-2.4.7-r1 ("<net-dialup/ppp-2.4.7-r1" is blocking net-dialup/ppp-scripts-0)
[blocks b ] net-dialup/ppp-scripts ("net-dialup/ppp-scripts" is blocking net-dialup/ppp-2.4.7)

....

media-gfx/imagemagick:0

(media-gfx/imagemagick-6.9.6.6:0/6.9.6.6::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(media-gfx/imagemagick-6.9.6.2:0/6.9.6.2::gentoo, installed) pulled in by
media-gfx/imagemagick:0/6.9.6.2= required by (media-gfx/uniconvertor-2.0_pre379-r1:0/0::gentoo, installed)
^^^^^^^^^^^
(and 1 more with the same problem)

..

[blocks B ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is blocking sys-libs/ncurses-5.9-r101)

Total: 71 packages (54 upgrades, 1 downgrade, 4 new, 2 in new slots, 10 reinstalls), Size of downloads: 1,100,030 KiB
Conflict: 3 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

(dev-libs/icu-58.1-r1:0/58.1::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/icu:0/58.1 required by (app-office/libreoffice-bin-5.2.3.3:0/0::gentoo, ebuild scheduled for merge)
^^^^^^^

(dev-libs/icu-57.1:0/57::gentoo, installed) pulled in by
dev-libs/icu:0/57= required by (media-libs/libvisio-0.1.5:0/0::gentoo, installed)
^^^^^^
(and 15 more with the same problem)


ahum .. tu n'as pas aussi ajouté media-gfx/imagemagick dans ton world par hasard ?

là, la seul solution que je vois ici c'est de passer par un emerge -C ... cf previous message.



Pour imagemagick :

Code:
→ equery s imagemagick
 * media-gfx/imagemagick-6.9.6.2
         Total files : 1497
         Total size  : 19.17 MiB


Code:

→ equery d imagemagick-6.9.6.6
 * These packages depend on imagemagick-6.9.6.6:
app-editors/emacs-24.5-r3 (imagemagick ? >=media-gfx/imagemagick-6.6.2)
app-text/asciidoc-8.6.9-r2 (test ? media-gfx/imagemagick)
media-gfx/inkscape-0.91-r3 (imagemagick ? media-gfx/imagemagick[cxx])
media-gfx/pstoedit-3.62 (imagemagick ? >=media-gfx/imagemagick-6.6.1.2[cxx])
media-gfx/uniconvertor-2.0_pre379-r1 (media-gfx/imagemagick)


et je l'inclus dans la compilation de certains programmes : http://pastebin.com/zt1JL1Gb (package.use)
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sat Dec 17, 2016 1:11 am    Post subject: Reply with quote

Tu peux essayer un
Code:
emerge -1 inkscape

Si ça ne veut pas compiler alors
Code:
emerge -C imagemagick

puis refaire
Code:
emerge -1 inkscape

Si ça ne veut toujours pas, faire
Code:
emerge -C uniconvertor

et re
Code:
emerge -1 inkscape

Si ça ne veut toujours pas donne nous le pastebin de emerge -1 inkscape
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Sat Dec 17, 2016 2:21 pm    Post subject: Reply with quote

Biloute wrote:
Tu peux essayer un
Code:
emerge -1 inkscape

Si ça ne veut pas compiler alors
Code:
emerge -C imagemagick

puis refaire
Code:
emerge -1 inkscape

Si ça ne veut toujours pas, faire
Code:
emerge -C uniconvertor

et re
Code:
emerge -1 inkscape

Si ça ne veut toujours pas donne nous le pastebin de emerge -1 inkscape


Salut,

La premère commande s'est correctement exécutée
Mais voici les logs de l'emerge world que j'ai essayé juste après : http://pastebin.com/kDnHU9zZ
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sat Dec 17, 2016 7:10 pm    Post subject: Reply with quote

Maintenant tu peux essayer
Code:
emerge -1 imagemagick

Si ça ne veut pas compiler
Faire
Code:
emerge -C uniconvertor

Puis re
Code:
emerge -1 imagemagick

Faut voir si il y a aussi pstoedit qui pose problème.

Ensuite pour retourner sur le problème de ncurses, tu peux commencer à faire
Code:
emerge -1 vim

Code:
emerge -1 pinentry


Enfin en dernier recours, tu peux faire la mise à jour des ebuild un par un
Code:
emerge -1 xdelta

Code:
emerge -1 chrome-binary-plugins

...
Jusqu'à ce que tu trouve le coupable.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Sun Dec 18, 2016 10:25 am    Post subject: Reply with quote

Biloute wrote:
Maintenant tu peux essayer
Code:
emerge -1 imagemagick

Si ça ne veut pas compiler
Faire
Code:
emerge -C uniconvertor

Puis re
Code:
emerge -1 imagemagick

Faut voir si il y a aussi pstoedit qui pose problème.

Ensuite pour retourner sur le problème de ncurses, tu peux commencer à faire
Code:
emerge -1 vim

Code:
emerge -1 pinentry


Enfin en dernier recours, tu peux faire la mise à jour des ebuild un par un
Code:
emerge -1 xdelta

Code:
emerge -1 chrome-binary-plugins

...
Jusqu'à ce que tu trouve le coupable.


Salut,

Toujours cette ********* de conflit... Du coup, si je t'ai bien compris, je dois tester l'installation
de tous les packages liés aux conflits (http://pastebin.com/HfYcRdr9) jusqu'à ce que je trouve celui-ci qui fait tout bugger ?
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sun Dec 18, 2016 12:05 pm    Post subject: Reply with quote

Tu ne vas pas tester mais bel et bien installer chacun de tes ebuild qui ont besoin d'être mis à jour avec emerge -1 xdelta puis emerge -1 (ebuild suivant). Je vois qu'il y a environs 70 a faire c'est plutôt fastidieux.

Lorque tu en auras un qui pose un soucis, il faudra le masquer.

J'ai regardé ton dernier pastebin c'est bien la réponse d'un emerge -1 imagemagick? Parce que si c'est le cas tu peux déjà commencer par masquer imagemagick-6.9.6.6

Tiens par exemple si tu fais
Code:
emerge -1 ppp

Ca va certainement bloquer alors il faudra masquer net-dialup/ppp-2.4.7-r3 en tapant "=net-dialup/ppp-2.4.7-r3" dans /etc/portage/package.mask
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Sun Dec 18, 2016 1:36 pm    Post subject: Reply with quote

Biloute wrote:

J'ai regardé ton dernier pastebin c'est bien la réponse d'un emerge -1 imagemagick?


Non, c'était un emerge world :) Le imagemagick marche bien.
Back to top
View user's profile Send private message
k-root
Guru
Guru


Joined: 08 Jan 2005
Posts: 427

PostPosted: Sun Dec 18, 2016 5:22 pm    Post subject: Reply with quote

periappi wrote:
Biloute wrote:

J'ai regardé ton dernier pastebin c'est bien la réponse d'un emerge -1 imagemagick?


Non, c'était un emerge world :) Le imagemagick marche bien.


ok, peux tu faire un : emerge -uva @system

puis un : emerge -uva @world
_________________
boozo wrote:
Gentoo, ça mange des ours et baffe des buffles par 37°C avec un bob et des tongs
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Mon Dec 19, 2016 12:39 am    Post subject: Reply with quote

k-root wrote:
periappi wrote:
Biloute wrote:

J'ai regardé ton dernier pastebin c'est bien la réponse d'un emerge -1 imagemagick?


Non, c'était un emerge world :) Le imagemagick marche bien.


ok, peux tu faire un : emerge -uva @system

puis un : emerge -uva @world


Bon, du coup je me suis tapé les 70 packets à la main (le coupable : util-linux avec Ruby(http://pastebin.com/GTqmRQfH)), ça avait l'air d'avoir réglé le problème de ncurses et maintenant c'est icu...
Le emerge system a bien fonctionné, mais il a fait revenir un problème de dépendance avec ncurses.
J'ai essayé de mask libreoffice avec :

Code:
=app-office/libreoffice-bin-5.2.3.3


mais ça ne semble pas marcher....
Une idée ? http://pastebin.com/81eyJ4tU

NB : C'est quand même énorme que j'ai tous ces problèmes de dépendance d'une semaine sur l'autre... comme c'est possible ?
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Mon Dec 19, 2016 2:32 am    Post subject: Reply with quote

periappi wrote:
Bon, du coup je me suis tapé les 70 packets à la main (le coupable : util-linux avec Ruby(http://pastebin.com/GTqmRQfH))

J'ai envie de te demander de vérifier s'il n'y a pas sys-apps/util-linux:0 et sys-apps/util-linux dans ton world
Ca donne quoi ton
Code:
cat /var/lib/portage/world | grep sys-apps/util-linux

periappi wrote:
Le emerge system a bien fonctionné, mais il a fait revenir un problème de dépendance avec ncurses.
J'ai essayé de mask libreoffice avec :
Code:
=app-office/libreoffice-bin-5.2.3.3

mais ça ne semble pas marcher....
Une idée ? http://pastebin.com/81eyJ4tU

C'est bien le caractère de gentoo avec portage tu ne peux pas toujours balancer un emerge world tranquille.
Là je trouve que tu devrais commencer par t'occuper de la MAJ de perl
Code:
emerge -av1 perl-cleaner
emerge -av1O dev-lang/perl
perl-cleaner --all

Ensuite tu pourrais passer au atom qui provoque beaucoup de rebuild
Code:
emerge -1 x264
emerge -1 =dev-libs/icu-58.1-r1
...

Je vois ta MAJ de Adobe-flash, je l'ai fait cette après midi et ça m'a sortie une conner#'^ de blocage entre www-plugins/adobe-flash et www-plugins/adobe-flash:0
C'était une grosse merd#~ réglée avec un emerge --deselect www-plugins/adobe-flash:0
En plus ils sont bien gentils de nous mettre flash24 mais mon firefox 46 reste bloqué sur flash11



NB : Ok donc la semaine dernière tu avais un total : 71 packages
maintenant c'est total : 143 packages
La semaines prochaines c'est combien? 210? 280?? :D :lol: :) :wink:
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Mon Dec 19, 2016 5:47 pm    Post subject: Reply with quote

Biloute wrote:

J'ai envie de te demander de vérifier s'il n'y a pas sys-apps/util-linux:0 et sys-apps/util-linux dans ton world
Ca donne quoi ton
Code:
cat /var/lib/portage/world | grep sys-apps/util-linux



Je n'obtiens rien.


Biloute wrote:

C'est bien le caractère de gentoo avec portage tu ne peux pas toujours balancer un emerge world tranquille.
Là je trouve que tu devrais commencer par t'occuper de la MAJ de perl
Code:
emerge -av1 perl-cleaner
emerge -av1O dev-lang/perl
perl-cleaner --all



Là il n'y a eu aucun problème ! (heureusement, vue le nombre d'install' que ça m'a fait ^^)

Biloute wrote:

Ensuite tu pourrais passer au atom qui provoque beaucoup de rebuild
Code:
emerge -1 x264
emerge -1 =dev-libs/icu-58.1-r1
...



Aucun des deux n'a fonctionné... j'ai tenté le emerge world : http://pastebin.com/f25H4882
Il faudrait faire un mask général ? (je vais finir pas avoir une install' cassée à la fin :P ?)


Biloute wrote:

Je vois ta MAJ de Adobe-flash, je l'ai fait cette après midi et ça m'a sortie une conner#'^ de blocage entre www-plugins/adobe-flash et www-plugins/adobe-flash:0
C'était une grosse merd#~ réglée avec un emerge --deselect www-plugins/adobe-flash:0
En plus ils sont bien gentils de nous mettre flash24 mais mon firefox 46 reste bloqué sur flash11


XD, l'installation faite par acquis de conscience :)


Biloute wrote:

NB : Ok donc la semaine dernière tu avais un total : 71 packages
maintenant c'est total : 143 packages
La semaines prochaines c'est combien? 210? 280?? :D :lol: :) :wink:


Je m'accroche !!!
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Mon Dec 19, 2016 6:48 pm    Post subject: Reply with quote

periappi wrote:

Ensuite tu pourrais passer au atom qui provoque beaucoup de rebuild
Code:
emerge -1 x264
emerge -1 =dev-libs/icu-58.1-r1
...

Aucun des deux n'a fonctionné...

Tu peux donner les pastebin de x264, icu?

J'ai regardé ton package.use, tu devrais supprimer les lignes qui ont été généré par portage.
Et faire aussi un peu de nettoyage (par exemple media-video/mpvr n'existe pas)
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Mon Dec 19, 2016 7:15 pm    Post subject: Reply with quote

Biloute wrote:

Tu peux donner les pastebin de x264, icu?


Pour x264 : http://pastebin.com/MzM7kNCC
Pour icu : http://pastebin.com/KjF2uPZG

Biloute wrote:

J'ai regardé ton package.use, tu devrais supprimer les lignes qui ont été généré par portage.
Et faire aussi un peu de nettoyage (par exemple media-video/mpvr n'existe pas)


Fait ! (http://pastebin.com/kubGs5tG)
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Mon Dec 19, 2016 9:49 pm    Post subject: Reply with quote

periappi wrote:
Pour x264 : http://pastebin.com/MzM7kNCC

Tu peux savoir avec
Code:
equery u x264

la liste des atoms à reinstaller. Donc tu dois désinstaller puis réinstaller ces atoms (Je suppose qu'il y a déjà ffmpeg, vlc il te faudra ajouter le reste)
Code:
emerge -C x264 ffmpeg vlc (et le reste)

Je suppose que vlc est dans ton world donc
Code:
emerge vlc (ajoute le reste qui est dans ton world)
emerge -1 x264 ffmpeg (ajoute le reste)


Sinon tu as le choix de faire l'impasse de mettre à jour x264 en masquant la version media-libs/x264-0.0.20160712
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Tue Dec 20, 2016 11:16 am    Post subject: Reply with quote

Biloute wrote:
periappi wrote:
Pour x264 : http://pastebin.com/MzM7kNCC

Tu peux savoir avec
Code:
equery u x264

la liste des atoms à reinstaller. Donc tu dois désinstaller puis réinstaller ces atoms (Je suppose qu'il y a déjà ffmpeg, vlc il te faudra ajouter le reste)


Aïe, la commande ne semble pas m'indiquer quoi réinstaller :

Code:

atlas ~ # equery u x264
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for media-libs/x264-0.0.20160712:
 U I
 - - 10bit             : Set output bit depth to 10, this may not be compatible
                         with all decoders
 - - abi_x86_32        : 32-bit (x86) libraries
 + + cpu_flags_x86_sse : Use the SSE instruction set
 + - interlaced        : enable interlaced encoding support, this can decrease
                         encoding speed by up to 2%
 - - opencl            : Add support for OpenCL.
 - - pic               : disable optimized assembly code that is not PIC
                         friendly
 - - static-libs       : Build static versions of dynamic libraries as well
 + - threads           : Add threads support for various packages. Usually
                         pthreads
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Tue Dec 20, 2016 6:33 pm    Post subject: Reply with quote

Code:
equery h x264

_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Tue Dec 20, 2016 7:36 pm    Post subject: Reply with quote

Biloute wrote:
Code:
equery h x264


Super, j'ai fais tout ce que tu m'as dis, il semblerait que x264 ne soit plus un problème : http://pastebin.com/tyJUwz3w
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Wed Dec 21, 2016 3:23 am    Post subject: Reply with quote

Tu as mis à jour ou tu as masqué?

Que donne
Code:
emerge -DuNav --exclude "ncurses icu" @world

?
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Wed Dec 21, 2016 10:01 pm    Post subject: Reply with quote

Biloute wrote:
Tu as mis à jour ou tu as masqué?

Que donne
Code:
emerge -DuNav --exclude "ncurses icu" @world

?


Salut, j'ai peu mettre beaucoup de packages à jour ; malheureusement impossible
de faire un beau depclean à la fin : http://pastebin.com/jepxuKQJ
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Thu Dec 22, 2016 8:29 am    Post subject: Reply with quote

Hello,

As-tu des paquets en ~amd64 ou es-tu en "full stable" ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Thu Dec 22, 2016 1:32 pm    Post subject: Reply with quote

xaviermiller wrote:
Hello,

As-tu des paquets en ~amd64 ou es-tu en "full stable" ?


Salut,

Tu parles du genre de stage3 que j'ai pris (si c'est le cas amd64) ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Thu Dec 22, 2016 2:03 pm    Post subject: Reply with quote

Non, si tu as ajouté des keywords "~amd64" sur certains packages.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Thu Dec 22, 2016 2:30 pm    Post subject: Reply with quote

xaviermiller wrote:
Non, si tu as ajouté des keywords "~amd64" sur certains packages.


Non, jamais. (du moins de souvenir)
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Thu Dec 22, 2016 9:11 pm    Post subject: Reply with quote

Tu peux retirer les versions de ncurses qui sont masqué parce que c'est pas ça le problème et tenter un
Code:
 emerge --update --newuse --deep --with-bdeps=y --backtrack=30 @world


Mais je vois que ton dernier pastebin ne concerne que des recompilations parce que tu as AB_X86=x32
Quelle est la raison. Tu ne peux pas rester en multilib?
_________________
Gentoo rocks
Back to top
View user's profile Send private message
periappi
n00b
n00b


Joined: 12 Dec 2016
Posts: 42

PostPosted: Fri Dec 23, 2016 11:44 am    Post subject: Reply with quote

Biloute wrote:
Mais je vois que ton dernier pastebin ne concerne que des recompilations parce que tu as AB_X86=x32
Quelle est la raison. Tu ne peux pas rester en multilib?


Je ne sais pas ce que ça fait là, je ne saurais l'expliquer...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum