Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Nieaktualny ifplugd?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
robertsurma
n00b
n00b


Joined: 17 Jan 2008
Posts: 47
Location: Tychy

PostPosted: Mon Dec 12, 2016 10:02 am    Post subject: [SOLVED] Nieaktualny ifplugd? Reply with quote

Mam takie proste marzenie ;-)
Aby wifi włączane było, gdy wtyczka eth jest odpięta... a gdy ją włożę, aby uruchamiany był interface eth a zamykany interface wlp3s0.

Myślałem, że problem rozwiąże instalacja ifplugd... ale on nie robi tego, co powinien robić.

Zajrzałem do skryptu /etc/ifplugd/ifplugd.action, a tam są np. odwołania do initng, ngc... które już dawno w portage nie istnieją.

Wnioskuję więc, że sam ifplugd jest już dawno nieaktualną starocią.

Co robić? Jak żyć?

Czy jest jakiś zamiennik?

Może zrobić to w skryptach ACPI?
Ale jak wykrywany będzie event podpięcia i wypięcia wtyczki eth?
_________________
Free as a bird...


Last edited by robertsurma on Tue Dec 27, 2016 4:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 532

PostPosted: Tue Dec 13, 2016 12:27 am    Post subject: Reply with quote

Quote:
Myślałem, że problem rozwiąże instalacja ifplugd... ale on nie robi tego, co powinien robić.


Nie robi, co powinien?

Tutaj jak widać robił:
https://forums.gentoo.org/viewtopic-p-7385212.html

Pozdro
8)
Back to top
View user's profile Send private message
robertsurma
n00b
n00b


Joined: 17 Jan 2008
Posts: 47
Location: Tychy

PostPosted: Sat Dec 17, 2016 4:53 pm    Post subject: Reply with quote

Przypomniał mi się kawał, który zapewne znacie:

Informatyk do lekarza:
- Panie doktorze, wątroba chyba mi siadła...
- Dziwne, u mnie działa.

------

Niestety, ifplug nie działa u mnie (gdyż jak powyżej napisałem), składniki do których odwołuje się, nie są już dostępne w portage. Więc jak ktoś ma jeszcze system zbudowany dwa lata temu - to być może ma to jeszcze... i działa.

Alternatywa, netplug, także nie działa (tutaj nie wgłębiałem się w kod).

Postanowiłem rozwiązać sprawę za pomocą regułek udev, ale... prawdopodobnie brakuje mi jakiś modułów jądra.

Regułki są dobrze napisane. Dowodem na to jest, że:

# udevadm trigger

odpala regułki i robią one to, co mają robić.

Ale już udev:
# udevadm monitor

nie rejestruje wpinania i wypinania wtyczki eth, choć bez problemu wykrywa akcje związane z usb, drukarkami itp.

Cały problem obecnie sprowadza się więc do modułów / składników jądra, które obsługują netplugging.

# dmesg
r8169 0000:02:00.0 enp2s0: link down
r8169 0000:02:00.0 enp2s0: link up

(wykrywa... ale widocznie udev korzysta z czegoś innego).
_________________
Free as a bird...
Back to top
View user's profile Send private message
Jacekalex
Guru
Guru


Joined: 17 Sep 2009
Posts: 532

PostPosted: Sun Dec 25, 2016 4:25 pm    Post subject: Reply with quote

Jeżeli udev nie pokazuje opdpięcia kabla sieciowego, to albo jakiś bląd sterownika, albo błąd w udevie.

W ogóle to jaką masz wersję udeva?

Pytam, bo u mnie kilka kolejnych wersji eudev zamraża system przy pierwszym wczytywaniu regułek.

Żeby tego uniknąć, musiałem udevadm trigger ustawić dopiero w skrypcie w /etc/local.d/, dlatego teraz się wiesza tylko raz na kilkanaście uruchomień, wczytanie ich w runlevelu boot, sysinit czy default ( wczensiej, niż local.d) powodowało zamrażanie nawet 70 % uruchomień.

Pozdro
8)
Back to top
View user's profile Send private message
robertsurma
n00b
n00b


Joined: 17 Jan 2008
Posts: 47
Location: Tychy

PostPosted: Tue Dec 27, 2016 4:15 pm    Post subject: Reply with quote

Udało mi się w końcu osiągnąć cel za pomocą netplug.
Uaktywniłem w jądrze większość opcji odpowiedzialnych za NETLINK oraz wyrzuciłem uevent_helper, czyli to:
Code:
Device Drivers →
   [*] Generic Drivers Option →
        [ ] Support for uevent helper (/sbin/hotplug)

bo prawdopodobnie konfliktuje z NETLINK.

Dodałem także trochę własnego kodu do skryptu /etc/netplug.d/netplug, aby po włożeniu wtyczki eth wyłączał interface wi-fi programowo i sprzętowo (oszczędność energii).

=========

Co do udev, też mam wrażenie, że błąd tkwi w funkcji udev. Zakładam w tym celu osobny wątek.
_________________
Free as a bird...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum