Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia driver question - need to edit XF86Config ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
avatar
n00b
n00b


Joined: 23 Jul 2002
Posts: 44
Location: London, United Kingdom

PostPosted: Fri Aug 02, 2002 11:44 pm    Post subject: nvidia driver question - need to edit XF86Config ? Reply with quote

I've installed nvidia drivers from portage. I get the splash screen just before fluxbox and it works fine. Now, how do I put on the nice effects like put a shadow around the mouse etc? I looked in XF86Config and see that it was not updated.

The reason I'm asking this question is that I've installed the nvidia drivers directly from the nvidia site when I was using Slackware, and looked into the XF86Config, and a whole bunch of extra options were added there.
Back to top
View user's profile Send private message
maystorm
Apprentice
Apprentice


Joined: 02 Jun 2002
Posts: 212
Location: Germany, not far away

PostPosted: Sat Aug 03, 2002 1:14 am    Post subject: Reply with quote

You'll need to edit your XF86Config file manually. Please note that you can find a sample config file here after having emerged the nvidia drivers: /usr/doc/nvidia-glx-xxxxx/XF86Config.sample.gz

I've tweaked my XF86Config in the meantime to contain following additional lines (to disable the splash screen and get mouse shadow):

Code:
Section "Device"
  Identifier  "GeForce"
  Driver      "nvidia"

[...snip...]

  Option "NoLogo" "1"                       # Turn off logo display
  Option "CursorShadow" "true"              # Shadowed mouse cursor
  Option "CursorShadowAlpha" "60"
  Option "CursorShadowXOffset" "2"
  Option "CursorShadowYOffset" "2"

[...snip...]

EndSection

_________________
Linux user #216018
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Aug 03, 2002 8:55 am    Post subject: Does X takes a long time to load? Reply with quote

I recently bought a GeForce 4 mx 440 based video card
(upgraded from GF2MX) and X takes forever to load after installing Nvidia drivers I wanted to ask if you had similar problems (if it's a problem at all)
Back to top
maystorm
Apprentice
Apprentice


Joined: 02 Jun 2002
Posts: 212
Location: Germany, not far away

PostPosted: Sat Aug 03, 2002 10:06 am    Post subject: Reply with quote

Was the loading time faster before you upgraded to your GF4 card?

I remember having seen some threads in these forums dealing with slowly starting X servers, perhaps you can try a search https://forums.gentoo.org/search.php.

My X starts with what I would call normal speed, however, I've not got a GF4 but a GF2 card.
_________________
Linux user #216018
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Aug 03, 2002 10:41 am    Post subject: Yes it was Reply with quote

With GF2 X used to load in 1-2 seconds. now it takes almost half a minute
to load. (same with win98 actually) when I use the non-accelerated nv driver it loads quickly but the pointer is invisible. I also tried to use XDirectFB but
I really don't know how to make the rivaFB kernel driver work.
Back to top
maystorm
Apprentice
Apprentice


Joined: 02 Jun 2002
Posts: 212
Location: Germany, not far away

PostPosted: Sat Aug 03, 2002 12:00 pm    Post subject: Reply with quote

Sorry, wouldn't have any idea straight away what could cause the slow-down.

However, you may want to have a look at the nVidia Linux Driver Troubleshooting Guide; worth could be to try the tweak regarding BIOS Repost mentioned in that document.
_________________
Linux user #216018
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum