Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-plugins/gst-plugins-ffmpeg fail to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Raoul
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jul 2006
Posts: 108
Location: Adelaide, Aust.

PostPosted: Thu Dec 08, 2016 5:04 am    Post subject: media-plugins/gst-plugins-ffmpeg fail to emerge Reply with quote

Hi,
This happened today without me consciously changing anything relevant in the system.

emerge --info is here:http://pastebin.com/BrbAqZd4
emerge -pqv is here: http://pastebin.com/rDt1KUKC
build.log is here: http://pastebin.com/yWWUhsJG
make.conf is here: http://pastebin.com/UUw2fLMP

Hoping someone can point out the error of my ways.
Regards
Raoul
_________________
**************
Not all pain is gain.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21345
Location: here

PostPosted: Thu Dec 08, 2016 8:59 am    Post subject: Reply with quote

Bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Raoul
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jul 2006
Posts: 108
Location: Adelaide, Aust.

PostPosted: Tue Dec 13, 2016 9:55 pm    Post subject: Reply with quote

Indeed. Thank you.
This doesn't look like it will be resolved any time soon. I did some further reading and found that there are two versions of gst (0.10 and 1.x) and the 0.10 is no longer under development.
If I do
Code:
equery g gst-plugins-ffmpeg
i get this result:
Code:
* Searching for gst-plugins-ffmpeg ...

 * dependency graph for media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5
 `--  media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5  amd64
   `--  media-libs/gstreamer-0.10.36-r2  (>=media-libs/gstreamer-0.10.36-r2) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  media-libs/gst-plugins-base-0.10.36-r2  (>=media-libs/gst-plugins-base-0.10.36) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  media-video/ffmpeg-3.2.1  (>=media-video/ffmpeg-1.2.6-r1) ~amd64  [postproc abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  media-video/libav-11.8  (>=media-video/libav-11.3) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  media-libs/libpostproc-10.20140517-r1  (>=media-libs/libpostproc-10.20140517-r1) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  dev-lang/orc-0.4.26-r1  (>=dev-lang/orc-0.4.17) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
   `--  virtual/pkgconfig-0-r1  (>=virtual/pkgconfig-0-r1) amd64  [abi_x86_32(-)? abi_x86_64(-)? abi_x86_x32(-)? abi_mips_n32(-)? abi_mips_n64(-)? abi_mips_o32(-)? abi_ppc_32(-)? abi_ppc_64(-)? abi_s390_32(-)? abi_s390_64(-)?]
[ media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r5 stats: packages (8), max depth (1) ]


So, my question is, how can I force my system to use the 1.x version of gst instead?

Regards
Raoul
_________________
**************
Not all pain is gain.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 434
Location: Brazil

PostPosted: Wed Dec 14, 2016 9:40 am    Post subject: Reply with quote

Add it to /etc/portage/package.accept_keywords
Back to top
View user's profile Send private message
Raoul
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jul 2006
Posts: 108
Location: Adelaide, Aust.

PostPosted: Wed Dec 14, 2016 11:09 am    Post subject: Reply with quote

Thanks Saboya,
I'm not sure I understand how to do this in this instance. I have a package.keywords file already. I don't quote see how package.accept_keywords is different and what the actual entry would look like. I would perhaps have thought putting gst-0.10 into package.mask.

Regards
Raoul
_________________
**************
Not all pain is gain.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13504

PostPosted: Thu Dec 15, 2016 3:43 am    Post subject: Reply with quote

package.keywords is the legacy name for the file that is now package.accept_keywords. Both work, but you should migrate to the latter. You can apply the previous advice with your package.keywords file for now.
Back to top
View user's profile Send private message
Wallsandfences
Guru
Guru


Joined: 29 Mar 2010
Posts: 354

PostPosted: Thu Dec 15, 2016 8:18 am    Post subject: Reply with quote

I have the same problem, but masking the gst-package does not lead to emerging a higher version but to portage demanding to unmask it again.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13504

PostPosted: Fri Dec 16, 2016 2:47 am    Post subject: Reply with quote

Why does Portage want to unmask it?
Back to top
View user's profile Send private message
davidbrooke
Guru
Guru


Joined: 03 Jan 2015
Posts: 341

PostPosted: Sat Dec 17, 2016 5:48 am    Post subject: Reply with quote

Raoul wrote:
Thanks Saboya,
I'm not sure I understand how to do this in this instance. I have a package.keywords file already. I don't quote see how package.accept_keywords is different and what the actual entry would look like. I would perhaps have thought putting gst-0.10 into package.mask.

Regards
Raoul

From what I have read so far in this thread....I believe there is a misunderstanding on your part Raoul. There is only one version of media-plugins/gst-plugins-ffmpeg but there are multiple versions of the gst-plugins-meta package. So you choices are:
1. Keep the current media-plugins/gst-plugins-ffmpeg package
2. Remove media-plugins/gst-plugins-ffmpeg package and any packages that depend on it. This is the route I took.
After reviewing the bug report:
https://bugs.gentoo.org/show_bug.cgi?id=575056
The very last entry....The individual downgrades ffmpeg to version 2.8.10 and then removes media-plugins/gst-plugins-ffmpeg.
I did the same as well as removing another package that depended on media-plugins/gst-plugins-ffmpeg then upgraded back to ffmpeg 3.2.2.
Hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum