Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird use flag issue with kde-apps-16.11.90
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 06, 2016 7:59 pm    Post subject: Weird use flag issue with kde-apps-16.11.90 Reply with quote

Currently that upgrade gets blocked on my box with

Code:
emerge: there are no ebuilds to satisfy ">=app-crypt/gpgme-1.7.1[cxx,qt5]".
(dependency required by "kde-apps/libkleo-16.11.90::kde" [ebuild])
(dependency required by "kde-apps/kdepim-apps-libs-16.11.90::kde" [ebuild])
(dependency required by "kde-apps/blogilo-16.11.90::kde" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


However eix gpgme shows that the use flag is available, just for whatever reason not enabled:
Code:
[I] app-crypt/gpgme
     Verfügbare Versionen:   (1) 1.5.5(1/11) (~)1.6.0(1/11) (~)1.8.0-r1(1/11)
       {common-lisp cxx python qt5 static-libs PYTHON_TARGETS="python2_7 python3_4"}
     Installierte Versionen: 1.8.0-r1(1)(00:46:31 05.12.2016)(python -common-lisp -cxx -qt5 -static-libs PYTHON_TARGETS="python2_7 python3_4")
     Startseite:             http://www.gnupg.org/related_software/gpgme
     Beschreibung:           GnuPG Made Easy is a library for making GnuPG easier to use


Which I do not understand, as both cxx and qt5 use flags seem to be globally enabled by kde. I even enabled them manually now in make.conf - no change.

Also "equery hasuse cxx" clearly lists it as available

Code:
* Searching for USE flag cxx ...
[IP-] [  ] app-crypt/gpgme-1.8.0-r1:1/11


while equery u app-crypt/gpgme again sais it is not

Code:
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for app-crypt/gpgme-1.8.0-r1:
 U I
 - - common-lisp              : Install common-lisp files
 + + python                   : Add optional support/bindings for the Python language
 + + python_targets_python2_7 : Build with Python 2.7
 + + python_targets_python3_4 : Build with Python 3.4
 - - static-libs              : Build static versions of dynamic libraries as well


Totally confused now - does anyone know what is going wrong here? Why does portage not install gpgme with cxx and qt5 use flag?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21332
Location: here

PostPosted: Tue Dec 06, 2016 8:12 pm    Post subject: Reply with quote

Use flags cxx and qt5 of gpgme are masked, probably it's the reason because with equery not show these.
Code:
$ emerge -pv =app-crypt/gpgme-1.8.0-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] app-crypt/gpgme-1.8.0-r1:1/11::gentoo  USE="-common-lisp (-cxx) -python (-qt5) -static-libs" PYTHON_TARGETS="python2_7 python3_4" 1'268 KiB

For unmask masked use flag see here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 06, 2016 8:31 pm    Post subject: Reply with quote

Thanks! That is indeed the source of the problem. Something in the profile masks cxx/qt5 for gpgme (where is that masked actually?), but the above (masked) kde-apps requires it.

And I have unmasked kde-apps, so that is what I get for that. Rather complex this masking of use flags. I haven't run into it yet.

Lets see if it works out now that I unmasked it in /etc/portage/profile/use.mask. gpgme did compile, now the global update...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Dec 06, 2016 8:53 pm    Post subject: Reply with quote

It is masked because the USE flags currently break dependency resolution with kdepimlibs:4 installed. When KDE PIM:5 will be unmasked, gpgme[cxx] can be as well. And that is currently waiting for Qt-5.7.1 to arrive...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 06, 2016 10:06 pm    Post subject: Reply with quote

I see. I anyway do not have kdepimlibs installed, so no problem then, if I unmask it.

The 16.11.90 does create some crossdependency and blocker hell again however:
Code:
[ebuild     U #] kde-apps/kde-apps-meta-16.11.90:5::kde [16.08.3:5::kde] USE="-accessibility -pim -sdk" 0 KiB
[blocks B      ] kde-apps/gpgmepp:4 ("kde-apps/gpgmepp:4" is blocking app-crypt/gpgme-1.8.0-r1)
[blocks B      ] kde-apps/gpgmepp:5 ("kde-apps/gpgmepp:5" is blocking kde-apps/kleopatra-16.11.90)


It seems gpgmepp has fallen out of favour and is beeing blocked by 16.11.90 (kleopatra needs to be installed obviously, so gpgmepp has to go).

This again the kde-framework does not seem to like
Quote:
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(kde-apps/kleopatra-16.11.90:5/5::kde, ebuild scheduled for merge) pulled in by
>=kde-apps/kleopatra-16.11.90 required by (kde-apps/kdepim-meta-16.11.90:5/5::kde, ebuild scheduled for merge)

(kde-apps/gpgmepp-4.14.11_pre20160211:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
>=kde-apps/gpgmepp-4.14.3:4[aqua=] (>=kde-apps/gpgmepp-4.14.3:4[-aqua]) required by (kde-apps/kget-16.11.90:4/16.11::kde, ebuild scheduled for merge)

(kde-apps/gpgmepp-16.08.3:5/5::gentoo, ebuild scheduled for merge) pulled in by
>=kde-apps/gpgmepp-14.12.0:5 required by (kde-frameworks/kwallet-5.28.0:5/5.28::gentoo, installed)

(app-crypt/gpgme-1.8.0-r1:1/11::gentoo, installed) pulled in by
app-crypt/gpgme required by (kde-frameworks/kwallet-5.28.0:5/5.28::gentoo, installed)


Seems like kde-framework-5.28.0 does insist on gpgmepp to be installed. I wonder how I solve that mess now again...
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 06, 2016 10:47 pm    Post subject: Reply with quote

Quote:
Seems like kde-framework-5.28.0 does insist on gpgmepp to be installed. I wonder how I solve that mess now again...


The answer seems to be disabling gpg use flag both for kwallet-5.28.0 and kget:4. Both require gpgmepp otherwise.

kwallet stops requiring this from 5.28.0-r1 (currently masked), so no problem dropping this for now, as soon as kde-framework-5.29 becomes ~amd64 this use flag will reenable.

More annoying is kget, where slot 5 version is only available as git-master version. I avoid these versions, as they give too many compile errors.

For some time to go kde-apps-16.11.90 isn't compatible with gpg use flag unless one is willing to install git-master .9999 versions. Hmmm, not so ideal.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Wed Dec 07, 2016 2:33 am    Post subject: Reply with quote

mas- wrote:
kwallet stops requiring this from 5.28.0-r1 (currently masked)

That's exactly why it exists, just unmask kwallet-5.28.0-r1

mas- wrote:
More annoying is kget, where slot 5 version is only available as git-master version. I avoid these versions, as they give too many compile errors.

That's why kget is no longer installed by meta packages.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Fri Dec 09, 2016 7:53 pm    Post subject: Reply with quote

Perfect, now I just gotta find out what pulls in kget. I did not explicilty merge it.

Might be a good idea if masked USE flags (flag) trigger a warning text at least when verbose is selected. I have a feeling these parentheses are not so well known...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Fri Dec 09, 2016 8:00 pm    Post subject: Reply with quote

Meh, I was wrong with that. It still is being pulled in ;) The best course of action would probably be to remove the flag entirely from >=kget-16.11.90 to allow it to still be used while hopefully being ported for 17.04.

EDIT: Fixed in kde overlay.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 13, 2016 7:49 pm    Post subject: Reply with quote

Quote:
mas- hat Folgendes geschrieben:
kwallet stops requiring this from 5.28.0-r1 (currently masked)

That's exactly why it exists, just unmask kwallet-5.28.0-r1


Stupidly kwallet-5.29.0 does again revert to requiring the depreciated gpgmepp for the gpg use flag!

If 5.28.0-r1 does not require this, I had somehow expected the 5.29.0 to also not require obsolete packages...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Dec 13, 2016 9:10 pm    Post subject: Reply with quote

That's why there is kwallet-5.29.0-r1...

You can't make ~arch kwallet depend on gpgme as long as it is masked...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 213

PostPosted: Tue Dec 13, 2016 10:21 pm    Post subject: Reply with quote

Quote:
That's why there is kwallet-5.29.0-r1...

You can't make ~arch kwallet depend on gpgme as long as it is masked...


Ok thanks, I simply do not understand these complex interdependencies. This also means that for a while to come there will be dual packages for kwallet - 5.xx.0 requiring gpgmepp and hardmasked 5.xx.0-r1 using gpgme(cxx,qt5).

I had unmasked 5.28.0-r1 and was hit again for 5.29.0-r1. Now I unmasked the whole kwallet package and hope there won't be a fancy kwallet-5.31.7 (M) pulling in other masked kde-framework versions...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Wed Dec 14, 2016 8:21 am    Post subject: Reply with quote

Gotta stay alert with unmasked packages, that's just how it is. I suspect that 5.29 will be the last version needing KF5Gpgmepp support.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Tue Dec 20, 2016 7:25 pm    Post subject: Reply with quote

Seeing this on ~amd64, no KDE overlay currently:

Code:

fPIC -std=gnu++11 -o CMakeFiles/kleopatra_bin.dir/view/keytreeview.cpp.o -c /var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0/src/view/keytreeview.cpp
/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0/src/selftest/gpgagentcheck.cpp: In member function ‘void {anonymous}::GpgAgentCheck::runTest()’:
/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0/src/selftest/gpgagentcheck.cpp:103:74: error: invalid use of incomplete type ‘class GpgME::AssuanResult’
                 const Error error = ctx->assuanTransact("GETINFO version");
                                                                          ^
In file included from /var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0/src/selftest/gpgagentcheck.cpp:41:0:
/usr/include/KF5/gpgme++/context.h:49:7: note: forward declaration of ‘class GpgME::AssuanResult’
 class AssuanResult;
       ^


Code:

fPIC -std=gnu++11 -o CMakeFiles/kleopatra_bin.dir/view/searchbar.cpp.o -c /var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0/src/view/searchbar.cpp
make[2]: *** [src/CMakeFiles/kleopatra_bin.dir/build.make:796: src/CMakeFiles/kleopatra_bin.dir/selftest/gpgagentcheck.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0_build'
make[1]: *** [CMakeFiles/Makefile2:184: src/CMakeFiles/kleopatra_bin.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0_build'
make: *** [Makefile:128: all] Error 2
 * ERROR: kde-apps/kleopatra-16.12.0::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=kde-apps/kleopatra-16.12.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=kde-apps/kleopatra-16.12.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/kde-apps/kleopatra-16.12.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-apps/kleopatra-16.12.0/temp/environment'.
 * Working directory: '/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0_build'
 * S: '/var/tmp/portage/kde-apps/kleopatra-16.12.0/work/kleopatra-16.12.0'

>>> Failed to emerge kde-apps/kleopatra-16.12.0, Log file:

>>>  '/var/tmp/portage/kde-apps/kleopatra-16.12.0/temp/build.log'



Code:


[I] app-crypt/gpgme
     Available versions:  (1) 1.5.5(1/11){tbz2} (~)1.6.0(1/11) (~)1.8.0-r1(1/11)
       {common-lisp cxx python qt5 static-libs PYTHON_TARGETS="python2_7 python3_4"}
     Installed versions:  1.8.0-r1(1)(10:04:37 PM 12/19/2016)(cxx qt5 -common-lisp -python -static-libs PYTHON_TARGETS="python2_7 python3_4")


Code:
[I] kde-frameworks/kwallet
     Available versions:  (5) 5.26.0(5/5.26) (~)5.29.0(5/5.29) (~)5.29.0-r1(5/5.29)
       {debug gpg +man test}
     Installed versions:  5.29.0-r1(5)(07:05:18 PM 12/19/2016)(man -debug -gpg -test)
     Homepage:            https://www.kde.org/
     Description:         Framework providing desktop-wide storage for pas


Looks related to the gpgme mess?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6824
Location: Austria

PostPosted: Tue Dec 20, 2016 8:07 pm    Post subject: Reply with quote

Remove kde-apps/gpgmepp

https://bugs.gentoo.org/show_bug.cgi?id=602924
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 557
Location: US

PostPosted: Tue Dec 20, 2016 9:10 pm    Post subject: Reply with quote

asturm wrote:
Remove kde-apps/gpgmepp

https://bugs.gentoo.org/show_bug.cgi?id=602924

Thanks, that fixed it!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum